Just nu i M3-nätverket
Jump to content

Returnera flera rader givet ett visst värde i Excel


Tagetar
 Share

Recommended Posts

Hej,

Jag har ett blad med givna värden t.ex:

Artikel Färg Leverans S M L XL
A Vit 2022-02-01 5 10 10 5
A Svart 2022-02-01 5 10 10 5
A Svart 2022-03-01 10 20 20 10
B Vit 2022-02-01 5 10 10 5
B Vit 2022-03-01 5 10 10 5
AB Vit 2022-02-01 5 10 10 5
AB Svart 2022-02-01 5 10 10 5

 

Jag skapar en cell med en Dropdown med värdena i "Artikel" för att inte få ett värde per rad använder jag funktionen UNIK.

Problem 1: Denna genererar ett värde "0" iom att formeln går från raden under "Artikel" och väldigt många rader ner då jag vill fortsätta fylla på artiklar här. Hur kan jag skriva den formeln så att den visar värdena <>0?

 

När jag sedan i Dropdownmenyn väljer ett värde, säg "A" så vill jag att den automatiskt ska presentera värdena i de 3 första raderna i givna celler. Målet är att välja en artikel och direkt kunna skriva ut en pdf av detta, sen ta nästa artikel och göra samma sak.

 

Jag hittade en gammal tråd här som förslog en lösning som denna.

Skapa en namngiven formel med nedan funktion och döp den till UNIK

"=OM(ÄRFEL(SÖK(Dropdownmeny;Artikelkolumn));RADER(Artikelkolumn)+1;OM(SÖK(Dropdownmeny;Artikelkolumn)=1;RAD(Artikelkolumn);RADER(Artikelkolumn+1)))"

"=MINSTA(Unik;RAD()-RAD($E$2))" Denna letar upp de rader som innehåller värdet som visas i Dropdownmeny och returnerar från minsta till största raden. Problemet med denna är att den returnerar både A och AB om valet bara är A. Samt att detta gjorde filen ganska trög. Går det att göra den första formeln som innehåller SÖK till att bara visa exakta matchningar?

 

Bytte till att hitta alla rader 

=OM(Dropdownmeny=Artikel2;RAD(Artikel2))

Sen sortera im den med hjälp av MINSTA.

Då vet jag vilka rader allt finns på och använder mig av funktionen FÖRSKJUTNING för att hitta rätt celler som ska returneras.

Detta är väl en bra lösning, men den kräver ganska mycket manuell hantering då FÖRSKJUTNING inte är så dynamiskt vid förändringar i indatan (kolumner).

Med denna lösning krävs dock att jag har flera rader preparerade med formeln då beroende på vilket val jag gör i Dropdownmenyn så blir resultatet olika antal rader.

Väljer jag A blir det 3 rader, väljer jag B blir det 2 rader samt att jag får en rad med ### då det inte finns mer att visa. Jag skulle vilja att dessa rader försvinner automatiskt.

 

Då hittade jag funktionen FILTER som skapar antalet rader beroende på antalet matchningar som blir. Kanon tänker jag! Men, för att skapa en tydlig PDF behöver varje cell omringas av kantlinjer, kan jag ställa in så att det automatiskt genereras kantlinjer runt alla celler med denna funktion?

 

 

Link to comment
Share on other sites

Kombinera unik och filter för att slippa 0-orna

=UNIK(FILTER(A2:A20;A2:A20<>""))

Obs att du inte kan köra formeln direkt i Dataverifiering->lista

 

En variant är att skapa din lista med hjälp av formeln ovan, t.ex i cell Q1. Sen skapar du ett namngivet område som ändrar storlek beroende på hur lång listan är.

Skapa ett namngivet område

Öppna namnhanteraren genom att trycka

tryck Ctrl+[F3]  -> [Nytt...]

Kalla området MinLista

och i "Refererar till" klistrar du in den här formeln

=INDEX(Blad1!$Q:$Q;1):INDEX(Blad1!$Q:$Q;ANTALV(Blad1!$Q:$Q))

 

Gå till

Dataverifiering->lista 

och i källa skriver du:

=MinLista

 

******Fråga 2 ************

antag att din DropDown står i cell N1. Då tar den här formeln fram alla träffar

=FILTER(A2:G20;A2:A20=N1)

Om du bara vill ha de tre första raderna så kan du ange det med hjälp av  Index och SEKVENS, men då måste du även ange att du vill ha 7 kolumner (obs att det är ett extra semikolon före 7:an i SEKVENS för kolumn)

=INDEX(FILTER(A2:G20;A2:A20=N1);SEKVENS(3);SEKVENS(;7))

Link to comment
Share on other sites

Jag ändrar mig angående den sista formeln. För att hantera fall när det finns mindre än Tre träffar: 

=INDEX(FILTER(A:G;A:A=N1);SEKVENS(MIN(3;ANTAL.OM(A:A;N1)));SEKVENS(;7))

 

**ED***

Nu ser jag dessutom att du tagit upp det problemet. Men tyvärr har Eforum problem med allt som flyter idag. Både annonser  och "ebesvarade ämnen" täcker din text 😞

*****

 

Och nu kan jag inte logga ut eftersom det ligger en Dell-annons precis där....

Edited by MH_
gndlsanroern
Link to comment
Share on other sites

Den sista formeln gjorde susen, tack så mycket.

Dock upplever jag att den gör hela arbetsboken segar ner, så fort jag gör en inmatning så börjar den beräkna trådar.

Link to comment
Share on other sites

Det känns som att allt segade ner om jag rensade värdena för att använda den som en mall, löste det genom att alltid lägga ett exempelvärde i. Då verkar det som att den inte behöver "beräkna trådar" vid nya inmatningar.

 

Stort tack för hjälpen!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...