Just nu i M3-nätverket
Jump to content

Färglägga "Gröna korset" per automatik


Emilb
 Share

Recommended Posts

Hej,

 

Jag har en kalender som jag vill färglägga om värde hittas i en tabell. Förmodar att det är ett villkorstyrd formatering jag ska använda.

Värdena (kan vara flera) ska kopplas till datum i tabellen som i sin tur ska hitta värdet i kalendern och färglägga det. :)

Någon som kan hjälpa mig?

 

Vänliga hälsningar 

Dan Ågren

 

Gröna korset.xlsx

 

Gröna korset.xlsx

Link to comment
Share on other sites

Är det tabell3 i "Form" som är tabellen?

 

Då kan du göra något slags Letarad och kolla vilken färgkod du får tillbaks

=LETARAD(E5;Tabell3;3;FALSKT)="gul"

eller, eftersom villkorsstyrd formatering verkar ogilla tabeller:

=LETARAD(E5;Form!$A:$C;3;FALSKT)="gul"

Och ha som villkorsstyrd formatering med resultatet Gul-bakgrundsfärg som resultat.

Gör samma sak för de andra färgerna

=LETARAD(E5;Form!$A:$C;3;FALSKT)="gul"

=LETARAD(E5;Form!$A:$C;3;FALSKT)="grön"

=LETARAD(E5;Form!$A:$C;3;FALSKT)="orange"

=LETARAD(E5;Form!$A:$C;3;FALSKT)="röd"

Utöka till hela korset
 

Se bifogat

korset_eforum.xlsx

Link to comment
Share on other sites

Tack snälla!  

Jag ser mitt eget problem, färgerna måste graderas , för om det finns olika färger på samma dag så ska exempelvis röd gå före orange etc.

 

Tror det blir vba-kod, då jag inte får installera python på jobbdatorn. (nybörjare)

 

Har aldrig kodat i vba tidigare men kan jag få några tips?

 

Det jag vill är följande:

1. Korset som består av månadens datum ska loppas och leta upp lika datum i tabell

2. Den ska sedan leta upp färgkoden och färglägga utifrån de färggraderingar som är satta

3. Om inget värde matchas ska korsets cell färgas grön.

Likt villkord styrning så vill jag att när jag ändrar år/månad så ska koden starta.

 

Vänliga hälsningar

Dan

Link to comment
Share on other sites

Om en regel ska viktas före de andra, bara att sortera dem i ordning.

 

De körs uppifrån och ned, lägg grön sist så blir det den som vinner om formeln där slår in.

Alternativt sortera dem med viktigaste först och bocka i "Avbryt om Sant".

 

bild.png.2965a7027fa5a3eb9b440dc8dcd4887d.png
 

Link to comment
Share on other sites

Är så tacksam!

Ni har sparat mig många timmar av kodning 😃

 

Mvh

Dan

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...