Just nu i M3-nätverket
Jump to content

Beräkna summa med IF villkor


Dreas
 Share

Recommended Posts

Hej

 

Jag har fastnat på en formelberäkning.

Kort och gott så ska följande beräknas. (se bifogad fil för exempel)

I kolumn H visas aktuellt +/- saldo av tid på en vecka utifrån aktuell beläggning.

Jag skulle vilja få till att de eventuella minustimmar i H som uppstår från vecka 1 och nedåt läggs till i G kolumnen under.

Men om inget minus finns i H i raden ovanför så ska beräkningen i G undanta att beräkna med H kolumnen.

För idag väntar man tills veckan är slut innan minustimmarna flyttas till veckan under. Att få med dem redan innan skulle underlätta att se ev överbeläggning framförvarande veckor.

Vad ska skrivas i G kolumnen för att få till det?

exempel.xlsx

Link to comment
Share on other sites

Ove Söderlund

Det du gör är att kolla om H2<0 och så är fallet ska du addera absoluttalet (dvs göra om ett negativt tal till positivt) i H2 till de timmar du summerar i B3:D3. Är värdet i H2 så är det bara summan B3:D3 som beräknas.

 

Lägg in denna formel i G3 och autofyll/kopiera nedåt.

 

=OM(H2<0;SUMMA(B3:D3)+ABS(H2);SUMMA(B3:D3))

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...