Just nu i M3-nätverket
Jump to content

BT ansluten för samtal och ljud?


Mikael63
 Share

Recommended Posts

Mikael63

I en av mina andra trådar lekte jag med tanken att via bluetooth ansluta en mobiltelefon till en Raspberry Pi 4B för att den skulle kunna spela upp ljud via sin audio-utgång.

Detta fungerade på direkten - "ansluten för samtal och ljud" - och ljudet funkade via utgången, jag kunde även justera volymen med mobilens knappar.

Men inga fler gånger. Ansluter bara för samtal. Slidern för ljud är gråad men går att flytta till läget "på" men förblir utgråat. Ljudet skickas enbart via telefonens högtalare.  Jag hittar ingenstans i telefonens inställningar (S21) hur man kan välja ljudutgång. När man etablerat ett telefonsamtal kan man ändra men när man ex. spelar nåt från Youtube?

Jag la ner den tanken men fick ett infall att testa samma sak på min MintBox och där sker anslutningen "för samtal och ljud", även vid upprepade försök.

 

Vad är det som styr detta egentligen? Det verkar vara klent med inställningar för just bluetooth.

 

Link to comment
Share on other sites

Jag har för mig att BT fungerar så att när man ansluter så pratar BT-chip med varandra, och så väljer dom vilka funktioner som är ok att använda. Men när du säger att det gick en gång så undrar jag om det inte är så att det är programvara som väljer vilka funktioner det är.

 

Så jag undrar om det är programvaran i din Raspberry som gör fel, kan du återställa drivrutinen för BT i raspberry och se om du kan återskapa att det fungerar? Då är det antagligen något i programvaran på din paj.

Link to comment
Share on other sites

Mikael63

Jag använde ingen särskild programvara, bekräftade bara parningen. Så fungerade det på direkten. När jag prövade lite senare med utrustningen på "rätt" plats fungerade det också bra, sedan en gång där det lät förskräckligt för att sedan en gång senare låta bra. Nästa dag skulle två Appleprodukter anslutas - gick inte alls. Efter det fungerade det inte med min lur heller. Då använde jag Ubuntu MATE Groovy Gorilla 64-bit som OS. Har bytt det till "original" Raspberry Pi OS.

Etablera kontakt fungerar bra. I min Mintbox har jag Linux Mint och där lirar det direkt med "ljud".

 

Egentligen inte så viktigt med att få till detta, nu är det mera att förstå "mekaniken" bakom.

 

Link to comment
Share on other sites

Mikael63

Installerade en "extra" Bluetooth manager och kunde då få fram ett felmeddelande, googlade, hittade lösning, fick annat felmeddelande, googlade, hittade flera träffar som bekräftar bugg.

Skippar detta.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...