Just nu i M3-nätverket
Gå till innehåll
M a t t

Automatiskt ändra del av cellnamn i Excel

Rekommendera Poster

M a t t

Hej

Finna det något smidigt sätt att markera celler eller ändra vilka celler som markerats.

Tex formeln SUMMA(J33:S35).

Vid annat tillfälle då jag använder dokumentet så vill jag att formeln ska beräkna SUMMA(H33:S34). Jag har fetmarkerat ändringarna i formeln.

Går det att tex ersätta bokstaven i formeln SUMMA(J33:S35) med en referens från tex cell A1 där jag skriver in en en bokstav, ex H? Eller för den delen ersätta siffrorna på liknande sätt, Där en siffra, ex 34, kan fyllas i i A2

Som exempelvis formeln nedan

SUMMA((A1)33:S(A2))

 

Idag så ändrar jag mina markeringar "för hand" och det tar lite väl mycket tid...

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MH_
Postad (redigerade)

Ja. Det finns faktiskt ett par olika sätt.

1a.)  Klistra ihop din adress med hjälp av t.ex Sammanfoga. Sen använder du INDREKT som bara berättar för excel att din ihopklistrade text är en adress 

https://support.microsoft.com/sv-se/office/indirekt-funktionen-indirekt-474b3a3a-8a26-4f44-b491-92b6306fa261

 

Så, för att få din önskade formel:

SUMMA((A1)33:S(A2))

Börjar du med att slå ihop alla texter till en adress:

=SAMMANFOGA(A1;"33:S";A2)

Berätta sedan för excel att det är en adress till ett område:

=INDIREKT(SAMMANFOGA(A1;"33:S";A2))

och summera

=SUMMA(INDIREKT(SAMMANFOGA(A1;"33:S";A2)))

Eller så här om du vill ha det lite mer generiskt

=SUMMA(INDIREKT(SAMMANFOGA(A1;"33";":";"S";A2)))

 

1b.)  Själva adressklistrandet kan du göra på flera sätt. Istället för "sammanfoga" så kan du använda &-tecknet

Dvs istället för:

=SUMMA((A1)33:S(A2))

Kan du använda

=A1&"33:S"&A2

om du tycker att det är smidigare

 

2.) Förskjutning

Förskjutning är en helt annan metod. Då anger du en förankringspunkt (tex J33). Sen kan du förskjuta området upp/ner och sidledes + bestämma hur stort det skall vara.

Den här formeln:

=FÖRSKJUTNING(J33;0;-1;5;4)

pekar t.ex på område

I33:L37

 

Fördelen för dig är att 0,-1,5,4 lika gärna kan stå i celler som du hänvisar till. Typ:

=SUMMA(FÖRSKJUTNING(J33;A1;A2;A3;A4))

 

https://support.microsoft.com/sv-se/office/förskjutning-funktionen-förskjutning-c8de19ae-dd79-4b9b-a14e-b4d906d11b66

Redigerad av MH_
Covfefe

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
M a t t

Tack!

Alternativet med förskjutning får jag att fungera bra 🙂

 

Men jag får problem när jag vill summera en förskjutning med ett OM villkor.

SUMMA.OM(F7;"A";FÖRSKJUTNING(H7;0;7;1;12))

Den returnerar då bara första värdet i cellen O7 och inte summan av området O7:Z7

 

Vad gör jag för fel?

 

Mvh

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MH_

i SUMMA.OM så måste du ha två områden. Det du söker i och det du returnerar. Nu kollar den bara i cellen F7, inte området som motsvarar FÖRSKJUTNING(H7;0;7;1;12)

 

Så om du verkligen vill ha en summa.om (dvs summera H-kolumnen  när F-kolumnen är lika med "A")

=SUMMA.OM(FÖRSKJUTNING(F7;0;7;1;12);"A";FÖRSKJUTNING(H7;0;7;1;12))

Eller, om det bara vill kolla i F7 och inget annat

=OM(F7;"A";summa(FÖRSKJUTNING(H7;0;7;1;12)))

(obs inte testat,  mest ett förslag på hur du bör tänka. kolla själv.)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
M a t t

Tack, ska prova.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...