Just nu i M3-nätverket
Jump to content

SummaOm att skilja på versaler, gemener


Martassen
 Share

Recommended Posts

Hur gör man så SummaOm skiljer på versaler och gemener?

Är det samma stuk om man använder Letarad och vill att den ska skilja på Sand och sand?

Låt säga följande SummaOm där N11 är en dynamisk cell som man kan skriva Sand  och sand och den ska tolka de som olika. Ja ibland kanske det är konstant med "Sand" och "sand" i formeln exempelvis.
=SUMMA.OM(J12:J17;N11;L12:L17). Jag gissar på att det ska kombineras med Versaler och gemener i formeln?

Edited by Martassen
Link to comment
Share on other sites

Summa.om skiljer inte på gemener och versaler.

VERSALER() och/eller GEMENER()  används tvärsom. Dvs när du vill att en Shift-känslig funktion skall bli Okänslig (gemener("Summa")=gemener("SUMmA") eftersom det blir  summa=summa)

 

Du vill istället använda någon skiftkänslig funktion. T.ex EXAKT()  som kollar om texten i två celler är exakt lika

Dvs på något sätt använda:

EXAKT(J12:J17;N11)

T.ex i en Produktsumma:

=PRODUKTSUMMA(EXAKT(J12:J17;N11)*L12:L17)

Link to comment
Share on other sites

Eller är filter tydligare? Förstår man filter så kan man nästan strunta i alla ".om" formler

=SUMMA(FILTER(L12:L17;EXAKT(J12:J17;N11)))

 

Link to comment
Share on other sites

Ja precis. Det är ju toppen! Båda fungerar.

 

Hur ser det ut om man vill att letarad ska tolka Sand och sand som 2 olika?

 

Det är ju samma sak om man använder Antal.Om(Område;"Sand") och att den då ska räkna antal Sand men inte sand (med små bokstäver).

Edited by Martassen
Link to comment
Share on other sites

7 minuter sedan, skrev Martassen:

Det är ju samma sak om man använder Antal.Om(Område;"Sand") och att den då ska räkna antal Sand men inte sand (med små bokstäver).

Det är ju charmen med filtervarianten. När man har 

=SUMMA(FILTER(L12:L17;EXAKT(J12:J17;"Sand")))

så kan man bar byta ut SUMMA mot antal 

=ANTAL(FILTER(L12:L17;EXAKT(J12:J17;"Sand")))

Även om det är onödigt krångligt så går supersnabbt att ändra

Det här är kortare/snyggare, men är det lika lätt att förstå som filtervarianten? 

=SUMMA(EXAKT(J12:J17;"Sand")*1)

 

 

25 minuter sedan, skrev Martassen:

Hur ser det ut om man vill att letarad ska tolka Sand och sand som 2 olika?

Samma sak där. Man kan inte använda Letarad. Antingen gör du en passa/index

=INDEX(L12:L17;PASSA(SANT;EXAKT(J12:J17;"Sand");0))

Eller kör med min älskade FIlter

=FILTER(L12:L17;EXAKT(J12:J17;"Sand"))

Möjligen kombinerat med Index om du vill vara säker på att bara få ut en träff

=INDEX(FILTER(L12:L17;EXAKT(J12:J17;"Sand"));1)

Link to comment
Share on other sites

Följande formel funkar om räkna antalet "Sand" och skilja på versaler gemener:
=SUMMA(EXAKT(Område;"Sand")*1)

Går det även använda funktionen Filter här? Om den ska utgå ifrån ett område som Antalom(område,”sand”)

 

Gällande Letarad:
Låt säga man har =LETARAD(E2;E7:G13;3;0)
I E2 ska man kunna skriva Pia och ibland pia och den ska tolka det som 2 olika namn.
Provade index men får inte till det riktigt.

Edited by Martassen
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...