Just nu i M3-nätverket
Gå till innehåll
Mikael63

udisks-error-quark, 0

Rekommendera Poster

Mikael63
Postad (redigerade)

Har sedan länge en, i mitt tycke, snabb och pålitlig USB-disk, Lacie by Porsche design.

Denna disk fungerar UA i Linux Mint. Programmet GParted menar dock, som jag väl skrivit annan tråd, att hela diskutrymmet är oallokerat men GParted är i mitt tycke överskattat.

I Windows har det bråkats om att "disken behöver formateras" men har fungerat som den ska. Tog, efter problemet nedan, och körde chkdsk /f på den och några fel hittades och reparerades. Inga kvarstående fel.

 

Denna disk har jag, liksom några andra anslutit till Raspberry Pi med Raspberry PI OS (eg. Debian Buster).

Har där två problem med denna disk, möjligen hänger de ihop:

 

Bilden nedan visar att disken är monterad men när jag försöker avmontera den får jag dialogen infälld i den större bilden, att den inte går att avmontera eftersom den inte är monterad. Varför blir det så?

 

Bilden visar också att den är monterad på /media/pi/Porsche1 vilket även filhanteraren Double Commander tycker.

Filhanteraren Nautilus tycker att den mer riktigt är monterad på /media/pi/Porsche.

Filhanteraren PCMan verkar inte ha riktig koll, se bild längre ner.

 

Vad är det som har hänt egentligen?

 

 

image.thumb.png.a2149f7a29161edac19bdf458c75f9ff.png

 

PCMan:

 

image.png.4c4cd2552ffd6ceebdf67730001f13d8.png

 

 

TILLÄGG:

Det var något med programmet Resilio som hade orsakat detta och efter avinstallation och en del meckande lyckades jag ta bort problemet men jag vet fortfarande inte vad som egentligen hade hänt.

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Automan
3 timmar sedan, skrev Mikael63:

Bilden nedan visar att disken är monterad men när jag försöker avmontera den får jag dialogen infälld i den större bilden, att den inte går att avmontera eftersom den inte är monterad. Varför blir det så?

I den övre bilden står det att disken är monterad på /media/pi/Porsche1

 

3 timmar sedan, skrev Mikael63:

Filhanteraren Nautilus tycker att den mer riktigt är monterad på /media/pi/Porsche.

Nu gissar jag bara, men om du försöker avmontera från /media/pi/Porsche1 och OS:et tycker att disken är monterad på /media/pi/Porsche då blir något fel

Blir det någon skillnad om du testar att avmontera från terminalen med någon av sökvägarna. T.ex.

 

sudo umount /media/pi/Porsche

Samt

 

sudo umount /media/pi/Porsche1

En av dem bör ge felmeddelande, medan den andra borde gå igenom utan något fel. Har dock inget bra svar på varför detta inträffar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Nu har jag ju lyckats städa bort det knepiga så jag kan inte testa mer men ovanstående sätt att avmontera fungerade inte.

Har ställt en fråga till Resilios support om det är något att beakta när/om man använder en extern disk.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...