Just nu i M3-nätverket
Gå till innehåll
Mikael63

[ändrad] Något stör USB-enheter

Rekommendera Poster

Mikael63
Postad (redigerade)

Jag har, här hemma, för tråden relevant utrustning följande:

Bärbar dator med Windows 10.

Dator med Linux Mint.

Blåtandhögtalare KS BoomCube (nedan bara kallad KS)

Datormus Logitech G602 med "dongle" 500 Hz

Datormus 3M med "dongle"

USB-switch som jag växlar 2 x datormus + tangentbord mellan ovanstående datorer. (Båda mössen växlas alltså)

 

Om jag ansluter KS till Windows får jag med G602 störningar i form av hack + att markören kan "försvinna". 3M fungerar fortsatt bra.

Detta i Windowsmiljö. Med KS (fortfarande) ansluten till Windows får jag med GS602 inga störningar i Mint.

Om jag ansluter KS till Mint får jag inga störningar varken i Windows eller i Mint.

 

Vad jag vet har det inte alltid varit på detta sätt och det är väl inte värre än att jag struntar i att ansluta KS till Windows men lite irriterande problem ändå.

 Vad kan detta bero på? 

 

 

 

 

(oklart var denna tråd hör hemma..)

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Dom sänder väl på likartad frekvens och även om det inte är problem med just den ena just då så kanske det hänger ihop i alla fall?

Alla enheter som kommunicerar trådlöst, däribland Bluetooth, som använder radiofrekvenser för att ansluta till varandra är känsliga för elektromagnetisk störning.

För många Bluetooth-anslutningar samtidigt igång tex. headset och överföra bilder från Bluetooth-ansluten kamera, samt Bluetooth-mus och det kan bli problem.

 

Prova att flytta högtalaren några deci åt något håll.

Du kan minimera den elektromagnetiska störningen genom att flytta andra enheter från området.

 

Finns det någon funktion i programvaran Logitech > Options som heter FLOW?

Det tillåter vissa nya möss och tangentbord att flytta musmarkören och därmed även filer mellan två olika datorer. FLOW möjliggör att kunna styra två datorer samtidigt, med samma mus och tangentbord, som en mjukvarubaserad kvm-switch, som går över bluetooth.

Prova i så fall att stänga av detta eftersom det har du nog bara i Windows och inte i Mint?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf

Jag fösöker se kopplingen bilden framför mig . (USB-switch!? ) en bild skull under lätta hur kopplingen se ut.

 

switch kan vara manuell eller automatisk,  

Vilken ordning parkoplingen sker har även lite betydelse.  

Parkoppla jag mina hörlura först,  så fungera det ok, kommer mus eller fjärr kontroll inna hörlura, då funger  inte hörlura alla gånger

 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
3 timmar sedan, skrev Flyfisherman:

Prova att flytta högtalaren några deci åt något håll.

Det har jag prövat, både en meter ifrån och även en placering där inte musen hamnar mellan Windowsdatorn och högtalaren utan skillnad.

 

3 timmar sedan, skrev Flyfisherman:

Finns det någon funktion i programvaran Logitech > Options som heter FLOW?

Har ingen mjukvara alls som det verkar (funderar på var jag konfade så att knapp G5 ska vara lika som klick på skrollhjulet)

 

4 timmar sedan, skrev Mikael63:

Vad jag vet har det inte alltid varit på detta sätt

Nä, det kom nog troligen i samband med att jag lånade ut min dockningsstation.

Jag har nu bytt plats på USB-kabeln till USB-switchen så att den sitter på vänster sida av datorn och det tycks hjälpa. Återstår att se om det blir störningar i mitt USB-headset då som fick en plats till höger på datorn...

**

 

41 minuter sedan, skrev Stafstaf:

switch kan vara manuell eller automatisk

Det är en manuell.

42 minuter sedan, skrev Stafstaf:

Vilken ordning parkoplingen sker har även lite betydelse

Det är bara frågan om en (1) enhet som parkopplas.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Problemet är inte löst och rubriken är nu ändrad.

Fick massiva störningar nu igen. Musen beter sig ungefär som när batteriet håller på att ta slut. Denna gång även den andra musen och även tangentbordet fick spunk, levde sitt eget liv.

Blåtand avstängd.

Bytte USB-port för möss/tgb och nu verkar det lira igen.

Finns ett troligt samband: Jag växlade USB med min USB-switch strax före detta började men den switchen använder jag väldigt ofta och borde då ha märkt detta oftare. Detta med tangentbordet har hänt EN gång tidigare och då såg jag inte kopplingen.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf

All respekt för dina kunslaper 

Jag bad tidigare 

Om en bild på usb Swich 

Om det går ta även blid allt har kopplingar göra som ligger bordet 

 

Jag få ingen blid hur det problem bygger på .

Tack i förhand 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Det är en https://www.aten.com/eu/en/products/usb-&-thunderbolt/peripheral-switches/us224/ jag har och till den är tangentbord, dongle för G602 och dongle för 3M ansluten.

Kablaget på skrivbordet ligger på exakt samma ställe när jag har störningar som när jag inte har störningar.

När jag byter USB-port så är det i Windowsdatorn jag gör det.

Om det skulle vara fel i ATEN 224 skulle felet då följa med till den "nya" porten men så tycks inte ske.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf

Tack för länk och bilden 

Så flyttar alltså,  sladen mellan pc och Linux  om jag föstår rätt .  

Dom andra sakerna sitter i Swich? 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Nej, jag byter port i Windowsdatorn bara när det krånglar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Helkasst av Windows 10 att inte kunna hantera en USB-switch längre då det fungerat bra sedan i fjol sommar 😠

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf
7 minuter sedan, skrev Mikael63:

Helkasst av Windows 10 att inte kunna hantera en USB-switch längre då det fungerat bra sedan i fjol sommar 😠

 

Det kan var mjukvaro fel. Windows 10

Nä tror jag inte på !

Det vanliga är blir glapp i någon stans!

Eller kabel brott!

 

USB kontakter är känsliga produkter

Jag har minst fem usb kontakter till min moblier som hel kass i usb port  vickar man på kotakt så fungera det 

 

Hur ska kunna kolla om port är sönder eller på väg .. 

Usb sticka brukar fungera som hjälp 

En med lampa på ..lyser  ljus på den är port ok .. är glapp så binkar den då och då 

 

Jag prova swtich i någon annas dator 

 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
Postad (redigerade)

Så du menar att det är glapp i alla USB portar på Windowsdatorn men bara när jag med switchen kopplar in Windowsdatorn?

För att sedan inte vara något glapp alls?

 

Tillägg2: Eller glapp i USB-kabeln från Switchen? Ja, men fortfarande bara när jag switchat om, vilket sker elektriskt.

 

Tillägg1: senaste gången kopplade jag ur enbart tangentbordet ur switchen, satte den i en port i Windowsdatorn och tangentbordet gick att använda igen. Därefter kopplade jag tillbaks tangentbordet till switchen och tangentbordet fortsätter att fungera bra.

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman
Postad (redigerade)

Vad är den sammanlagda strömförbrukningen på samma usb-port du kopplar in?

USB 2.0 max 0,5A (5V +0,25 -0,6) anslutna enheter enligt standard måste klara ned till 4,4V.

USB 3.0 max 0,9A (5V +0,25 -0,6) anslutna enheter enligt standard måste klara ned till 4,0V.

 

bild.png.1ff7839960e98ac8ca9c141e4794a203.png

Redigerad av Flyfisherman
Lagt till bild

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Automan
1 timme sedan, skrev Stafstaf:

Det vanliga är blir glapp i någon stans!

Eller kabel brott!

Utifrån beskrivningen av felet kan vi nog utesluta kabelbrott

 

På 2020-10-04 på 13:39, skrev Mikael63:

Om jag ansluter KS till Windows får jag med G602 störningar i form av hack + att markören kan "försvinna". 3M fungerar fortsatt bra.

Detta i Windowsmiljö. Med KS (fortfarande) ansluten till Windows får jag med GS602 inga störningar i Mint.

Om jag ansluter KS till Mint får jag inga störningar varken i Windows eller i Mint.

Om det skulle vara ett kabelbrott borde det inte ha någon betydelse om man kör Windows eller Linux Mint. Nu fungerer det utan störningar i Mint vilket indikerar att det troligen är något annat än kabelbrott som orsakar problemen.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
16 minuter sedan, skrev Flyfisherman:

Vad är den sammanlagda strömförbrukningen på samma usb-port du kopplar in?

USB 2.0 max 0,5A (5V +0,25 -0,6) anslutna enheter enligt standard måste klara ned till 4,4V.

USB 3.0 max 0,9A (5V +0,25 -0,6) anslutna enheter enligt standard måste klara ned till 4,0V.

 

bild.png.1ff7839960e98ac8ca9c141e4794a203.png

Det är 5.11 V, 0.074 A

Det är ju samma belastning hela tiden, mina tre enheter; två möss och ett tangentbord.

Det hände en grej nyss.. ett av de program jag arbetar med hickade till, det var ett kommando jag avbröt (typ) och i den vevan (exakt då) dog Logitech G602. Gick inte att slå av och slå på som åtgärd för att den skulle kvickna till. Bytte batterier och nu fungerar den igen. Ytterst långsökt att problemen hänger ihop. Mer som en liten minnesanteckning.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
1 timme sedan, skrev Automan:

Om det skulle vara ett kabelbrott borde det inte ha någon betydelse om man kör Windows eller Linux Mint. Nu fungerer det utan störningar i Mint vilket indikerar att det troligen är något annat än kabelbrott som orsakar problemen.

Jo, om det skulle vara kabelbrott i kabeln mellan switchen och Windowsdatorn men det är ju knepigt att ett sådant avbrott inte går att framtvinga genom att ex. röra på kablaget/switchen, att det enbart uppstår efter att med en "fjärr"knapp elektriskt ha kopplat om från ena datorn till den andra.

 

Om switchen i sig skulle glappa, internt, så borde det glappet finnas kvar just där även efter att jag byter port på Windowsdatorn.

 

Jag får ibland systemmeddelande om att en USB-enhet inte fungerar när jag växlat till Linux men det är ju naturligt eftersom enheterna inte längre är inkopplade.

 

Jag hade också kunna köpa att en eller flera enheter inte ger någon respons alls.

Tangentbordet lever eget liv när detta händer, det kan ex. slänga ur sig kkkkkkkkkkkkkkkkkkk eller ett gäng backspace som raderar tidigare skrivna tecken. Dock bara när jag trycker på någon tangent.

Numlock-lampan kan "lagga" osv.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
1 timme sedan, skrev Mikael63:

Det är 5.11 V, 0.074 A

Lite knepigt men det är samma värden när jag växlat till Linuxdatorn. Mätningen alltså kvar i Windowsdatorns port.

Tänkte då att det skulle bli någon slags störning (fortfarande bara ibland) från Linuxdatorn men även med den USB-porten urkopplad har jag dessa störningar.

Varje gång jag byter port, antingen på Windowsdatorn eller för de enskilda enheterna på switchen så poppar det upp ett sådant statusmeddelande i Windows, som när man ansluter en ny enhet för första gången i en port.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf

En riktig dum fråga 

Gör du bytet medan dator är i gång !, ?? 

Så kan jag garantera att du få konstiga händelser eller ljud . 

Byte ska gärna göras avstängda dator 

 

Det är något man fick lära sig .. 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
Postad (redigerade)
2 timmar sedan, skrev Stafstaf:

Gör du bytet medan dator är i gång !, ?? 

Ja, givetvis gör jag det. Det är liksom vitsen.

Så har jag gjort hela tiden och det har fungerat bra tills ganska nyligen, antagligen i samband med att jag lånade ut "dockan" eller i samband med Windowsuppdateringen till 1909. 

Redigerad av Mikael63
nej, körde utan docka före pandemin och då var det inga problem

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf
Postad (redigerade)

DZSpHrhHEXz_64HY8sDZNzm9DAdzSkaLaQ-O0SmnfTrgpXlbe2F0BmWbqVZpIgjIbCcBiFzOurAzLdA5jil0zTg3gs6V_Mg5VYT2lIVZFlwqt6_t84kdnwIwVm2JOKyzxmFy0d9GQ1w

Är det något detta håll? 

Pc1 skull kunna vara Linux , USB  A kontakt

Pc 2 Windows 10, USB A kontakt 

Osv 

 

Tagenbord och mus sitter som bilden visar ? 

Så få man en uppfattning hur det fungera 

 

(Det låter själva swich kablar , har något hänt med )

"Windowsuppdateringen till 1909."

visst  kan Windows uppdatering , ställa till 

"nä jag har svår tro på" 

Det brukar fram omgående bland alla Windows användare . För skull alla USB kontskter få problem 

 

 

 

 

 

 

Redigerad av Stafstaf

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
Postad (redigerade)
31 minuter sedan, skrev Stafstaf:

Är det något detta håll? 

Pc1 skull kunna vara Linux , USB  A kontakt

Pc 2 Windows 10, USB A kontakt 

Osv 

 

Tagenbord och mus sitter som bilden visar ? 

Så få man en uppfattning hur det fungera 

Ja

 

Tillägg: Som svar på ev. fråga om jag testat att skifta PC1 & PC2 så är svaret ja.

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf

Nu börja  jag få uppfattning ! 

Om vi tar antagande! 

Säg pc1 är Windows 10  " 

Jag skull inte flytta någon kontakt i huvudetaget när pc är i gång 

Jag stänga av pc . Byt USB port och sätta på pc 

 

Jag förstår att man vill sifftar när till  pc eller linux .  Och använda tagentbordet och mus 

 

Dom saker tänk på är vilken ordning sätter i produkter . 

Steg 1, Sätta i gång Linux 2 , första lägget

 Steg 2,  Sätta i gång pc 1, andra lägget 

 Steg 3, Sen skull jag  sätta i usb till tagenbord och mus 

 Steg 4 ,Slå på on knapp , mus och tangentbord 

Troligen har ingen betydelse i huvudtaget 

 

Felsökning , är besvärligt ! 

Man tror att alla möliga och omöjliga 

Kabel insättningar 

Steg för steg olika utgångar 

Stäng av enheter  i mella varje byte

 

 

 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Automan
12 timmar sedan, skrev Stafstaf:

Jag stänga av pc . Byt USB port och sätta på pc 

Det finns ingen anledning att stänga av en PC vid byte av USB port. Hela poängen med USB är att det ska vara enkelt att koppla in och ur hårdvara utan att stänga av datorn. Du stänger väl inte av din PC då du ska koppla in eller ur ett USB minne?

 

12 timmar sedan, skrev Stafstaf:

Stäng av enheter  i mella varje byte

Jag förstår inte din logik avseende felsökning. Är inte syftet med den enhet som Mikael63 har att enkelt kunna switcha mellan de anslutna datorerna utan att behöva stänga av dem mellan bytet.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Stafstaf

Om swich  kopplad . 

Det är vi  överens om alla. 

Är alla överens hur  "Det" är kopplat mellan dessa enheter !? 

 

 

Jag har efter fråga en bild där alla se hur är kopplat.  

Allt vi fått är USB  flyttas melkan olika USB.  På grund det är problem 

 

Alla bör vet att usb stika inte dra ut från enhet ut att matas ut först 

 

Om inte vill förstå är viktigt felsöka på olika sätt.

Alla sina egna idéer.  Jag ser ett problem , med massa kablar . "Bara ägaren kan se " 

Hur sak vi andra då kunna hjälp till.

 

Nu når jag  till en pungt, där jag inte ser hur vi gå vidare. 

Problem kvarstår .

I band så behövs bilder ,ibland en ritning osv 

 

 

 

 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

@Stafstaf jag svarade ja på din fråga om det ser ut som på bilden.

Din bild visar dock en 424, jag har en 224, en som bara hanterar två datorer men fyra usb-enheter

Vilka USB-enheter som är anslutna framgår tidigare i tråden men man kan säga att det ser ut som på bilden om man räknar bort skrivaren.

Jag använder switchen, ATEN US224, som den är tänkt att användas - att med ett knapptryck på "fjärrkontrollen" styra över mina tre USB-enheter omväxlande till två datorer.

Detta har alltså dagligen fungerat bra sedan i fjol sommar (finns en tråd här om själva köpet) och fram tills för ett par veckor sedan är det väl nu.

Det som ändrats sedan i fjol sommar är en större Windowsuppdatering. Mus nr 2 tillkom i början av september i år men störningarna började någon månad senare.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...