Just nu i M3-nätverket
Gå till innehåll
KimS

Flera om i samma formel

Rekommendera Poster

KimS

Hej, nu har jag kört fast.

Jag har en formel med 3 om-satser. Problemet är att de två senare inte räknas med alls, bara den första? Jag har skillt satserna med ;

Ngn som vet varför?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

=OM(A1=1;"ja ett";OM(A1=2;"ja två";OM(A1=3;"hela TRE";"Inget!")))

så KAN man skriva men det finns bättre alternativ för just det problemet jag löser ovan.

kanske även ditt har en bättre lösning?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
KimS
Postad (redigerade)
12 timmar sedan, skrev Monshi:

=OM(A1=1;"ja ett";OM(A1=2;"ja två";OM(A1=3;"hela TRE";"Inget!")))

så KAN man skriva men det finns bättre alternativ för just det problemet jag löser ovan.

kanske även ditt har en bättre lösning?

 

Tack, så här ser formeln ut som jag försöker få till:

=OM(($H8>=100)($H8<=9999);*(($O8*$F$3)+$E8)*$C$239;"Falskt";OM(($H8>=10000)($H8<=19999);*($O8*$F$3)+$E8*$C$240;"Falskt";OM(($H8>=20000)($H8<=49999);*($O8*$F$3)+$E8*$C$241;"Falskt")))+$F8

 

Något som inte stämmer...

Redigerad av KimS

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Ove Söderlund

Så som jag tolkar din formel så kontrollerar du värdet i H8 mot tre olika intervaller så du bör använda formeln OCH för att definiera nedre och övre gräns i intervallet och om formeln ger värdet SANT -> beräkna. Så mitt förslag till formel ser ut så här:

=OM(OCH($H8>=100;$H8<=9999);(($O8*$F$3)+$E8)*$C$239;OM(OCH($H8>=10000;$H8<=19999);(($O8*$F$3)+$E8)*$C$240;OM(OCH($H8>=20000;$H8<=49999);(($O8*$F$3)+$E8)*$C$241;"Falskt")))

Det jag blir lite nyfiken på är att du vill addera F8 till formeln, så jag har nu utelämnat det men vill du ha med det i en uträkning så får du lägga till den till varje uträkning inom formeln.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
KimS
35 minuter sedan, skrev Ove Söderlund:

Så som jag tolkar din formel så kontrollerar du värdet i H8 mot tre olika intervaller så du bör använda formeln OCH för att definiera nedre och övre gräns i intervallet och om formeln ger värdet SANT -> beräkna. Så mitt förslag till formel ser ut så här:


=OM(OCH($H8>=100;$H8<=9999);(($O8*$F$3)+$E8)*$C$239;OM(OCH($H8>=10000;$H8<=19999);(($O8*$F$3)+$E8)*$C$240;OM(OCH($H8>=20000;$H8<=49999);(($O8*$F$3)+$E8)*$C$241;"Falskt")))

Det jag blir lite nyfiken på är att du vill addera F8 till formeln, så jag har nu utelämnat det men vill du ha med det i en uträkning så får du lägga till den till varje uträkning inom formeln.

 

 

Tusen tack Ove, din hjälp uppskattas verkligen :)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MH_
Postad (redigerade)

Hej. Ser din "beslutsmatris" ut så här (står parenteserna rätt)? 

 

Min Max Formel
100 9999 ($O8*$F$3+$E8)*$C$239
10000 19999 ($O8*$F$3+$E8)*$C$240
20000 49999 ($O8*$F$3+$E8)*$C$241

 

Då är det ju bara C-delen som ändar sig och resten kan stå utanför villkoret

=$F8+($O8*$F$3+$E8)*vilkoret

eller

=$F8+($O8*$F$3+$E8)*OM(OCH($H8>=100;$H8<=9999);$C$239;OM(OCH($H8>=10000;$H8<=19999);$C$240;OM(OCH($H8>=20000;$H8<=49999);($O8*$F$3)+$E8*$C$241)+F8))

eller, med den "moderna" IFS istället

=$F8+($O8*$F$3+$E8)*IFS(OCH($H8>=100;$H8<=9999);$C$239;OCH($H8>=10000;$H8<=19999);$C$240;OCH($H8>=20000;$H8<=49999);$C$241)

 

Eller, direkt mot "beslutsmatrisen"

=$F8+($O8*$F$3+$E8)*INDIREKT(LETARAD($H8;{100,"$C$239";10000,"$C$240";20000,"$C$241";49999,"fel"};2;SANT))

 

 

Redigerad av MH_

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...