Just nu i M3-nätverket
Jump to content

Hur kan man använda =om( , om(och( tillsammans med ActivX funktioner ?


S.azon1953
 Share

Recommended Posts

Hej Eforum entusiaster,

 

Jag har ett problem som jag inte har  lyckats att lösa och det finns kanske tre svar A omöjlig funktion, eller B en lösning eller C kombinerad lösning typ 2 stegs variant.  

 

Problemet: Jag vill att några villkor skall uppfyllas enligt följande syntax att notera detta fungerar inte med det är så jag vill att resultatet skall bli. 

=OM( A1>0,BÄDDA IN("Forms.ComboBox.1",""),OM(A2>0,BÄDDA IN("Forms.ComboBox.1",""),OM(A3<0,BÄDDA IN("Forms.ComboBox.1",""),0))) 

Område F1:F20 är ok och länkade cellen A10 är ok.

Jag misstänker att det beror på AktivX kontrollen eftersom den inte finns kopplad till en cell som funktioner och formler är.  

Jag har kört fast tänker troligen fel , hoppas någon har en lösning och jag tror också många är intresserad

 

 

   MVH

S.azon

Link to comment
Share on other sites

Vad menar du egentligen? Ska du med en OM-sats anpassa/lägga in en combobox på arbetsbladet?

Det går ju inte, en funktion i en cell kan inte påverka något annat än värdet i cellen.

Det du kan göra är två saker.

1: Använda VBA-kod som körs givet någon händelse

2: Skapa formler som fyller i området som comboboxen hämtar sina möjliga värden från.

 

Link to comment
Share on other sites

Tack Monshi, 

Jag skulle i stället ha skrivit mitt problem i pseudokod:

1 Kontrollera om  cell A1 > 0 eller cell A2 > 0 eller cell A3 > 0

2 Använd  ActiveX ComboBox  

3  Om cellerna A1-A3 är < 0 , använd inte combobox , produkten blir därmed 0 

 

MEN- 

din tankegång i 2:an är helt klart rätt väg. Det kommer troligen att fungera.

 

 

 

 

Link to comment
Share on other sites

 Share



×
×
  • Create New...