Just nu i M3-nätverket
Gå till innehåll
Nofo

LÖST Om formeln fungerar med lista

Rekommendera Poster

Nofo

När jag använder OM formeln =OM(C2=”Ja”,1,2) och gör en lista med ja och nej i C2 så fungerar inte formeln. Hjälp nån?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Kan det vara så enkelt att det ska stå

=OM(C2=”Ja”;1;2)

 

Fast om det ska vara komma eller semikolon beror på språkinställningarna i datorn.

Vad får du för fel? Kanske ett exempel?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Nofo

Det fungerar om jag inte har listan, i cell c2 har jag gjort en lista med orden KORT och LÅNG som man kan välja av. Om jag tar bort listan fungerar det... 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

är det något som detta du kanske vill ha då?

=IFS(A1="kort";1;A1="lång";2;SANT;0)

Formeln i sig bryr sig inte om den står i en tabeller eller ej. fördelen i en tabell är att du kan använda kolumnernas namn i den.

I stil med

=IFS([@Klass]="kort";1;[@Klass]="lång";2;SANT;0)

om kolumnen med kort/lång heter "Klass"

 

Ett exempel som sagt, det kan hjälpa

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Nofo

Aha ska kolla!! Tack snälla, blir tokig!

 

kanske återkommer ...;)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Nofo

Så här ser det ut (nu har jag inte använt andra formeln som du gav mig än). Om man kollar i C10 som inte är en lista så fungerar det med inte där jag har en lista. Är det något jag gör fel?

The Fish List (1).xlsx

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

As simple as ...

Kicka på bladet Referens.

Texten du har där är inte "Short" utan "Short "

Med ett extra mellanslag efter ordet.

Därav att det inte fungerar.

 

Gjort om det med lite tabeller och sök-funktion istället i dessa.

Kopia av The Fish List (1).xlsx

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Nofo

tusen tack, det där hade jag ju aldrig kommit på själv!!!

 

tack för de nya formlerna!!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...