Just nu i M3-nätverket
Gå till innehåll
Gklav99

LÖST Kopiera ett värde beroende på cell innehåll

Rekommendera Poster

Gklav99
Postad (redigerade)

Hej Jag har försök att med hjälp av olika trådar lösa ett Exelproblem som jag har och hoppas någon kan ta mig i mål.

 

Jag skall kontrollera om ett värde E1-3 finns. Om det överensstämmer med B1 skall det värde som är närmas till höger om E skickas till A1

I min formel så blir det alltid F1 som skickas

image.png.5f953c4e9b330809e9e4f71b0f285ecd.png

 

Går det att lösa på något enkelt sätt?

 

Tack på förhand ☺️

 

image.png

Redigerad av Gklav99

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gklav99

Kanske är dålig på att förklara eller helt fel ute med mitt försök.

Men vad jag vill åstadkomma är egentligen att flytta resultatet i F1- F3 till A1-3 där B och E är lika

Någon som har något tips?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Jag hade svarat här tidigare men när jag senare kollade här igen insåg jag att jag nog missförstått frågan.

Som moderator kunde jag då ta bort inlägget så att ditt inlägg åter hamnade bland "Senast obesvarade".

 

Nu när du förtydligar så kanske jag tänkt rätt ändå?

Ska jämförelsen alltid ske på en och samma rad, enbart?

B2 & E2 lika ger resultatet F2 i cell A2 ?

 

Eller ska det "tittas i" flera rader?

Typ om samma värde som finns i E2 finns någonstans i kolumn B så ska osv...

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gklav99

Det ska tittas i flera rader t.ex. B1 ska leta i E1-E3 och värdet till höger om matchande fält skall presenteras i detta fall A1.

Knepigt att beskriva, hoppas du förstår....

Sedan ska B2 göra samma sak söka i E1-E3 presentera matchande fält till höger i fältet A2

o.s.v.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Okej, nu förstår t.o.m. jag. Dock ligger detta över min nivå men håll ut bara så får du nog en lösning här.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MH_

Är det inte en vanlig Letarad du är ute efter?

I A1

=LETARAD(B1;$E$1:$F$3;2;0)

(Titta efter värdet från B1 i första kolumnen E1:F3 och returnera värde från kolumn2 (F).  0/Falskt  samma som i din "passa"

 

PASSA är flexiblare med den säger bara var matchningen finns. Den returnerar inte rätt värde. Så din formel behöver kompletteras med INDEX

=INDEX($F$1:$F$3;PASSA(B1;$E$1:$E$3;0))

 

Eller. om du har nyaste excel. Kolla XLETAUPP

https://support.office.com/sv-se/article/xletaupp-funktionen-xletaupp-b7fd680e-6d10-43e6-84f9-88eae8bf5929

 

Då bestämmer du själv var returvärdet finns, Vad som skall hända om värde saknas osv. Smiiiidigt

=XLETAUPP(B1;$E$1:$E$3;$F$1:$F$3;"";0)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Gklav99

Tusen tack det fungerar bra 🙂

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...