Just nu i M3-nätverket
Jump to content

Jämföra två kolumner


Vinter21
 Share

Recommended Posts

Jämföra kolumn A och B, få det som finns i A men saknas i B returnerat till kolumn C.

Har använt formeln =OM(ÄRFEL(PASSA(B2;$A$1:$a$149;0));"";B2)

men behöver göra det omvända, returnera "ej träff" eller "saknas".

 

 

Jämföra kolumner.docx

Edited by Vinter21
Link to comment
Share on other sites

Om du vill ha det omvända borde det väl bara vara att enbart returnera resultatet från PASSA eller kanske slå in det som

=OM(ÄRFEL(PASSA(B2;$A$1:$a$149;0));SAKNAS();"")

exempelvis.

 

 

Link to comment
Share on other sites

Din formel och texten visar på helt olika saker. Formeln returnerar B-värdet om det även finns i A.

Om du vill ha ut det du frågar efter så får du byta plats på A och B i Monshis formel. 

 

Har du en ny excel och bara vill ha ut listan (och struntar i var det står) så kan du även testa:

=FILTER(A1:A149;ÄRFEL(PASSA(A1:A149;B1:B149;0)))

eller

=FILTER(A1:A149;ANTAL.OM(B1:B149;A1:A149)=0)

Kanske rensa dubletter

=UNIK(FILTER(A1:A149;ANTAL.OM(B1:B149;A1:A149)=0))

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...