Just nu i M3-nätverket
Gå till innehåll
Vinter21

Jämföra två kolumner

Rekommendera Poster

Postad (redigerade)

Jämföra kolumn A och B, få det som finns i A men saknas i B returnerat till kolumn C.

Har använt formeln =OM(ÄRFEL(PASSA(B2;$A$1:$a$149;0));"";B2)

men behöver göra det omvända, returnera "ej träff" eller "saknas".

 

 

Jämföra kolumner.docx

Redigerad av Vinter21

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Om du vill ha det omvända borde det väl bara vara att enbart returnera resultatet från PASSA eller kanske slå in det som

=OM(ÄRFEL(PASSA(B2;$A$1:$a$149;0));SAKNAS();"")

exempelvis.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Din formel och texten visar på helt olika saker. Formeln returnerar B-värdet om det även finns i A.

Om du vill ha ut det du frågar efter så får du byta plats på A och B i Monshis formel. 

 

Har du en ny excel och bara vill ha ut listan (och struntar i var det står) så kan du även testa:

=FILTER(A1:A149;ÄRFEL(PASSA(A1:A149;B1:B149;0)))

eller

=FILTER(A1:A149;ANTAL.OM(B1:B149;A1:A149)=0)

Kanske rensa dubletter

=UNIK(FILTER(A1:A149;ANTAL.OM(B1:B149;A1:A149)=0))

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...