Just nu i M3-nätverket
Gå till innehåll

Rekommendera Poster

Har stött på ett litet problem.
Försöker räkna antalet ? i en kolumn som ser ut såhär

1
@
1
1
?
2
2
X
!
1

med den vanliga formeln =ANTAL.OM(A1:A10;"?")

Får värdet 4. @ X ! räknas också
Försökt med ASCII-koden för ? (63)
 
=ANTAL.OM(A1:A10;TECKENKOD(63))
Samma resultat.
Kolumnen är allmänt formaterad.
Om jag räknar antal 1, 2, X, @ ger det rätt resultat,
men icke ?.
Vad gör jag för fel i en så banal formel?

 

Lars G

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

PROBLEMET LÖST

Efter lite googlande hitta jag denna lösning

för att räkna ?-tecken i en kolumn.

=ANTAL.OM(A1:A10;"~?")

d.v.s lägg till ~ (tilde), ASCII-kod 126 före ?

Fungerar perfekt. Typiskt att det är så enkelt.

Se sidan https://www.extendoffice.com/documents/excel/2862-excel-count-question-marks.html

Hittade även detta =PRODUKTSUMMA((A1:A10="?")+0) som också fungerar.

Lars G

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...