Just nu i M3-nätverket
Gå till innehåll
Mikael63

LÖST Trimma inställningar i Virtualbox för ökad upplevelse?

Rekommendera Poster

Eftersom jag inte hittat duglig mjukvara för 2D-CAD i Linuxmiljö har jag installerat en sådan i en virtuell maskin med Windows 10 (1903).

Att starta den virtuella maskinen och använda/nyttja den kräver en ganska stor dos av tålamod.

 

Det tar 6 minuter och 23 sekunder att starta upp den och få ett autostartande program att öppnas (notepad.exe, bara för att ha något att öppna när jag tar tid).

(Motsvarande förlopp med en virtuell maskin med Windows XP tar 15 sekunder)

Utforskaren startar 44 sekunder efter att man dubbelklickat på genvägen, Aktivitetshanteraren 13 sekunder, avsluta 53 sekunder.

 

Mina inställningar i virtualbox just nu är:

Minne 1024, 2 st CPU, videominne 32, ej 3D-grafik, ej 2D-grafik

Jag har haft "högre" värden tidigare men sänkte eftersom jag tänkte att värden då drabbades av det.

Värden har 8GB minne och 8 kärnor.

 

För den XP som behöver 15 sek att starta är motsvarande siffror 256, 2, 20, ej 3D/2D

 

I Windows 10 har jag stängt av alla autostartande tjänster som det medges att stänga av.

Jag har inga program som autostartar (förutom notepad i testsyfte), jag har avaktiverat brandvägg mm.

 

Är det ens möjligt att påverka upplevelsen till det bättre?

Mitt CAD-program fungerar även (utmärkt) i XP-miljön varför jag inte behöver Windows 10-eländet men jag är lite nyfiken ändå. 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Att köra Windows 10 på bara 1 GB fungerar inte bra och jag tror att det i ditt fall leder till för mycket swappande mot disk. Microsoft skriver visserligen att systemkravet är 1 GB för 32-bitars Windows 10 men att ligga precis på systemkravet brukar inte vara bra. För du har väl installerat 32-bitars?

Kravet för 64-bitars är 2 GB.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har du ett BIOS där du kan aktivera virtualization technology eller liknande? Säkerställ i så fall att det är gjort.

 

Utgår från att du har uppgraderat till den senaste versionen av Virtualbox?

Har du installerat Guest Additions i Windows gäst-os?

Har du satt "Host I/O cache" till "Enabled"?

Har du fixed size för virtuella hårddisken? 

Ligger disk-filen på en snabb SSD?

 

Skulle även rekommendera att du testar olika kombinationer av aktivera/deaktivera 2D och 3D acceleration. Bara för att 🙂

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
2 timmar sedan, skrev Mikael63:

Det är 64 bitars

Har man mindre än 4 GB RAM finns det få anledningar till att inte ha 32-bitars.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Har ändrat till 4 GB RAM, ingen skillnad.

 

"Har du ett BIOS där du kan aktivera virtualization technology eller liknande? Säkerställ i så fall att det är gjort." - Ja Intel virtualization technology är enabled, CPU VT-d är dock disabled.

 

"Utgår från att du har uppgraderat till den senaste versionen av Virtualbox?" - Ja, den senaste som tillhandahålls/uppdateras i mitt programförråd. 6.0. Finns en 6.1 ser jag.

 

"Har du installerat Guest Additions i Windows gäst-os?" - Ja

 

"Har du satt "Host I/O cache" till "Enabled"?" - Nej, men nu.

 

"Har du fixed size för virtuella hårddisken? " - Nej, vet inte om det går att ändra sådär rakt av.

 

"Ligger disk-filen på en snabb SSD?" - Finns på ett SanDisk Ultra microSDXC Class 10 UHS-I U1 A1 100MB/s 128G

 

Andra virtuella maskiner, som XP och LMDE har samma förutsättningar.

 

Testar nu med att importera en "färdig" virtuell maskin från Micro$oft

Tillägg: Nej orkade inte med det..

 

Ska testa aktivera 2D.

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Aktiverad 2D och CPU VT-d enabled ger ingen egentlig skillnad. Tog fyra minuter och 48 sekunder denna gång.

 

Får kolla om jag kan ändra disken till fixed och hjälper inte det får jag ta bort eländet och hålla mig till XP.

(som ju startar upp snabbare än Mint!)

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ja, Playern har jag kört med tidigare, även i Windowsmiljö.

XP-maskinen i tråden här är skapad med VMware.

 

Tycker Playern är knepigare att installera och har stökat till resten av systemet, både i Windows & Linux.

Eftersom virtualbox finns i programförrådet har jag "beslutat mig" att hålla mig till den.

 

Men visst skulle jag kunna göra ett nytt försök med Playern.

 

Har konverterat till "Fixed" nu, tog hela natten. Ska se om det påverkar något.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
9 timmar sedan, skrev Mikael63:

Har konverterat till "Fixed" nu, tog hela natten. Ska se om det påverkar något.

Ja, nu hamnar jag på ca en minut och 45 sekunder vid uppstart.

Kanske man får leva med även om det är sex gånger längre tid än vad XP behöver.

 

Men nu kan jag inte släppa detta innan jag testat Playern.. 🤓

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nä, det måste vara galet!

Nåt står inte rätt till!?

För det första: naturligtvis skall man om man har en Intel processor CPU VT-d  Enabled i Bios setup.

Detta möjliggör för själva hårdvaran att använda sig av något som kallas hardware utilization, mao. det sitter en krets i själva moderkortet som möjliggör detta att via processorn (som måste ha stöd för detta) accelerera beräkningarna och därmed märker man knappt av det,

 

När du kör flera operativsystem i tex.VMware (som stöder hårdvara-accelaration) så belastar detta inte processorn lika mycket som en sk. s/w virtualisering som tex. Virtual Box. Virtual Box har också något som kallas för hårdvaru accelerering, men det fungerar inte på samma effektiva sätt.

 

Vill du ha det optimala, så är WMware Workstation Player det bästa sättet att utnyttja det du har under huven, förutsatt att hårdvaran stöder detta..

 

Det finns absolut ingenting som ger en prestandavinst med Virtualbox jämfört med tex. VMware, förutsatt att processorn klarar av att virtualisera via moderkortet.

 Å andra sidan tar det process-förluster med flera operativsystem pågående med dess olika applikationer, så det blir alltid en avvägning.

 

Jag har testat båda och med samma dedikerade minne och samma last:  jag kan direkt se en skillnad på hur processorn arbetar på en av mina bildskärmar och jämförelsevis.

Mellan dessa två kan jag inte säga annat att WMware Workstaion Player är överlägsen i virtualisering.

 

Dessutom: kan man i WMware Workstaion Player installera flera olika operativsystem inkl.Windows (Guest) och aktivera dess licens-nyckel och köra dessa med flera applikationer igång -samtidigt,  helt oavsett om Linux eller windows är host.

Möjligen är Wmvare Workstaiion Player bättre att i Linux köra som host?

 

Gratis Vmware WorkstatonPlayer finns här https://www.vmware.com/products/workstation-player.html

 

Vad är det med Playern som inte fungerar?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)
6 timmar sedan, skrev Flyfisherman:

CPU VT-d  Enabled i Bios

Enabled eller Disabled påverkade inte uppstartstiden men det verkar ju rimligt att den ska vara Enabled och så är den också nu.

 

6 timmar sedan, skrev Flyfisherman:

Vad är det med Playern som inte fungerar?

Att den inte godkände den från virtualbox exporterade .ova

 

 

Tillägg:

Passar på att anteckna - en tredje virtuell maskin, LMDE 4, Debbie (beta), gillade inte konvertering från dynamic- till fixed disk.

Från en uppstarttid på 2:15 tar den nu ca 4:45.

 

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)
Citat

Att den inte godkände den från virtualbox exporterade .ova

Nja vad skall jag säga? 

Fast är du helt säker?

Se detta: Import an Open Virtualization Format Virtual Machine

 

WmWare Docs:

 

Citat

 

OVF is a file format that supports exchange of virtual appliances across products and platforms. When you export a virtual machine as an OVF file, you create a directory that contains an OVF file and the virtual disk files. You might consider an OVF as an archive of all the files that belong to the OVF directory. OVA is a single file distribution of the same OVF file package.

The OVF and OVA formats offer the following advantages:

  • OVF and OVA files are compressed, allowing for faster downloads.
  • The vSphere Web Client validates an OVF or OVA file before importing it, and ensures that it is compatible with the intended destination server. If the appliance is incompatible with the selected host, it cannot be imported and an error message appears.
  • OVF and OVA can encapsulate multi-tiered applications and more than one virtual machine.

 

  •  

Det verkar ju som VWware i alla fall stöder formatet....

How to import Howtoforge OVF and OVA Virtual Machine Images in VMware and Virtualbox

 

Eller om du stött på detta problem:

VMware fix for Invalid manifest and ova file import failed errors

Redigerad av Flyfisherman
Lagt till

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)
2 timmar sedan, skrev Flyfisherman:

Ja:

"The import failed because ova did not pass ovf specification conformance or virtual hardware compliance checks"

 

Även

  

18 timmar sedan, skrev Mikael63:

klagar på den XP-maskin som skapats med VMware.

 

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Jag gav detta en ny chans.

Konverterade disken med W10 från .vdi till .vdmk

Installerade Playern igen.

Skapade där en ny maskin med Windows 10.

Tog bort den befintliga disken och lade till den nyss konverterade.

Startar inte.

 

Kollade på XP.

Där var det .vmx som var korrupt. Öppnade den och tog bort en dubblett-rad.

Startar men får blåskärm.

 

Nu blir det inga mer chanser med Player.

 

Tillägg:

Men nån nytta gav detta. Jag exporterade min XP som ju var en hybrid mellan VMware och Virtualbox, med två mappar med många filer, till OVA och sedan importerade jag den OVA,n igen. Snyggt & prydligt i en och samma mapp.

 

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Exakt hur gjorde du med konverteringen?

 

Jag kan tillägga att med min Acronis True Imagage Backup & Restore så skapade jag för många år sedan en full disk-backup av min dåvarande Windows XP laptop. Formatet i .TIB

Måste vara mer än 10 år sedan.

 

Och nu kommer det roliga: Jag hade(har) en maskin som direkt kunde importeras .TIB i Playern och med alla dom program jag då hade installerade.

Fungerar helt klockrent. Faktum är att jag på denna har ett särskilt program för att bränna CD/DVD med och som jag bara har där. Inga problem, startar bara Playern och laddar min XP-laptop guest och vips är min gamla trötta XP-laptop (som numera snurrar 10 ggr. fortare) och kör brännaren inifrån detta.

 

Jag får för mig att något gått snett och att det inte beror på WmWare?

Vill du att jag skall testa hos mig, i så fall tar vi det privat via pm eller nåt.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)
2 timmar sedan, skrev Flyfisherman:

Exakt hur gjorde du med konverteringen?

Med qemu-img

 

https://docs.openstack.org/image-guide/convert-images.html m.fl.

 

Tillägg:

  

2 timmar sedan, skrev Flyfisherman:

Jag får för mig att något gått snett och att det inte beror på WmWare?

Vill du att jag skall testa hos mig, i så fall tar vi det privat via pm eller nåt.

 

Jag ser ingen anledning att fortsätta med detta. Mina maskiner fungerar med/i Virtualbox.

Har svårt att tro att VMware Workstation Player skulle starta upp min Windows 10 så mycket snabbare att det skulle vara värt besväret.

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Å nej! :blush::blush:

 

Jag var för snabb när jag gjorde min tidtagning, inser jag.

Jag konverterade min dynamiska disk, med namnet Windows 10.vdi till en fast disk med namnet Win10.vdi.
Detta gjordes på min USB-disk av utrymmesskäl, och på den fil som redan låg där och som jag tidigare kopierat till minneskortet.
När allt var klart testade jag först om disken Win10.vdi skulle fungera överhuvudtaget, tog i inställningarna bort disken Windows 10, som fanns på minneskortet (man tar inte bort disken utan man typ kopplar loss den) och lade till nyss skapade Win10.vdi som fanns på USB-disken.
Windows startar upp. Avslutar.

Tar bort filen Windows 10.vdi på minneskortet, kopierar dit Win10.vdi.
I inställningarna kopplar loss Win10 (på USB-disken) och lägger till Win10.vdi som finns på minneskortet.
Startar och tar tiden osv..

Men det som händer är att det är Win10 på USB-disken som körs!

När man lägger till diskar så "hamnar" de i Virtual box Virtual Media Manager, om man inte i den lagt till diskar.
Där får det inte finnas två diskar med samma namn, vilket man blir varse om om man lägger till och kopplar från diskarna den vägen.
Så fastän jag bläddrade till minneskortet och pekade på Win10.vdi så blev det den Win10.vdi som fanns kvar på USB-disken som kördes.
Av detta kan man lära sig att man ska hantera diskarna i denna Virtual Media Manager innan man väljer in dem i inställningarna för respektive maskin.

 

**

 

Kan filsystemet på minneskortet vara av betydelse?

Jag formaterade inte det utan använde det rakt av efter inköp.

Partitionstyp anges till NTFS/exFAT/HPFS

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...