Just nu i M3-nätverket
Gå till innehåll
calculus

index match flera kriterium

Rekommendera Poster

Hej

Vår kund har ett intternt artikelnr (kund eid kolumn A) och vi har kopplat deras artikelnr till vårat artikelnr (företagsitem = kund eid kolumn B och C). För att leta upp vårat företagsitem kör jag index match i kolumn F. Vad ska jag skriva i kolumn G för formel för att den ska leta efter kopplingen även i kolumn D och E. Försökte med flera olika formler men det blev fel. Svaret ska bli

G2=99

G3=98

G4=97

 

image.thumb.png.b17623f40b0647178335ba44e0ae8805.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Kan du inte köra IFERROR ?

Kolla kolumn C, omfel; kolla kolumn D, omfel: kolla kolumn D. 

På svenska:

=OMFEL(PASSA($A2;$C$2:$C$4;0);OMFEL(PASSA($A2;$D$2:$D$4;0);PASSA($A2;$E$2:$E$4;0)))

och ett index runt den naturligtvis

 

Du kan även presentera Passa för en kolumn i taget med hjälp av en "inre" index-formel:

=PASSA($A2;INDEX($C$2:$E$4;RAD($1:$3);RAD($1:$3));0)

Men det blir inte roligt att hålla reda på antal rader och kolumner i den soppan. Särskilt inte när du lägger på den yttre INDEX igen

=INDEX($B$2:$B$4;PASSA($A2;INDEX($C$2:$E$4;RAD($1:$3);RAD($1:$3));0))

Alternativt

=INDEX($B$2:$B$4;PASSA($A2;INDEX($C$2:$E$4;SEKVENS(RADER($A$2:$A$4);;1;1);SEKVENS(3;;1;1));0))

Det är kortare än IFERROR. Men rätt osmaklig.

 

Omfel=iferror

INDEX=index

PASSA=Match

RAD=row

sekvens=SEQUENCE

 

 

Redigerad av MH_

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...