Just nu i M3-nätverket
Jump to content

GParted - ett dåligt val?


Mikael63
 Share

Go to solution Solved by Mikael63,

Recommended Posts

Jag har ställt samma fråga i ett annat forum och jag vill redan nu poängtera att det inte är frågan om ett problem jag behöver hjälp med att lösa.

Det handlar, som så ofta när det är jag som skriver, om att stilla min nyfikenhet: varför?

 

Citat

Jag har vid ett flertal tillfällen råkat ut för att GParted antingen inte fungerar (står och tuggar) eller hanterar/tolkar diskar felaktigt.
Har även påpekat detta i flera trådar här och på annat forum.

Tänkte jag skulle försöka få rätsida på detta, om möjligt.

Jag har en USB-disk som jag använder nästan dagligen. Dels innehåller den bra-att-ha-saker sedan >10 år tillbaka och dels utgör den min plats för virtuella maskiner (och de ISO som behövs för att skapa maskiner)
Disken är på 500 GB, formaterad som NTFS och fungerar alldeles utmärkt. 

Det andra forumet är alltså här på eforum.

 

Disken är alltså på 500 GB och jag har 204 GB ledigt.

Alla de övriga (ca) 296 GB går att läsa då jag kopierat dem till en annan disk.

 

GParted visar detta om disken är monterad, men ingen varning om den inte är monterad:

20200104152647.png.3e7645f0ce720ca0d781a557b102868a.png

 

Monterad eller ej monterad så visas detta:

 

20200104152712.png.988719062d94116a23ff82764ac131c5.png

 

Alltså att hela disken utom 2,84 MiB+1,00 KiB skulle vara oallokerad!

Nonsens!

 

Detta gäller även andra GUI som använder Parted.

Programmen Gnome-disks och cfdisk visar korrekt innehåll.

 

20200104152748.png.311c81ec21ce9d4c3516f451d2249a67.png

 

 

image.png.654f6bdfebb1dfb41e309a096b9a1d26.png

 

Varför klarar inte GParted av detta? GParted är ju ett välrenommerat program och egentligen väldigt bra.

Min erfarenhet, om man ser till alla gånger som det programmet "har behövts", så är det ett riktigt uselt program.

 

 

Edited by Mikael63
Link to comment
Share on other sites

Det verkar som (eller jag tror) att det kan vara en "för ny" version av GParted.

Googlade igen. Kom hit:

https://bbs.archlinux.org/viewtopic.php?id=231674

Medlemmen gedakc skriver där:

Citat

This problem sounds like there are still ISO signatures existing on the hard drive.  Perhaps an ISO file was copied directly to the hard drive at some time in the past???  The solution involves identifying where the ISO signatures exist and then removing ONLY those ISO signatures.

For an example of how another user accomplished this, see:

GPT disk full of partitions looks like iso9660 with no partitions

Går man dit så verkar det som att man behöver 

Citat

Erasing the ISO signature does let newer GParted versions see all the partitions like the older ones did.

min utdata för wipefs /dev/sdb är:

DEVICE OFFSET TYPE UUID LABEL
sdb    0x1fe  dos       
sdb    0x0    mac  

wipefs /dev/sdb1

ger
DEVICE OFFSET TYPE UUID             LABEL
sdb1   0x3    ntfs F0E4948FE4945A24 Porsche

 

Frågan då om

sudo wipefs -o 0x1fe /dev/sdb

och

sudo wipefs -o 0x0 /dev/sdb

rensar det som behövs?

 

 

Edited by Mikael63
Link to comment
Share on other sites

20 timmar sedan, skrev Mikael63:

Frågan då om

sudo wipefs -o 0x1fe /dev/sdb

och

sudo wipefs -o 0x0 /dev/sdb

rensar det som behövs?

Nej, jag tror inte det.

Har försökt läsa på och jag tror att om det nu ÄR något med ISO signatur så ska utdata se ut liknande detta

Citat

0x8001 iso9660 [filesystem]

.. vilket jag inte får.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...