Just nu i M3-nätverket
Jump to content

Om värde finns i kolumner


Martassen
 Share

Recommended Posts

Om har text eller värden i a och b-kolumnen ifrån rad 1 och ner går det då på nåt vis i c1  göra en formel som anger:

om värdet finns i a kolumnen någonstans enbart så ska texten ”finns bara i A” returneras i c1, finns den i bara i b-kolumnen så ska ”finns bara i b” returneras i c1. Finns den i både a och b så ska ”finns i båda” returneras” i c1. Därefter kopiera ner formeln som kollar sv.

 

Försökt lite med letarad och passa men får ej till det med att den ska söka ifrån båda osv.  Sökning rakt över går väl säkert med ” om”men den ska söka i hela kolumnerna. 

 

tack på förhand ?

Edited by Martassen
Link to comment
Share on other sites

Var står värdet du letar efter?

Om värdet står i C1 så kan du bygga vidare på det här:

=(ANTAL.OM(A:A;C1)>0)*1

=(ANTAL.OM(B:B;C1)>0)*2

T.ex så här:

=OMFEL(VÄLJ((ANTAL.OM(A:A;C1)>0)*1+(ANTAL.OM(B:B;C1)>0)*2;"finns bara i A";"finns bara i B";"finns i Båda");"finns inte alls")

Edited by MH_resurrected
Skrev fel adress
Link to comment
Share on other sites

värden står i a och b kolumnen.

om bara i A ska ”finns bara i A” returneras. Om finns bara i b ” finns bara i b”. Om finns i båda ”finns i båda”. Sträcker sig flera rader ner. 

 

 

Edited by Martassen
Link to comment
Share on other sites

Mitt tips är att skriva logiken i skilda celler och sedan få ihop det. Antal.om är bra, passa fungerar även för detta.

men bara att byta referens i MHs formel annars, C1 mot B1 i formel ett och C1 mot A1 i formler två. Typ ungefär.

 

Link to comment
Share on other sites

=VÄLJ(1+(ANTAL.OM(B:B;A1)>0)*1+(ANTAL.OM(A:A;B1)>0)*2;"unika";"A"&RAD()&" finns även i B-kolumnen";"B"&RAD()&" finns även i A-kolumnen";"Både A"&RAD()&"och B"&RAD()&" har dubletter")

 

Du måste hantera 4:a möjliga lägen

Varken a eller b har dubbletter

a har dubblett i B

b har dubblett i A

Både a och b  har dubbletter i den andra kolumnen

Edited by MH_resurrected
a<>b
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...