Just nu i M3-nätverket
Gå till innehåll
Martassen

Om värde finns i kolumner

Rekommendera Poster

Martassen

Om har text eller värden i a och b-kolumnen ifrån rad 1 och ner går det då på nåt vis i c1  göra en formel som anger:

om värdet finns i a kolumnen någonstans enbart så ska texten ”finns bara i A” returneras i c1, finns den i bara i b-kolumnen så ska ”finns bara i b” returneras i c1. Finns den i både a och b så ska ”finns i båda” returneras” i c1. Därefter kopiera ner formeln som kollar sv.

 

Försökt lite med letarad och passa men får ej till det med att den ska söka ifrån båda osv.  Sökning rakt över går väl säkert med ” om”men den ska söka i hela kolumnerna. 

 

tack på förhand 🙂

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MH_

Var står värdet du letar efter?

Om värdet står i C1 så kan du bygga vidare på det här:

=(ANTAL.OM(A:A;C1)>0)*1

=(ANTAL.OM(B:B;C1)>0)*2

T.ex så här:

=OMFEL(VÄLJ((ANTAL.OM(A:A;C1)>0)*1+(ANTAL.OM(B:B;C1)>0)*2;"finns bara i A";"finns bara i B";"finns i Båda");"finns inte alls")

Redigerad av MH_resurrected
Skrev fel adress

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Martassen

värden står i a och b kolumnen.

om bara i A ska ”finns bara i A” returneras. Om finns bara i b ” finns bara i b”. Om finns i båda ”finns i båda”. Sträcker sig flera rader ner. 

 

 

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Mitt tips är att skriva logiken i skilda celler och sedan få ihop det. Antal.om är bra, passa fungerar även för detta.

men bara att byta referens i MHs formel annars, C1 mot B1 i formel ett och C1 mot A1 i formler två. Typ ungefär.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MH_

=VÄLJ(1+(ANTAL.OM(B:B;A1)>0)*1+(ANTAL.OM(A:A;B1)>0)*2;"unika";"A"&RAD()&" finns även i B-kolumnen";"B"&RAD()&" finns även i A-kolumnen";"Både A"&RAD()&"och B"&RAD()&" har dubletter")

 

Du måste hantera 4:a möjliga lägen

Varken a eller b har dubbletter

a har dubblett i B

b har dubblett i A

Både a och b  har dubbletter i den andra kolumnen

Redigerad av MH_resurrected
a<>b

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...