Just nu i M3-nätverket
Gå till innehåll

Rekommendera Poster

Hej! 

 

Jag har en förfrågan, jag ska göra en sökmotor med att du fyller i en vikt, Te:x 3 Kg som visar ett pris, Tex: 300 kr.

 

Jag får den endast att funka med jämna tal, dvs 1,2,3 osv. Om jag skriver in 3,3 Kg så visar den fortfarande 300 kr. 

DÅ vill jag att den ska visa nästa cell som är på 4 Kg som kostar 350 kr. 

 

Hur får jag Letarad funktion att leta i nästa cell om talet är ojämt? 

 

// Fredric 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Kontroll: Så här tolkar jag din fråga. 

Du pratar inte om udda/jämna tal utan om nästa heltal?

 

Då kan du använda AVRUNDA.UPPÅT() för att ändra 3,3 till 4. Dvs om "3,3" står i cell G2 så kan du köra:

=AVRUNDA.UPPÅT(G2;0)

Inbakat i LETARAD

=LETARAD(AVRUNDA.UPPÅT(G2;0);$A$2:$B$200;2;FALSKT)

 

ed

=LETARAD(AVRUNDA.UPPÅT(G2;0);$A$2:$B$200;2;SANT)

Vid närmare eftertanke vill du nog ha argumentet FALSKT i letarad när du kör AVRUNDA. Då returnerar den bara ett svar om det finns en exakt träff

/ed

 

 

Ett alternativ är att "bygga" din letarad med hjälp av PASSA och INDEX.

Passa har argumentet -1 som söker efter nästa värde som är större än eller lika med 3,3. Det tråkiga är att din hjälptabell måste stå i fallande ordning. 

https://support.office.com/sv-se/article/passa-funktionen-passa-e8dffd45-c762-47d6-bf89-533f4a37673a

Men om det funkar kan du köra formeln:

=PASSA(G2;$A$2:$A$200;-1)

För att hitta rätt rad och returnera med:

=INDEX($B$2:$B$200;PASSA(G2;$A$2:$A$200;-1))

 

Redigerad av MH_resurrected
hade otur när jag tänkte

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Förstår missförståndet om jag är otydlig. 

men jag har både udda heltal i tabellen!

 

Avrunda.uppåt() funkar, men jag går upp för mycket i kg när jag använder den vikten.

När jag kör avrunda så blir vikten inte längre 3,3 kg utan det blir 13 KG. 

 

// Fredric 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vilket steg går fel? Menar du att:

=AVRUNDA.UPPÅT(G2;0)

Ger 13 om det står 3,3 i G2? Det låter helknasigt. 

 

Eller blir det fel i Letarad?

Har du testat att ta bort argumentet SANT i min första letarad-formel? Om man har sant så låter man excel leta "ungefär rätt". Och det funkar bara om data står i exakt rätt ordning osv.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...