Just nu i M3-nätverket
Gå till innehåll
PerX

Tids synk problem - peer not resolved

Rekommendera Poster

Hej,

 

Jag har  problem med windows 10 och att windows 10 inte kan synkronisera med tids servern och felmeddelandet är att synkroniseringen misslyckades och att peer is unresolved, vilket verkar betyda att en timeout inträffar . 

Comodo brandvägg och antivirus. Router : RT-AC51U, windows version : 1903

Jag har försökt lösa problemet på följande sätt, utan att få det att fungera, tacksam för ytterligare felsökningstips :

Bytt tids server, provat 4 – 5 olika

Kontrollerat att servicen Windows time körs och är satt på Auto

Kört följande

                         w32tm /debug /disable

w32tm /unregister

w32tm /register

net start w32time

 

Kontrollerat att Comodo eller Routern inte blockerar port 123

Stängt av Comodo under synkroniserings försöken

Stängt av brandväggen i Routern

Kört Sfc /scannow med administratörs behörigheter

Kört windows felsökaren för windows update

Uppdaterat tiden manuellt och därefter satt om parametrarna för automatiskt tid och återigen försökt synka med tids server

Kontrollerat att det inte finns misslyckade system uppdateringar

 

I maj bytte jag router till ASUS och jag noterade att senaste lyckad synkronisering var just någon gång i maj. Jag upptäckte synk problemen just nu när justering till vintertid skall ske.  Samtidigt uppträder just nu andra fel : Comodos agent stängs av , intermittent i början efter start av datorn. Två appar startar inte och när jag försöker uppdatera dem i store så fås felmeddelande 0x80070005, vilket antyder problem med access rättigheter.

 

Hänger problemen ihop ?

Router problem ?

Brandväggsproblem ? 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Kan du koppla datorn så att routern inte används, dvs med nätverkskabel direkt till fiberkonverter/modem/vägguttag (alltså dit routerns WAN-port normalt är ansluten)?

Det blir ju en kontroll av om problemet beror på routern.

 

När installerade du Comodo?

 

På 2019-10-29 på 08:17, skrev PerX:

Kört följande

                         w32tm /debug /disable

w32tm /unregister

w32tm /register

net start w32time

Och fått normala svar på de kommandona?

Vad blir det för resultat av kommandot w32tm /resync?

 

Är du inloggad som administratör?

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej,

 

Jag är inloggad som administratör och Comodo installerade jag för ca 2 år sedan. Alla w32tm kommandon har jag fått normalt svar på.  Jag skall testa w32tm/resync och att koppla direkt till  vägguttaget, återkommer.    

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nu har jag kopplat datorn direkt till fiberingången, kört w32tm kommandona och på w32tm /resync får jag svaret :

 

C:\WINDOWS\system32>w32tm /resync
Sending resync command to local computer

The computer did not resync because no time data was available.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Då har det inte med routern att göra i alla fall utan det ligger i datorn. Kan du få fram någon lista i Comodo som visar om den brandväggen har blockerat något?

 

Se

https://www.thewindowsclub.com/computer-did-not-resync-because-no-time-data-was-available

https://answers.microsoft.com/en-us/windows/forum/all/the-computer-did-not-resync-because-no-time-data/57823fcb-49a2-4fa2-a794-9dd623bbc0bb

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Comodo har blockerat följande :

 

image.thumb.png.fc1b301f96426256906c1fae1f0e8855.png

 

Ska jag köra kommandona som det refereras till i länken ? Dvs reset på local group policy ? 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Whitelist svchost. Be comodo snällt att tillåta in/ut kommunikationen via Port 123 (UDP). 

 

Sedan ska det finnas en time-service som måste vara igång (tjänster?). kollla att den är igång och testa att restarta tjänsten. Restarta windows, vänta på uppdateringar :) Sedan vet jag inte...

Redigerad av Phenomen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
12 minuter sedan, skrev PerX:

Comodo har blockerat följande :

Verkar ju vara saker som har med Chrome och Comodo att göra och inte tidssynkronisering.

 

15 minuter sedan, skrev PerX:

Ska jag köra kommandona som det refereras till i länken ? Dvs reset på local group policy ? 

Jag ser inget om någon reset i länkarna?

Men annars tror jag att det är bra om du följer tipsen i länkarna men skapa en systemåterställningspunkt först så att du kan backa tillbaks om ändringarna leder till att det blir sämre.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Uttryckte mig kanske fel, men sist står det  click ‘Time Providers’, and then set all the objects in this node to ‘Not Configured’. för en local computer. Men när jag kör kommandot gpedit.msc, så får jag ett felmeddelande  det går inte att hitta filen gpedit.msc . . . 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

När jag läser på nätet, så verkar det som om den filen inte är installerad i windows 10 home, vilket jag har. Jag skall försöka fixa det, det finns tips på nätet, 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har kört :

 

FOR %F IN ("%SystemRoot%\servicing\Packages\Microsoft-Windows-GroupPolicy-ClientTools-Package~*.mum") DO (
DISM /Online /NoRestart /Add-Package:"%F"
)
FOR %F IN ("%SystemRoot%\servicing\Packages\Microsoft-Windows-GroupPolicy-ClientExtensions-Package~*.mum") DO (
DISM /Online /NoRestart /Add-Package:"%F"
)

 

Men jag får inte den installerad, dock meddelande om att "operation completed succesfully"

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Efter omstart så är den installerad, skall prova att editera med den enligt länken

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

I länken står det att man skall sätta ej konfigurerad. Detta värde var redan satt, så jag behövde inte ändra något. Testar vidare med länken från Phenomen.    

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej. Jag har inte lusläst din post. så det är risk att jag svarar helt ur nattmössan.

 

Men när moderkortets backupbatteri tog slut i min stationära dator så fick jag väldigt konstiga felmeddelanden när den skulle synka tid. Om jag fattar det rätt så har windows 10:s standard-tidsservrar certifikat. Och eftersom datorklockan hamnade på moderkortets/biosens tillverkningsdatum efter varje omstart så var certifikaten ogiltiga så att anslutningen till tidservern fick timeout ...

Jag kommer tyvärr inte ihåg de direkta felmeddelandena men det handlade inte om utgångna certifikat utan något som jag tolkade som att tidservrarna var otillgängliga. Det skulle kunna vara ditt felmeddelande. 

 

Lösningen var att ställa datumet ungefär rätt så att certifikaten blir giltiga.Sen kopplar den upp. 

 

Och jag kan stolt meddela att det bara tog ett år innan jag gick till kjelle eller clabbe och köpte ett nytt batteri (2025 eller 2032, inte svindyra). 

https://www.kjell.com/se/produkter/el-verktyg/batterier/knappcellsbatterier/kjell-company-litiumbatteri-cr2025-p32245

 

 

Jag hade nästan glömt att moderkorten hade backupbatteri. Jag antar att batteriet får jobba hårdare när man har huvudströmbrytare på datorhörnan. en oförutsedd biverkan.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

MH_resurrected, tack för tipset. Jag har ställt klockan på en så exakt tid som möjligt och försökt göra en ny synk, men det misslyckades återigen (se ovan). Min dator är ca 2- 3 år gammal, kan moderkortets backup batteri  ta slut efter så kort tid ?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Nej, batteriet tar knappast slut på den tiden. Särskilt inte om du saknar mekanisk huvudbrytare (jag har lite brand-foliehatt när det gäller att lämna maskiner i standby).

Men nu har du i alla fall uteslutit ett möjligt problem och kan koncentrera dig på övriga varianter. När det gäller certifikatens giltighet så behöver du nog ligga minst ett halvår fel för att den skall ge problem (beroende på uppdateringsdatum osv).

 

ED

Hmmm

Och om jag hade läst din första post ordentligt så hade du sluppit läsa min post... 

"Uppdaterat tiden manuellt och därefter satt om parametrarna för automatiskt tid och återigen försökt synka med tids server"

/ED

Redigerad av MH_resurrected

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej,

 

Nu har  jag kollat port 123 litet mer noga.  Kört :

1) kommandotolken : netstat -a.  För att kolla alla öppna portar. Port 123 syns inte där

 

2) Kollat i Comodo över processer : port 123 ägs av w32time men uppgift om port status saknas och det finns ingen regel aktiverad för den i Comodo :

image.thumb.png.414f6d67fd9318857ddc18b4f74e28e9.png

 

 

 

 

 

 

 

3) Kört   kommandot Test-NetConnection DESKTOP-9BT590A -Port för både port 123 och en port som jag kunde se var öppen och lyssnande ( i 1 ovan). 

För  Port 123 testade jag med brandvägg på och utan brandvägg och resultatet blir att den ä'r stängd :

image.png.f86b594fa219750926b209a73e2f89de.png   

 

För en port som var öppen får jag :

image.png.ba509986c0052f89d52c1f8ccb2b3c63.png

 

4) Kontrollerat att windows brandväggen är av aktiverad

 

Om det inte är brandväggen som blockerar porten , vad är det då ? Det kan inte vara brandväggen med ovanstående resultat. Kan jag öppna porten genom ett kommando ?  Det jag hittat på nätet  verkar bara vara för windows egen brand vägg.

image.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tidssynkroniseringen i Windows lämnar allt annat att önska.

Den är långtifrån bra!

 

Jag har haft samma problem av och till sedan åtminstone en 6-7 år tillbaks. Jag tror t.o.m att jag startat en tråd om om detta?

Synkronisering mot tidsservern misslyckades etc.

 

Tex. nu senast vid omställning till normaltid från sommartid så visade den inte bara en timme fel, utan 1 timme och en kvart!

 

I min Bios Setup så stod klockan korrekt på normaltid, sånär som på en bråkdelssekund mot Fröken ur:

men  när Windows startade så gick klockan fullständigt galet.

 

Om man ändrar tidsservrar så fungerar det ett tag, ja kanske ett längre tag, men vips så hoppar Windows klocka nån halvtimme hit och dit.

 

Att ändra tidsserver:

Start > inställningar (lilla kugghjulet) > Tid och språk >  högerklicka "Datum, tids och regionsformat" > till höger sedan klicka "Fler datum-/tidsinställningar etc." >  Ställ in tid och datum > Fliken Internettid > Ändra inställningar =>

 

image.png.a2b0a1f889b6f620c8d0a8d1ebc09244.png

image.png.a1415e71ae7dfdab6c24836cf7f142b8.png

> Ändra inställningar => Välj en tidsserver och klicka 'Uppdatera nu'

image.png.888a1b39cf2b6cf2531c5ccad93d1a11.png

Bocken för att synkronisera med en tidsserver är ibockad, men nu har jag lust att ta bort denna bock...

Och även om jag valt time.windows.com så sker det regelbundet att denna ställer min dators klocka helt fel.

Det kan vara allt ifrån nån minut till nån timme.

 

Antingen är det fel på tidsserverna eller något i Windows 10 som orsakar detta problem och jag tror på Windows och hela vägen sedan Windows 7 faktiskt...

 

M.a.o. är du inte ensammen om detta fenomen.

;)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej,

Jag noterar andra märkligheter. När jag själv klickar på inställningar för att synka med tids servern får jag hela tiden synkning misslyckas, likaså via w32time kommandona. Men på inställningarna så redovisas senaste lyckad tid synkning, just då jag själv begärt den. Om synkningen misslyckades och felhanteringen skulle vara konsekvent, så borde inte windows redovisa i efterhand att senaste synkning är lyckad ?   

 

image.png.a81ca297e0cd9bc208a6eb5cb539715f.png

 

Detta är iofs ingen katastrof , jag kan sätta om tiden själv,men jag är lite pedantiskt lagd och vill gärna följa upp fel som inträffar där det tidigare fungerat, det kan tyda på intrång eller annat, när något plötsligt ändras oförklarligt. Dock har jag en NAS (synology) som synkar mot en tids server och här fungerar synkningen helt utan problem. Det som stör mig här är att port 123 tycks vara stängd och att det är därför som requestet timar ur. Jag har för litet kunnande om portar och nätverk för att förstå varför.   

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Prova time.nist gov klicka uppdatera.

Fungerar inte det så testa: time.windows.com igen och uppdatera.

Ingen lösning på problemet, bara för att se om du kan komma vidare.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag jag vet att detta är direkt frustrerande.

Just nu har jag tyvärr ingen lösning, men misstänker starkt att det ligger i Windows operativsystem, eftersom jag på en annan Linux maskin aldrig haft detta problem .

 

För övrigt är tidsservarna som lokala företag använder sig utav, i regel synkade med RISE https://www.sp.se/sv/index/services/time_sync/ntp/Sidor/default.aspx

Och som följer Network Time Protocol (NTP).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
11 timmar sedan, skrev PerX:

1) kommandotolken : netstat -a.  För att kolla alla öppna portar. Port 123 syns inte där

netstat -a listar alla TCP-portar där något program lyssnar, det är inte samma sak som öppna portar och tidsynkroniseringen lyssnar bara när den är aktiv. Dessutom är väl port 123 den port som tidsservern använder och det behöver inte vara den porten som tidsynkroniseringsprogrammet i din dator lyssnar på. Sen går tidssynkronisering över UDP och inte TCP så jag är inte säker på att kommandot är relevant.

 

Pröva med netstat -a -b medan tidssynkronisering pågår.

 

Om du misstänker att Comodo ställer till med något bör du väl avinstallera det för att se om det hjälper.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

När jag kollar på nätet så verkar det som port 123 används för både request och respons. Jag skall kolla upp om netstat avser även UDP. Det jag skulle behöva är ett pgm som kan monitorera en specifik port och skapa loggar, så att jag kan se exakt vad som händer vid en given tidpunkt, kanske finns att ladda ner, skall kolla upp detta. Om jag skall gissa , utan att kunna något om portar etc, så borde port 123 normalt vara stängd och när requesten skickas så öppnar windows porten och sätter porten i lyssna läge tills dess att responsen erhållts eller att en viss tidsgräns nåtts, därefter stängs den igen. Det märkliga är att min sambo har en laptop med windows 10, version 1903 och exakt samma sättningar i Comodo, men där fungerar tid synkroniseringen korrekt. Tveksam till att det är brandväggen som är boven i detta.    

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...