Just nu i M3-nätverket
Gå till innehåll
tomashag

Nya problem med VPN

Rekommendera Poster

Jag har ett antal år kört med VPN (PPTP) mellan två Windows 7-datorer och det har fungerat bra. Nu ska den dator som har fungerat som server bytas mot en som kör Windows 10 men jag har inte fått det att fungera. Jag har varit iväg till fjärrdatorn, alltså inte servern, men det gick inte. Jag har bytt  ip-adressen på routern för att peka på  den nya datorn. Kan man köra på det lokala nätverket för att testa så jag slipper att fara som en skottspole mellan de båda datorerna? Jag använder då den externa ip-adressen för att ansluta till servern men det fungerar inte då heller. Jag får ett felmeddelande om att jag måste ändra nätverksinställningarna, vilka då? På serverdatorn har jag under nätverksanslutningar en ruta Inkommande anslutningar och Inga klienter är anslutna.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Kan du inte skriva flera detaljer, är det cisco eller juniper router du kör eller vad snurrar trafiken igenom? Ansluter inte tunneln på något sätt med datorn som trafiken ska gå igenom, får du någon rutt ut på nätet överhuvudtaget isf hur långt, hur är det med DNS osv.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Finns TCP/IP verktyget traceroute, tracert tror jag kommandot i windows är kommando promten (cmd), ex tracert idg.se så kan du se hur många hopp om det ansluts överhuvudtaget eller ta ett random IPv4 adress om du inte har någon DNS, Om jag förstår dig rätt i det du skrev innan! vill du sätta upp och testa publika adresser hemma för test miljö så får du ladda ner openbgpd eller zebra och sätta upp en annonsering i nätverket. Prova även se om anslutningen inte blockeras i någon brandvägg.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Sätter du VPN klient värdena i routern då? Eller sätter du det i Windows VPN grej typ skapa anslutning eller vad det nu heter?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
2 minuter sedan, skrev tomashag:

Jag kan tillägga att jag kör VNC mellan samma datorer utan problem.

Då har du anslutning, kolla brand väggen i Windows 10 datorn. Och se om du även får DNS uppslagen på rätt sätt.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag provade med att stänga av brandväggen (Norton) tillfälligt men det hjälpte inte. DNS borde väl fungera, jag har inga problem med att komma ut på internet.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Du kör samma VPN inställningar som innan bara på ny installation med Windows 10 istället för 7,  med samma router sedan tidigare, men du kan inte trycka trafiken igenom Windows 10 datorn? Alltså du får igen anslutning ut på nätet från den? Ja bara för du har DNS på en lokal dator betyder det inte samma sak som igenom en VPN anslutning, borde vara någon sak med brandväggen eller VPN server inställningarna som inte är ok.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Datorn är ny. Om man tittar på inställningar för inkommande anslutningar så får man detta:

 

241355060_Skrmklipp.PNG.6a88858453dc6ee163be78410c0b2b93.PNG

Dvs ingen maskinvara finns. Hur lägger man till det och vad menas med maskinvara? Eller är det texten längst ner som gäller?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Om man håller muspekaren över nätverksikonen i aktivitetsfältet så dyker det upp en ruta där det står : Nätverk Internetåtkomst samt RAS(dial-in interface) Internetåtkomst saknas. Hur får man internetåtkomst till det senare? Obs att jag stängde av brandväggen och det hjälpte inte.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hoppade Windows-brandväggen igång när du stängde av Nortons brandvägg?

Vilka portar är "forward" i routern till nya datorn?

Har den nya datorn en ny IP-adress eller är det samma som den gamla?

I det första fallet måste ju forward-reglerna gås igenom.

 

3 timmar sedan, skrev tomashag:

Kan man köra på det lokala nätverket för att testa så jag slipper att fara som en skottspole mellan de båda datorerna?

Nja, men du skulle kunna ha en dator som är ansluten till internet via en mobil som agerar hotspot (trådlös router).

 

Kolla denna guide: https://www.howtogeek.com/135996/how-to-create-a-vpn-server-on-your-windows-computer-without-installing-any-software/

för att se om du har missat något steg.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hur ser man om  Windowsbrandväggen går igång? Port 1723 används till den nya datorn som har en annan ip-adress. Jag såg något intressant, kanske. Texten RAS osv syntes inte enligt mitt tidigare inlägg förrän jag gjort ett försök att ansluta, då dök den upp så något måste tydligen hända i servern när man försöker ansluta.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
2 timmar sedan, skrev tomashag:

Hur ser man om  Windowsbrandväggen går igång? Port 1723 används till den nya datorn som har en annan ip-adress. Jag såg något intressant, kanske. Texten RAS osv syntes inte enligt mitt tidigare inlägg förrän jag gjort ett försök att ansluta, då dök den upp så något måste tydligen hända i servern när man försöker ansluta.

Använd programmet nmap, för att se vilka portar som är öppna finns länk till nmap på närmaste sökmotor och manual sidor.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
11 timmar sedan, skrev tomashag:

Hur ser man om  Windowsbrandväggen går igång?

Inställningar - Uppdatering och säkerhet - Windows-säkerhet

eller

Programlistan i Start-menyn - Windows-säkerhet

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nmap var verkligen ett proffsprogram men jag fick kanske ut något intressant från det. När jag körde det med den nya Win10-datorn så såg man att portarna 1723 och 5900 var rödmärkta och satta som filtrerade. Dock så fungerade VNC i alla fall. Jag kopplade sedan bort Win10-datorn, ändrade i routern till rätt ip-adress och körde igång den gamla Win7-datorn. Då fick jag minsann båda portarna som öppna och VPN fungerade igen. Mysteriet tätnar!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
2 timmar sedan, skrev tomashag:

Nmap var verkligen ett proffsprogram men jag fick kanske ut något intressant från det. När jag körde det med den nya Win10-datorn så såg man att portarna 1723 och 5900 var rödmärkta och satta som filtrerade. Dock så fungerade VNC i alla fall. Jag kopplade sedan bort Win10-datorn, ändrade i routern till rätt ip-adress och körde igång den gamla Win7-datorn. Då fick jag minsann båda portarna som öppna och VPN fungerade igen. Mysteriet tätnar!

Nmap är ett enkelt verktyg, eftersom du sitter i ett grafiskt läge (användere världen) ex user nisse, detta eftersom du som användare inte kan se felet. Ett annat enkelt verktyg för felsökning är wireshark där kan du få fram det vad som pågår i subnätet hemma, och inkommande och utgående trafik. - lycka till

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ett annat tips när du väl fått igång VPN anslutningen mot servern är att köra programmet snort på den så du kan få lite översyn vad som händer med nätverket. - lycka till.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag hittade en tråd på answers.microsoft.com där 322 personer hade samma problem! Det sista inlägget var från 14 oktober och folk var jäkligt sura på Microsoft som inte hade löst problemet. Tydligen började det med 1903-uppdateringen. Jag lägger ner mitt projekt att byta serverdator tills dom har löst det. Supporten för Windows 7 pågår ju till årsskiftet. Tack i alla fall för visat intresse, Cecilia och Nisse1236.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag upptäckte ett nytt inlägg från idag i tråden som nämns i det föregående inlägget. KB4522355 skulle fixa det hela men icke! Jag fick samma resultat som tidigare. Jag har inga problem med att ansluta till Windows 7 servern, både anslutning via ikonen i aktivitetsfältet och anslutning i inställningar där man konfigurerar VPN så klienten i Windows 10 datorn verkar ju fungera, det är servern i den nya Windows 10 datorn som inte vill vara med. Det verkar ju vara ganska otroligt att Microsoft inte har fixat problemet på ett halvår.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...