Just nu i M3-nätverket
Gå till innehåll
Martassen

Om eller Eller, och?

Rekommendera Poster

Postad (redigerade)

=Om(A1="Kina";"Flyg";Om(A1="Italien";"Tåg","Cykel"))

 

Om jag nu vill att Kina och frankrike ska vara "flyg". Kan visserligen lägga in Om igen.

Borde väl gå lägga in funktionen OCH eller funktionen ELLER istället?

Jag testade men får inte till det riktigt.

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Om du har en nyare excel så borde du gilla VÄXLA(). Då slipper du en massa nästlande OM() när du bara skall ta hand om värdet från en cell. Den här länken borde funka i normalfallet (jag har DNS-fel så office.com är oåtkomligt för mig just nu. Vet inte om det är microsoft eller den här datorn som busar)

https://support.office.com/sv-se/article/vÄlj-funktionen-vÄlj-fc5c184f-cb62-4ec7-a46e-38653b98f5bc

Då går det snabbt att lägga till frankrike som eget villkor

I äldre så kan du het enkelt lägga ett "ELLER" i villkoret för Flyg 

=OM(ELLER(A1="Kina";A1="frankerrike");"Flyg";OM(A1="Italien";"Tåg";"Cykel"))

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

eller skapa en lista med nyckelord och ressätt. Bara att söka i denna lista och returnera det som hittas.

Enkelt att bygga ut med fler länder.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Låter kanon. 

 

 

Det här med OCH och ELLER. Har sällan använt ellerfunktion och ochfunktion.

Använder mest Om tycker jag.

När används egentligen och funktionen?  Antar att de används ofta ihop med OM.

 

Om vi nu kan ta ett litet sidospår i detta 🙂. Kanske kan leka med ovan exempel. Intressant. 

 

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...