Just nu i M3-nätverket
Gå till innehåll
Elsaed

Fördela i Excel

Rekommendera Poster

Hej alla.

Fick för mig att jag skulle leka med Excel och inser att leken nu börjat bli jobbig. 

Jag håller på med studier dit klubbar anmäler in ett behov. Sedan har jag en budget att ta hänsyn till.

Så om fem klubbar skickat in behov på 2,5,5,15st utbildningar (27) men budgeten tillåter bara 20st vill jag fördela dessa 20 på fem klubbar MEN den som skickade in 2 ska ju inte ha 5. Samt att jag vill "vikta" klubbarna så exempelvis den som skickat in 2 är mer värd än 5 som är mer värd än 15. Krångligt?

 

Tänker så här: Jag lägger in en "viktningskolumn" ex 0.2, 0.5, 0.3...... som på något sätt visar vilken klubb som har prioritet att få behovet tillgodosett och andra klubbar får mindre. Men återigen en klubb med behov 2 ska ju inte ha mer än just 2 och 20 platser ska fördelas

 

Verkar krångligt så skickar upp excelbladet om ni vill kolla på det.

TEST behov och viktning.xls

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Du kan ju skapa den procentuella vikten relativt enkelt. För klubb 1 blir det t.ex  Antal i klubb1/totalt antal  (2/27) 

I ditt blad

=(B4/$B$33)

Sen mulitplicerar du det med antal platser. Dvs skriv in den här formeln i B37 

=$BH$37*(B4/B$33)

Och kopiera ner till B64.

jag skulle dessutom se till att siffrorna blev avrundade till 0 decimaler:

=AVRUNDA($BH$37*(B4/B$33);0)

Då kan du se i summan på rad 66 om det blir ett avrundningfel någonstans (då får du köra lite manuell korruption och ge/ta en plats någonstans).

 

Eftersom du har lagt "PLATSER EFTER BUDGET denna leker vi med för att få ihop budget" åt andra hållet (kolumner och rubriker har bytt plats) så får du nästan göra varje kolumn formel för sig.

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Tack för den koden. Skulle vilja dock ha att en klubb kanske har mer prioritet än andra eller olika prio. ex klubb 1 o 2 vill jag ska kunna skicka alla sina medan klubb 5 som kvoterar 15 kanske får skicka 5, alltså lägre prioritering av antal platser. Någon extra kolumn med tal som visar på vilken prio och som ger utslag på "tilldelade platser efter budget"?

 

Redigerad av Elsaed

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Gjorde en viktning på procent men får ju då inte summan att stämma riktigt utan får trixa lite 🙂

=$BH$37*(B7/B$33)+BF7 <-- ny kolumn men procentviktning

 

Viktning

100%
50%
50%
-200%
Redigerad av Elsaed

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Du inser att det är personer och inte procent du drar av /lägger till? 

När du skriver + 100% tolkas det som + 1 person och -200% är -2 personer oavsett hur många personer som finns i gruppen.

Dvs I excel/matte är 

100%=1: 50%=0,5: -200%=-2 (procenten är bara ett visningsformat, Högerklicka på cellen och välj formatera cell, talformat, allmänt så ser du det underliggande värdet)

 

Ett helt annat sätt skulle ju vara att bestämma om det skall avrundas upp eller ner med en omsats. Typ:

=OM(BF7=1;AVRUNDA.UPPÅT($BH$37*(B7/B$33);0);AVRUNDA.NEDÅT($BH$37*(B7/B$33);0))

(om det står en etta i "prioriteringskolumnen" BF7 så avrundas det upp, annars ner.)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...