Just nu i M3-nätverket
Gå till innehåll

Rekommendera Poster

Det här håller på att knäcka mig fullständigt.

Får rådata i form av excellakan som exporteras från programvara.

Vill sedan sortera och lyfta ut denna data baserat på datumintervall.

 

Aktuella datum finns i kolumn B i nedan exempel, och jag vill summera data ifrån kolumn C.

 

=SUMMA.OMF(C:C;B:B;">=2019-01-01";B:B;"<2019-02-01")

Ger mig korrekta värden för Januari exempelvis.

men om jag istället försöker mig på att skriva

=SUMMA.OMF(C:C;B:B;">=F3";B:B;"<G3") när jag anger datumspannet i egna celler (F3 och G3) så får jag inget resultat alls.

 

Vad hände med logiken är min stilla undran :)
Har "dummat ned" allt för att testa enl. bif. bild.

 

Tacksam för all hjälp,

 

 

 

 

 

Excel_summa.omf.JPG

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Jag har inte testat din formel, men man ser direkt ett fel:

När du skriver in:

">=F3"

Så blir "F3" en text, inte värdet i cell F3. Den testar bokstavligen ">=F3". Använd sammanfoga eller & och skriv F3 utanför citattecknen för att hämta värdet i F3

dvs ändra villkoret till

">="&F3

eller

sammanfoga(">=";F3)

 

=SUMMA.OMF(C:C;B:B;">="&F3;B:B;"<"&G3) 

Redigerad av MH_resurrected

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Strålande tack för hjälpen, det fungerade.

Kan tycka att det är sisådär när formeln ovan faktiskt är den som genereras av excels dialogrutor när man använder den.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det som är riktigt förvirrande/irriterande är att du kan skriva >= osv utan citationstecken i andra formler. T.ex om du gör en "hemmagjord"  Summa.omf med hjälp av produktsumma:

=PRODUKTSUMMA((A:A>=F3)*(A:A<G3)*B:B)

(villkoren inom parenteserna blir falskt/noll(0) om villkoret inte är uppfyllt så det är bara de rader som uppfyller villkoren som summeras )

Det borde ju gå att göra samma sak i SUMMA.OM också.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...