Just nu i M3-nätverket
Gå till innehåll
RHudson

Olika Ja och Nej ska ge olika svar

Rekommendera Poster

Jag vill att beroende på om det står Ja, Nej eller båda få en specifik summa i de röda fälten. Jag har suttit och testat med olika OMs men får F*n inte till det. Hoppas någon här besitter denna kunskap.

 

Ska lagfart sökas: Ja
Ska det tas ut nya pantbrev:Nej

Bankensarvode: 375
Expeditions avgift: 825
---------------------------------------------------------------
Ska lagfart sökas: Nej
Ska det tas ut nya pantbrev:Ja

Bankensarvode: 625
Expeditions avgift: 375
-----------------------------------------------------------
Ska lagfart sökas: Ja
Ska det tas ut nya pantbrev:Ja

Bankensarvode: 900
Expeditions avgift: 1200
-------------------------------------------------------------
Ska lagfart sökas: Nej
Ska det tas ut nya pantbrev:Nej

Bankensarvode: -
Expeditions avgift: -
 

image.png.d87c875d57ab18793a352e84cb23ac3d.png

=OM(D2="Ja";375;0)

=OM(D3="Ja";825;0)

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Finns säker bättre/snyggare sätt att lösa det på men detta borde funka:

=OM(OCH(D2="Ja";D3="Ja");900;OM(OCH(D2="Ja";D3="Nej");375;OM(OCH(D2="Nej";D3="Ja");625;OM(OCH(D2="Nej";D3="Nej");0))))

=OM(OCH(D2="Ja";D3="Ja");1200;OM(OCH(D2="Ja";D3="Nej");825;OM(OCH(D2="Nej";D3="Ja");375;OM(OCH(D2="Nej";D3="Nej");0))))

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)
48 minuter sedan, skrev Cluster:

Finns säker bättre/snyggare sätt att lösa det på men detta borde funka:

I alla fall kortare: 

Om office 365,2422

=VÄXLA(D2&D3;"JaNej";375;"NejJa";625;"JaJa";900;"NejNej";"-")

Det är en relativt ny formel i Excel. Som gamla VÄLJ, men du kan själv bestämma svarsalternativen. ("Select Case" i VBA och enligt googling: switch/select/inspect i olika språk).

Redigerad av MH_resurrected
Det är svårt att skriva

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
11 minuter sedan, skrev MH_resurrected:

I alla fall kortare: 

Om office 365,2422

=VÄXLA(D2&D3;"JaNej";375;"NejJa";625;"JaJa";900;"NejNej";"-")

Det är en relativt ny formel i Excel. Som gamla VÄLJ, men du kan själv bestämma svarsalternativen. ("Select Case" i VBA och enligt googling: switch/select/inspect i olika språk).

Detta ger mig #NAMN? error.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Som sagt var. VÄXLA() är ganska ny och felmeddelandet  #NAMN? tyder ju på att din excel-version inte känner igen det som en formel. Se kompatibilitet:

https://support.office.com/sv-se/article/vÄxla-funktionen-vÄxla-47ab33c0-28ce-4530-8a45-d532ec4aa25e

 

Du kan naturligtvis bygga en likadan genom att t.e.x använda PASSA/VÄLJ eller PASSA/INDEX, men då försvinner  hela vitsen eftersom Clusters formel är enklare att förstå.

=VÄLJ(PASSA(D2&D3;{"JaNej";"NejJa";"JaJa";"NejNej"};0);375;625;900;"-")

=INDEX({825;375;1200;"-"};PASSA(D2&D3;{"JaNej";"NejJa";"JaJa";"NejNej"};0))

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...