Just nu i M3-nätverket
Gå till innehåll
eken81

Räkna ord i celler, del av cell, OpenOffice Calc

Rekommendera Poster

Har gjort en enkät via Google Forms, men eftersom jag vill presentera resultatet på en bildskärmskanon så har jag tagit ut resultatet och petat in det i OpenOffice Calc. En fråga med ett stort antal kryssalternativ är värdelöst presenterat till det jag vill få ut. Googles egna staplar ser inte alls bra ut eftersom stapel och etikett inte är i linje klokt. Pga att det är 14 olika svarsalternativ.

 

Låt oss säga som exempel att frågan är, vilka är dina favoritfrukter? Varje rad är en svarande och denna fråga hamnar i en cell likt nedan.

 

Citron, Äpple, Päron

Äpple, Mango

Citron, Päron

 

Jag vill enkelt kunna få ut siffror för varje frukt

Citron 2

Äpple 2

Päron 2

Mango 1

 

Kan jag lyckas med detta utan att behöva räkna för hand?

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Bara testat i excel, med det brukar vara samma:

Om ordet bara förekommer en gång per cell så kan du köra ANTAL.OM med jokertecken/Wildcards. T.ex *citron*"

=ANTAL.OM(A1:A3;"*citron*")

 

Om du vill skriva in "sök efter", t.ex  citron i t.ex cell så får du antingen skriva in med jokertecken *citron* eller klippa in dom i formeln. Exempel om du vill skriva in Citron i E1

 

=ANTAL.OM(A1:A3;SAMMANFOGA("*";E1;"*"))

 

 

Om citron kan förekomma flera gånger i varje cell så är det enklaste att strunta i formler och köra ersätt (Ctrl+H i svensk excel).  

Markera cellerna du är intresserad av och kör Ersätt:  sök Citron ersätt med: med Citron-> [Ersätt alla].

Då får du reda på antal ersatta.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej MH,

 

Klurade lite åt samma håll som du och har nu försökt. Kommit så långt i alla fall att jag från error meddelanden nu i alla fall får en siffra, tyvärr är siffran konstant 0.

 

Det där med Sök och Ersätt var klurigt. Har för länge sedan använt mig av samma knep någon gång i Excel. Visade sig dock att OpenOffice Calc inte bryr sig om att räkna ersättningarna. Programmet bara gör dem.

 

Som svar på en fråga du ställde, nej, ett värde i en cell kan bara dyka upp en gång i varje cell/rad. Varje rad är en svarande och värdet dyker upp om personen kryssat i rutan. Men jag vill i detta läget alltså inte veta vilken person har kryssat vilken ruta, utan hur många har kryssat en viss ruta. En viss ruta av flera under samma fråga.

 

Tack för att du försökte och gav mig ideer, men står tyvärr kvar utan en lösning på mitt problem.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...