Just nu i M3-nätverket
Gå till innehåll
MvS

Formelargument ändras vid infogandet av ny rad

Rekommendera Poster

Här är något riktigt mysko som jag råkat ut för:

Har en tabell med data och i en kolumn använder jag funktionen "LETARAD" för att länka information mot en annan flik som innehåller "databasen" eller rådata. Allt frid & fröjd so far, MEN när jag infogar en ny rad i tabellen så ändrar Excel argumentet i min LETARAD-funktion så att kolumnreferensen ökar ett steg (från 9 till 10)! Se bifogad bild.

Image.thumb.png.b7845e83c084af3c7d5d3c53d4414ca8.png 
Någon som kan förklara varför detta sker?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack för snabbt svar!
Jag har ett formulär som infogar ny rad men jag har även prövat att helt enkelt högerklicka på radrubriken och infoga med samma resultat!

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ok´. Jag gömde att testa högerklick. Man får ju inte infoga rader på vanligt sätt. 

 

Jag kan inte replikera. Högerklickar och väljer "infoga rad ovanför". Då ändras formeln som vanligt.

 

Vad händer om du tar bort allt innehåll i kolumnen, utom rubriken och den översta  formeln,  och sedan trycker enter i cellen (så att den autofylls)? Det är ju bara @ delen som skall ändras om excel har fattat att det är en strukturerad formel men om man har joxat runt så kan excel helt plötsligt hantera varje rad för sig och den strukturerade formeln bli något mellanting. Då brukar det enklaste vara att rensa allt utom översta raden.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Japp, nu kan jag replikera.

Om du t.ex har en 8:a i rad 7 och en 9:a i rad 8 så kommer excel att den att tolka det som om du vill räkna upp till en 10:a i rad 9:o.

 

Om du ser till att det är samma formel hela vägen så löser det sig (radera från rad 8 och ner, gå till rad7, [F2], [Enter])

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag har som sagt ett formulär som användare ska kunna lägga till data i tabellen med (se bifogat utsnitt av VBA) och hela poängen med formuläret är att enkelt tillföra data som ska uppdatera sig automatiskt via LETARAD-funktionen. Det verkar ju heltossigt att Excel inte skulle kunna klara detta...

InfogaRad_VBA.txt

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det är en massa Active cell osv så jag vet inte riktigt vad koden gör. Men du har två radinfogningar. 

'Set oNewRow   ....  

Kör radinfogning i tabellen "enligt boken"? Då lägger den till en rad sist och formeln för Letarad utökas som vanligt (utan att byta kolumn).

 

Om du menar 

.EntireRow.Insert Shift:=xlDown

Så funkar det märkligt nog, även om du står i en tabell (det går som sagt var inte att göra manuellt i excel). Formeln uppdateras som vanligt utan att byta kolumnargument. 

 

Återigen. Nollställ kolumnen och låt den autofylla formeln igen. Även om du tycker att formeln ser likadan ut i alla rader. 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Hur gör jag det? Skriver jag =OMFEL(LETARAD([@Db];Tabell6;$I$7;0);"") så returnerar den blankt...

Redigerad av MvS

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det verkar funka om jag skriver =OMFEL(LETARAD($A:$A;Tabell6;9;0);"")

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...