Just nu i M3-nätverket
Gå till innehåll
Stefan Flink

LÖST Beräkna formel om cell är tom, annars noll..

Rekommendera Poster

Hej.

Jag tyckte att jag hade varit duktig och lyckats med beräkning utav flextid, tills jag kom på att det kan förekomma jourjobb. Är man ute på ett jourjobb i 2tim så vill man inte få minus 6tim i flex. Har man haft ett eller flera jourjobb på en dag så fyller man i det i en cell. Min tanke var då att om den cellen ej har något värde så ska det räknas som vanligt och om det finns ett värde så ska flextiden visa noll. 

 

Beräkningen för flextid ser ut så här:

=OM(ELLER(B10="";C10="");0;(G10-$I$6))

 

och mitt försök såg ut så här:

=OM(ÄRTAL(E10);0;(ELLER(B10="";C10="");0;(G10-$I$6)))

Excel skrattar åt mig och säger att "det finns ett problem med den här formeln"

 

Någon som har några idéer??

 

Mvh Stefan

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag gör följande antaganden;

 

Cell I6 är en hel arbetsdags tid, typ 8:00 timmar

B10 och C10 är start och slut för arbetsdagen

G10 är beräkning hur lång arbetsdagen varit

E10 är tom om ingen jourtid utförts annars numeriskt om så varit fallet

 

Mitt förslag är:

H10 är bara ett antagande, du får placera forlemn där det passar dig

Formatera alla tidsceller enligt formatet tt:mm

 

Formel i G10: =OM(ELLER(B10="";C10="");"00:00";C10-B10)

Formel i H10: =OM(ELLER(B10="";C10="");"00:00";OM(ÄRTAL(E10);"00:00";G10-$I$6))

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vet inte vad du vill göra. Men i din formel har du missat ett om:

=OM(ÄRTAL(E10);0;OM(ELLER(B10="";C10="");0;(G10-$I$6)))

eftersom du vill ha ett slags "Annars OM" när det första OMet är falskt

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...