Just nu i M3-nätverket
Gå till innehåll
Go4Iron

LÖST Hitta värde i en cell efter val i cellen bredvid

Rekommendera Poster

Hej.

Jag undrar om någon kan hjälpa mig med formel för en körjournal jag håller på att göra till frugan. Jag har Office 365 på svenska. Fältet "Resväg (från - till)" pekar mot listan under fältet "Resväg till höger genom Data-Dataverifiering. Det jag vill ska hända är när valet är gjort under "Resväg (från - till)" så ska cellen under "Sträcka totalt" hämta motsvarande värde från fältet "Km". i detta fall ska det alltså stå 8,8 under "Sträcka totalt" eftersom "Matmästarna Hovsjö" är valt.

Jag har testat olika teorier jag hittat med bl a PASSA och LETARAD men får inte till det. Tacksam för hjälp!

1645775384_krjournal.PNG.456613441724555e35b42b2f6d84683c.PNG

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Du ska använda formeln LETARAD enligt följande:

Eftersom du inte postar en bild med rad- och kolumnrubriker så har jag antagit att cellen högst upp till vänster med värdet Datum har koordinaten A1 så ska du lägga in följande formel i C2 (första fältet för Sträcka totalt):

 

=LETARAD($B2; $E$3:$F$10; 2; FALSE)

=LETARAD($B2; $E$3:$F$10; 2; FALSKT)

 

Anpassa sedan formeln efter den cellreferenser du nu har i ditt kalkylark.

 

Kopiera sedan formeln i C2 och klistra in i C5, C8, C11 osv.

 

Formeln läser av vilket värde du anger i B2, B5, B8, B11 osv.

Sedan slår den upp i datatabellen $E$3:$F$10, matchar värdet från Resväg.. mot första kolumnen i tabellen och returnerar sedan rätt värde från andra kolumnen.

 

 

Redigerad av Ove Söderlund
Rättade översättningsmiss i formel.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack Ove.

Jag förstår logiken i den formel du föreslår och har ändrat efter vad jag tror och hoppas ska vara rätta värden. Men jag får ett felmeddelande som säger "Fel: Ogiltigt namn". OM du, eller nån annan, har nån mer teori om vad det kan vara så tar jag gärna emot hjälp.

körjournal.PNG

körjournal2.PNG

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ingen fara, det var ganska självtalande ändå när jag tänkte efter 🙂 . Däremot om du vet ett tillägg i formeln så cellen C9, C12 etc är tomma om cell B9, B12 etc är tomma. Det står #SAKNAS! nu vilket såklart är rätt men det skulle se snyggare ut om det var tomt.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Justera formeln enligt följande:

=OM($B2="";"";LETARAD($B2; $E$3:$F$10; 2; FALSKT))

 

Alltså, formeln kollar om B2 (B5, B8 osv) är tom så ska C2, C5 osv vara tom, om inte så letar den upp rätt värde.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...