Just nu i M3-nätverket
Gå till innehåll
Datakajsa

LÖST Felaktig kod på hemsida?

Rekommendera Poster

Vet inte om jag är på rätt ställe att ställa min fråga men jag gör ett försök.Jag har en hemsida som heter www.holkbyn.se.På Indexsidan alltså startsidan har jag lagt ut livesändningar från två fågelholkar som heter Rune och Torsten.Livesändningen sker via NetcamStudio och alla portar är öppna i rotern.

Nu till min fråga.När man från en dator inom mitt lokala nät eller en utomstående dator ska titta på sändningen blir det bara en fyrkant ( se bild jag bifogat) ingen sändning med andra ord.

Det är även helt oberoende av Internetleverantör det spelar ingen roll om det är Telia,Comhem eller någon annan så finns ingen sändning.

Jag har i Routern även prövat att byta DNS utan framgång.

Besöker man däremot sidan med en mobil via 4G fungerar livesändningen.Använder man mobilen via wifi fungerar det inte heller.

Har någon klok människa här något svar på detta?

Mvh Monicafyrkant.thumb.jpg.b31aabbebfe45263d53c8a285be0195c.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag får upp bilder, trots att jag kör via dator och vanligt bredband.

 

Men du har ett script-fel på din sida, ett } saknas. Jag tror det är funktionen LoadImage2 som är felet. Det borde du kolla på.

 

image.png.a7215ea5082946a9d49aaeac0ed1da75.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack för svaret. Kunde du se livesändningen? Men var tror du att jag ska lägga in } i koden?

Med vänlig hälsning Monica

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Inget såg ut att röra på sig. Men om vi provar så här. Vad är det du vill uppnå? Koden i din sida är jättegammal och ärligt talat inte särskilt bra. Den verkar dessutom dubblerad, du verkar ha flera script-taggar med samma kod i.

 

Du har några img-taggar som pekar på en IP-adress. Är det IP-adress till kamerorna? Och är det dessa du vill ska uppdateras med något slags intervall? Jag försökte surfa in direkt på en sådan länk och min browser kraschade vilket är lite oroväckande.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej igen. Först vill jag bara tala om att jag själv inte gjort hemsidan. Tyvärr är den personen som gjort den inte vid liv idag. Vad det gäller kodningen förstår jag ingenting. Jag törs inte ändra på något som jag inte förstår mig på. Det jag lärt mig är hur jag ska uppdatera med nyheter och bilder mm och var jag ska lägga in koden för livesändningen som jag får från NetCamStudio.

Jag har ochså sett i koden att på flera ställen så finns en gammal ip-adress: http://78.73.108.245:8080 vilken inte används idag eftersom jag har en annan internetleverantör. Men som sagt jag törs inte ta bort något.

Vad jag vill uppnå är att man ska kunna se live vad som händer inne i holkarna när fåglarna bygger bo, lägger ägg och slutligen alla fågelungar. Det är många skolor vet jag som brukar titta.

Jag vet inte hur jag ska få till det hela.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag roade mig med att försöka få igång dina videor. Är ganska säker på att jag såg något röra på sig i en av dem, men är inte säker.

 

Så här ser det ut just nu i mitt test, säg till om du upplever att det inte fungerar.

https://www.noodlearray.com/mjpeg/index.html

 

Det bästa av allt vore kanske om du hade haft en kamera som pekar på en klocka med sekundvisare, på så vis är man 100% säker på att något rör sig hela tiden så man kan felsöka. Om fågeln inte är hemma så antar jag att det står ganska still i videon?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Snabb uppföljning, om du laddar ned VLC startar programmet, väljer öppna nätverksström och klistrar in url till en av videosarna, ser du det du förväntar dig då? När jag gör det så ser jag exakt samma sak som på webbsidan. Dvs ingenting rör på sig. Verkar det rimligt?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag tror vi börjar närma oss problemet. Jag kan se på både min sida och din att det rör på sig i Runes kamera. Det är en ljusstrimma som inte fanns där tidigare idag som nu dykt upp och en skugga i den rör på sig.

 

Att du inte ser något beror antagligen på något annat. För du bör kunna komma åt via vlc. Så jag tänker nu misstänka att det är din router som gör fel. Den låter dig inte surfa in mot den IP-adress den exponerat ut på internet. Jag får surfa in på den, därför ser jag videos, både via webbsida och vlc.

 

Så vilken router har du? Och är dessa kameror anslutna till den?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Det stämmer precis det du skriver om ljusstrimman och skuggan. Vad duktig du verkar vara!!!

Huvud routern är en ASUS RT-AC68U  och sedan har jag satt en ASUS RT-AC66U trådlöst  som repeater och kamerorna ansluter trådlöst till den. Jag var tvungen att göra så för att holkarna är så pass långt ifrån.

 

Redigerad av Datakajsa

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
5 minuter sedan, skrev Mikael63:

Har det att göra med att @Datakajsa (s dator) är på samma sida av routern som kameran är?



Jag funderar på om det kan vara så att routern inte tillåter användare på dess lan att komma åt den wan-ip hur som helst.

 

@Datakajsa Vill du prova att logga på inställningssidan till routern och gå in på WAN och sen DDNS.

 

Välj sedan att aktivera DDNS Client, borde fungera att använda asus.com som server, sen skriver du exempelvis holkbyn i textrutan.

 

Om allt gått bra, så borde du sen kunna byta ut IP-adress till videsarna med holkbyn.asuscomm.com. Då kanske det är löst. Fördelen med denna metod är att om din internetleverantör byter din IP-adress så kommer routern uppdatera domännamnet automatiskt så du inte behöver ändra något.

DDNS1.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)
På 2019-04-27 på 16:14, skrev .M:

Så här ser det ut just nu i mitt test, säg till om du upplever att det inte fungerar.

https://www.noodlearray.com/mjpeg/index.html

 

En second opinion: Livefeedsen funkar bägge två. I den högra är det en talgoxe (tror jag) som grejar runt. Den vänstra holken är just nu tom, men man ser på ljus-bruset att det är live.

Redigerad av ChromaWoods

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
9 timmar sedan, skrev ChromaWoods:

 

En second opinion: Livefeedsen funkar bägge två. I den högra är det en talgoxe (tror jag) som grejar runt. Den vänstra holken är just nu tom, men man ser på ljus-bruset att det är live.

Japp, men problemet är att Datakajsa inte kan se dessa när hon använder sin vanliga router. Antagligen pga någon slags inställning. Och ärligt talat så vet jag inte riktigt vad man gör åt det.

 

Det vi kan bestämma oss för är att det är inte fel på koden för det verkar fungera för oss även på hennes sida.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Citat

Tack för att ni engagerar er men jag kan fortfarande inte se något annat än 2 gula bakgrunder.Snällt att ni konstaterat att det inte är koden som är felaktig utan felet måste sökas på annat håll. Min Internetleverantör säger att hos dem finns inga spärrar heller.Ni verkar ju vara väldigt kunniga så alla tips tas tacksamt emot.

Hej igen. Jag vill bara tala om att det inte är jag själv som gjort hemsidan. Det enda jag någorlunda förstår mig på när det gäller hemsidor så är det att uppdatera med nyheter och lägga in bilder mm.Själva koden förstår jag ingenting av. Av den anledningen törs jag inte ta bort någonting i koden som kanske skulle vara kvar. Jag har själv sett att det på några ställen finns adresser till en gammal IP-adress 

Jag har lärt mig var jag ska kopiera in koden som jag får från Netcam Studio-programmet.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

 

Förresten så kom jag på en sak.Kan det ha att göra med Java eller Silverlight på något vis?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej igen.Skulle man kunna använda detta script för att få det att fungera? Är det något jag i så fall måste ändra, t ex detta:

'ws://example.com:8084/ . Och var på hemsidan kan jag klistra in scriptet?

canvasid.thumb.jpg.7a5d38d43d21fd1cc65160ae64ee07c4.jpg

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...