Just nu i M3-nätverket
Gå till innehåll
Mikael63

Transponera/sammanfoga till EN cell?

Rekommendera Poster

Postad (redigerade)

I A2 har jag, från annat, blad, inklistrade värden, som ex. 101

I B2 har jag =OM(A2;A2&"{Enter}";"")

 

Har fyllt ut till rad 130 (så i detta exempel är det värden från 101-229 i A)

 

I C2 skulle jag nu vilja få alla värden från B2 till B130 som

101{Enter}102{Enter}103{Enter}104{Enter} osv.

 

Hur löser man det?

 

Jag kommer att behöva formel, eller makro, då detta ska gå att återanvända med nya/andra värden i A.

Ska dock se om jag kan hitta alternativ i den applikation jag sedan ska använda värdet 101{Enter}102{Enter}103{Enter}104{Enter}

Då behövs inte någon formel, men fram tills dess att jag hittat det så..

 

Tillägg: Ja, eller om jag kan få hjälp med det, att hitta alternativet?

Tanken är att klistra in resultatet i en autohotkey-skriptfil för att med den "verkställa" i en annan applikation.

https://autohotkey.com/docs/commands/Send.htm

Redigerad av Mikael63
autohotkey

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Svarar mig själv för att lyfta bort från obesvarade:

En kollega har hittat en fungerande lösning på detta.

(Hade tydligen klurat på detta samtidigt som jag skrev inlägget)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vilken lösning blev det?

Jag har aldrig fått sammanfoga att funka som matrisformel. Min lösning skulle ha  krävt en hjälpkolumn. Typ

=OM(A2;B1&A2&"{Enter}";"")

Hittade ni något smidigare? Det är ett ganska vanligt problem för mig (i ärlighetens namn funkar hjälpkolumnen utmärkt. Men det är irriterande att ha en massa onödiga mellansteg.)

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ja, det blev en lösning med flera kolumner och flera blad.

 

Resultatet har ="^F9::Send "&SAMMAN(Editera!F3:G202)

(där ^F9::Send bara är extra text)

 

Editera,s G innehåller {Enter} (resultat av en utvärdering)

Editera,s F är samma som E som är samma som D som är samma som C som är samma som B (varför vet jag inte?)

Editera,s B är =OM(A3<>"";A3+$B$2;"") och blir ett omräknat värde beroende på vad man skrivit in i B2

Editera,s A är =OM(INdata!A1<>"";INdata!A1;"")

 

Grunddatat ligger inklistrat i bladet INdata, A

 

(lite mer än vad jag efterfrågade från början)

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...