Just nu i M3-nätverket
Gå till innehåll
Martassen

SummaOmF och wildcards

Rekommendera Poster

Postad (redigerade)

Kan man använda wildcards(jokertecken) i SummaOmf funktionen?

=SUMMA.OMF(D3:D16;B3:B16;H2;C3:C16;H3)

 

Se bifogad bild.

SummaOmf.gif

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Ja/nja ... 

JA

I sökrutan (H2) med text kan du skriva in det direkt. Det här skulle t.ex hitta allt som börjar med grönt

grön*

medan det här hittar både grön och röd

*rö*

och det här hittar bara de gröna (? kräver att det står ett tecken)

?rö*

 

 

Om du alltid vill kolla om texten i H2 finns någonstans så kan du alltid klistra in jokrarna i formeln med hjälp av sammanfoga. 

=SAMMANFOGA("*";H2;"*")

eller

"*"&H2&"*"

=SUMMA.OMF(D3:D16;B3:B16;"*"&H2&"*";C3:C16;H3)

 

 

Nja

eftersom c-kolumnen och H3 är tal så blir det knepigare att söka med wildcards (t.ex *2 för att hitta både 2 och 12). Om det skall funka måste du omvandla allt till text och jag tror inte att det går med antal.omf()

Men du kan exempelvis skriva in 

>0

i cell H3 om du vill hitta alla gröna oavsett vilken siffra som står i grupptillhörighet (men det måste stå en siffra).

 

Redigerad av MH_resurrected
skickade ofärdigt.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Jag hade ingen aning om att man kunde använda exempelvis *b* mm direkt i cellen H3. Trodde man vara tvungen skriva fullständigt. :-). Verkar ju även fungera med SummaOm. Har vetat det går lägga in jokertecken i SummaOm formeln men inte i en dynamisk cell.

 

Ska kolla igenom det andra och återkommer.

Tack

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...