Just nu i M3-nätverket
Gå till innehåll
grer

LÖST Kopiera text från web-läsare

Rekommendera Poster

Sedan många år har jag vid behov kopierat texter, helt eller delvis, från t.ex. dn.se för att spara i en doc-fil. Detta kan tyckas vara helt okomplicerat och självklart att det ska gå att göra så, eller hur. Det är också så jag har förhållit mig till det hela tiden - inget speciellt alls...

 

Med en sedan ett knappt år ny HP laptop med Windows 10 så kan jag inte längre kopiera texter från web-sidor på det sätt jag nämnt. Jag har fem web-läsare men använder i huvudsak bara tre av dem. Det är de tre, Internet Explorer, MS Edge och Firefox som låter sig påverkas av Windows 10´s inställning för högkontrast, d.v.s. där jag får vit text på svart bakgrund i de flesta fönster för ökad läsbarhet.

 

Först nu har jag försökt att klara ut vari kopierings-problemet består, men det var inte lätt... Dock visar det sig att om jag tar upp samma fil i Opera så går det bra att kopiera web-sidan till en doc-fil utan krångel. Samma sak går bra även i Google Chrome.

 

Nu uppstår en rad frågor: Varför går det inte att kopiera från de tre tidigare nämnda web-läsarna - medan det går alldeles utmärkt, som sig bör, i de två web-läsarna där högkontrast-inställningen inte slagit igenom, vilket fått till följd att där har jag fortfarande svart text på vit botten - som jag ändå inte kan läsa...

 

Jag har inte kunnat dra några tydliga slutsatser av nämnda yttringar av respektive web-läsare - men jag tycker ändå att det har något med högkontrast-inställningen att göra, eller hur...

 

Är det någon som känner igen min beskrivning och/eller har liknande erfarenheter från det bejublade Windows 10 - så låt mig få veta vad jag kan göra för att komma till rätta med problemet ifråga.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag har inte win 10 men vad händer om du klistrar in som text? Jag känner inte till något snabbkommando men högerklick eller Ctrl+Alt+V  följt av bokstaven O brukar funka. Det skulle kunna vara så enkelt att det följer med en massa tvingande formateringar som kör över högkontrastnställningarna. 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
59 minuter sedan, skrev Cecilia:

Har du möjlighet att testa webbläsarna utan att ha ställt in högkontrast? 

 

Hur gör du när du försöker kopiera?

Första frågan: Ja, för all del, om det verkligen är nödvändigt - men jag skulle föredra att avstå från det då jag tror att det är mera jobb än att det skulle bidra till en lösning på problemet. Dessutom har jag ju två web-läsare  där kopieringen fungerar varför jag inte gärna vill ge mig på en omställning som jag kanske kommer att ha svårt att återställa. Men, som sagt, om jag måste så...

 

Andra frågan: Jag sätter mus-pekaren, som då har formen av ett stort I, tätt intill första tecknet i texten samt trycker på vänstra mus-knappen, håller den nedtryckt samt drar pekaren nedanför fönsterkanten varvid fönstret scrollas uppåt och all text markeras tills jag stoppar scrollandet genom att dra pekaren in i fönstret igen till slutet på den text som skulle markeras och släpper vänsterknappen. Kopierar med Ctrl C samt paste-ar in den kopierade texten med Ctrl V i en doc-fil. Så har jag alltid gjort för att kopiera stora textmängder till en annan fil... men det kanske finns bättre sätt(?).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
1 timme sedan, skrev MH_resurrected:

Jag har inte win 10 men vad händer om du klistrar in som text? Jag känner inte till något snabbkommando men högerklick eller Ctrl+Alt+V  följt av bokstaven O brukar funka. Det skulle kunna vara så enkelt att det följer med en massa tvingande formateringar som kör över högkontrastnställningarna. 

 

Sorry, men jag förstår inte hur du menar att jag ska göra med vad... Var snäll och förtydliga, tack.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Kan du se att texten blir markerad?

 

Ett annat sätt att markera är att efter man har vänsterklickat använda tangentbordet och där hålla nere Skift-tangenten medan man använder ner-piltangenten (och ev. höger/vänster) tills man kommer till slutet av det man vill kopiera.

 

I stället för Ctrl+C kan man högerklicka och välja Kopiera i menyn som visas då, samt för att klistra in i stället välja det i högerklicksmenyn.

 

Har du prövat med att i stället klistra in i programmet Anteckningar som är enklare än Word och mer tillåtande?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
1 timme sedan, skrev Cecilia:

Har du möjlighet att testa webbläsarna utan att ha ställt in högkontrast?

 

Hur gör du när du försöker kopiera?

Jag har testat de tre som jag skrev om, även i högkontrast utan problem. 

Däremot så vet jag att jag råkat ut för liknande problem, tror det var med Edge, men nu fungerar det iaf.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Svar till Cecilia

 

Nej, Cecilia, texten blir inte markerad som förväntat. Tidigare kunde jag markera texten och en del bilder för kopiering av en hel artikel - men nu blir bara texten fram till nästa bild eller annons markerad och det räcker ju inte...

 

Jo, men att klistra in i Anteckningar är ju ingen vits med eftersom det hela hänger på om texten blir markerad eller inte...

 

Man kan ju markera artikeln med Ctrl A men då får man ju med rubb och stubb allting på den sidan artikeln är på och sedan får man sitta och rensa allt som inte hör till artikeln - så det är inte heller en framkomlig väg.

 

Total förvirring råder, hälsar

 

Göran

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Provat att markera texten baklänges?

 

Alltså ditt sista inlägg drar du markeringen från Göran upp till Svar till Cecilia.

 

Vissa sidor kan vara knepiga att kopiera från eller spärrade.

 

Spara som PDF och kopiera därifrån brukar gå.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
3 timmar sedan, skrev grer:

Ja, för all del, om det verkligen är nödvändigt

 

1 timme sedan, skrev grer:

Jo, men att klistra in i Anteckningar är ju ingen vits

 

De förslag som ges som svar i en tråd är många gånger tänkt som en hjälp i felsökningen och inte som en lösning på problemet som helhet.

Alltså att man, om möjligt kan ringa in problemet, utesluta saker, för att därifrån gå vidare.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Jag har senaste Firefox som borde fungera likadant i alla Windows 10-versioner. (Jag har v 1709.) Prova detta: Från menyn (hamburgarikonen) väljer du Options - > Language and Appearance -> Colors

1449964886_Firefox65ingenbockframfrUseSystemColors.thumb.png.8bd651aee15308eec51ba2ae763fea04.png

Här ser du till att "Use system colors" inte är ibockat och klickar därefter på OK.

Redigerad av mbgtmari

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
9 timmar sedan, skrev Vedex:

Provat att markera texten baklänges?

 

Alltså ditt sista inlägg drar du markeringen från Göran upp till Svar till Cecilia.

 

Vissa sidor kan vara knepiga att kopiera från eller spärrade.

Ja, jag har provat på alla sätt jag kan komma på...

Men på den här eforum-sidan är det inget problem, här kan jag kopiera helt obehindrat...

Det kanske är dags att fråga DN om de försöker kopieringsskydda sina artiklar i dn.se.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
3 timmar sedan, skrev mbgtmari:

Jag har senaste Firefox som borde fungera likadant i alla Windows 10-versioner. (Jag har v 1709.) Prova detta: Från menyn (hamburgarikonen) väljer du Options - > Language and Appearance -> Colors

Hm, i min står det Firefox Quantum 65.0

De bilder du bifogat är ett exempel på sådant jag inte kan läsa och på sådana popup-er som inte låter sig påverkas av högkontrast-inställningen... Hamburgarikonen, vad är det?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
9 timmar sedan, skrev Mikael63:

De förslag som ges som svar i en tråd är många gånger tänkt som en hjälp i felsökningen och inte som en lösning på problemet som helhet.

Alltså att man, om möjligt kan ringa in problemet, utesluta saker, för att därifrån gå vidare.

 

Jag försöker hålla mina kommentarer så kortfattade som möjligt vilket kanske kan uppfattas som ointresse - men jag skriver ju en del annat också som övriga deltagare verkar att förstå, trots allt...

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Mikael63 syftade nog på att du t.ex. inte ville pröva med att kopiera in i Anteckningar, men om problemet är att text inte markeras så är det ju mindre relevant. När jag frågade om det visste jag ju inte om problemet låg i att text inte markerades, att kopieringen inte fungerade eller att inklistringen inte fungerade.

 

1 timme sedan, skrev grer:

Det kanske är dags att fråga DN om de försöker kopieringsskydda sina artiklar i dn.se.

Är det bara på DN du har problem?

Fungerar Ctrl+A på DN?

 

Ett annat sätt att markera är att först vänsterklicka där markeringen ska böra/sluta, skrolla med musen tills man ser andra änden av det önskade området och så hålla nere Skift-tangenten medan man vänsterklickar där markeringen ska sluta/börja.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
25 minuter sedan, skrev Pelle Penna:

Ser att det finns ett tillägg till Chrome som heter Allow Select And Copy

Testa detta

 

Tack, jag ska titta på det.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
1 timme sedan, skrev Cecilia:

Är det bara på DN du har problem?

Fungerar Ctrl+A på DN?

 

Nja, jag vet inte, men det är bara på DN jag försökt kopiera stora artiklar med bilder och allt.

 

1 timme sedan, skrev Cecilia:

Ett annat sätt att markera är att först vänsterklicka där markeringen ska böra/sluta, skrolla med musen tills man ser andra änden av det önskade området och så hålla nere Skift-tangenten medan man vänsterklickar där markeringen ska sluta/börja.

 

Därmed till finalen: Tack Cecilia för att du återigen har kommit med en bra lösning på ett problem! Lösningen fanns i ditt förslag här ovan "Ett annat sätt att markera..." Jag måste säga att i det avseendet, med bra problemlösningar, intar du en framträdande plats i detta forum! Det är åtminstone min erfarenhet.

Nu drar jag mig tillbaka - tills jag stöter på nästa svåra problem och återigen dyker upp här med mina ibland "konstiga" frågor..., hälsar Göran

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Även om problemet löstes med hjälp av Cecilias kopieringsmetod så vill jag i alla fall förklara det som var oklart i mitt inlägg. Jag har Windows 10 version 1709.  Firefox senaste version är förstås Quantum 65.0. Mitt förslag utgick från ditt första inlägg, nämligen att problemet skulle bero på högkontrastinställningen, och då i en senare Windowsversion än den jag har, dvs  version 1803 eller 1809.

 

Längst ut till höger om adressfältet i Firefox hittar man meny-knappen. Den består av 3 vågräta streck och det är därför den kallas för hamburgar-ikonen. Min skärmbild, som du hade svårt att se, visar vad jag får upp om jag klickar på meny-knappen osv. Jag har engelsk version av Firefox så det var därför det stod Options osv och inte "Inställningar" osv som i den svenska versionen.

 

Jag tycker du har förklarat allt väldigt tydligt i dina inlägg och min ambition är också att skriva begripligt i mina.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
1 timme sedan, skrev grer:

Därmed till finalen: Tack Cecilia för att du återigen har kommit med en bra lösning på ett problem! Lösningen fanns i ditt förslag här ovan "Ett annat sätt att markera..." Jag måste säga att i det avseendet, med bra problemlösningar, intar du en framträdande plats i detta forum! Det är åtminstone min erfarenhet.

Tack! :)

Nåja slänger man ur sig 10 förslag så ökar ju chansen för att något stämmer ;)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
3 minuter sedan, skrev Cecilia:

Tack! :)

Nåja slänger man ur sig 10 förslag så ökar ju chansen för att något stämmer ;)

 

Nåväl, var inte så blygsam - det där något som kanske stämmer måste bli framfört på ett övertygande sätt och det är just det som är svårigheten, eller hur... Lycka till fortsättningsvis med alla dina kunskaper!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
44 minuter sedan, skrev mbgtmari:

Jag tycker du har förklarat allt väldigt tydligt i dina inlägg och min ambition är också att skriva begripligt i mina.

 

Hej och tack för ditt förtydligande - och jag förstår nu hur du menar.

Jag tryckte nog lite för hårt på just kopiera - medan det egentliga problemet var markeringen som måste föregå kopierandet. Även Cecilia nämnde att hon inte uppfattat just den saken från början - men numera så framstår väl allt för alla som i "ett förklarat skimmer", hoppas jag.

Och jag kan återigen kopiera långa artiklar med bilder och allt - lätt som en plätt... Tack och hej!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...