Just nu i M3-nätverket
Gå till innehåll
Interactives

LÖST Motion Eye Os

Rekommendera Poster

Hej!

Jag har ett problem som irriterar mig väldigt mycket. Jag har skaffat en Raspberri Pi och av den vill jag göra en övervakningskamera.

Har installerat Motion Eye OS på datorn och allt fungerar som det ska internt utan några som helst problem,

men externt utanför det egna nätverket fungerar den inte. Har provat med Port Forwarding på min router men det fungerar trotts detta inte.

Jag har fyllt i RP:ns ipadress den lokala porten och den externa porten, vilket protocol som man ska ha och sparat det. Det som jag är osäker på

är vilken port man ska ha var. Port 80 lyssnar Motion Eyes HTTP:s server mot och mot port 8081 lyssnar webbkamerans server mot. Har provat

både med att sätta port 8081 externt och port 80 internt och port 8081 på båda ställena mm. Men det fungerar inte. Routern som jag har är en

CH7486E Wireless Voice Gateway från Compal som jag har via Comhem.

Vad ska jag göra? Har inga mer förslag. Det skulle i så fall vara brandväggen som blockar portarna. Där har jag Windows egen brandvägg via F-Secure.

 

Hoppas på hjälp.

Lars Eriksson.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej!

Motion Eye OS är alltså ett operativsystem du kör på din Raspberry Pi?

Hur gör du när du från en "vanlig" dator, i samma nätverk, kollar på det kameran visar? Webbläsare? Annan mjukvara?

Anger du bara ip eller anger du ip och port?

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Motion Eye är ett operativsystem som som körs på RP:n.

När jag sitter vid en vanlig dator i samma nätverk så använder jag

webbläsaren. Då skriver jag bara in ip adressen utan portnummer.

Jag har en app i telefonen som gör att jag kan komma åt RP:n, men det

är fortfarande i samma nätverk. Även där använder jag bara ip numret

och inget annat.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
6 minuter sedan, skrev Interactives:

När jag sitter vid en vanlig dator i samma nätverk så använder jag

webbläsaren. Då skriver jag bara in ip adressen utan portnummer.

Då är det port 80 för det är det som webbläsare använder om man inte skriver in något annat.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

När jag använder den lokala ip adressen, http://xxx.xxx.xx.xx:80, då funkar det men bara lokalt.

När jag försöker att använda den externa ip adressen, http://xx.xxx.xx.xx:80 då funkar det inte.

Alltså utanför det lokala nätverket. Då säger han bara att det tog för lång tid och kontrollera anslutningen.

Detta har jag provat med en mobil där jag stängt av det trådlösa nätverket.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har du dubbelkollat regeln för portforward av port 80?

Du kan också pröva med att använda port 8080 externt och göra en portforward för port 8080 till internt IP med port 80, utifall att routern har problem med port 80 eftersom det är dess egen webbserver också.

 

Som felsökning kan man också sätta den lokala IP-adressen i DMZ om routern har stöd för det, men det ska inte användas permanent eftersom man då öppnar upp enhetens samtliga portar mot omvärlden. Med DMZ kommer trafiken inte att passera routerns brandvägg och regler om portforward ignoreras.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
35 minuter sedan, skrev Interactives:

När jag använder den lokala ip adressen, http://xxx.xxx.xx.xx:80, då funkar det men bara lokalt.

När jag försöker att använda den externa ip adressen, http://xx.xxx.xx.xx:80 då funkar det inte.

Din lokala address är något i stil med 192.168.1.xxx men när du prövar med mobilen utanför nätverket anger du något i stil med 85.194.xxx.xxx

Stämmer det?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
25 minuter sedan, skrev Cecilia:

Du kan också pröva med att använda port 8080 externt och göra en portforward för port 8080 till internt IP med port 80, utifall att routern har problem med port 80 eftersom det är dess egen webbserver också.

Ja, eller någon helt annan port, typ 59208

Att trafik in på 59208 ska slussas till 192.168.1.xxx port 80

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
2 minuter sedan, skrev Mikael63:

Din lokala address är något i stil med 192.168.1.xxx men när du prövar med mobilen utanför nätverket anger du något i stil med 85.194.xxx.xxx

Stämmer det?

Det stämmer.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
6 minuter sedan, skrev Mikael63:

Ja, eller någon helt annan port, typ 59208

Att trafik in på 59208 ska slussas till 192.168.1.xxx port 80

Ska man skriva 192.168.1.xxx port 59208 då?

Eller ska man skriva 192.168.xxx port 80?

Redigerad av Interactives

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag får det att fungera lokalt men inte externt.

När jag använder den externa ip adressen så säger den bara att den tog för lång tid på sig att svara.

Varför?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Kan du ta en skärmavbild på hur det ser ut i routerns inställningar för port forward?

Du kan ju stryka över delar av den externa IP-adressen i Skärmklippverktyget innan du sparar bilden.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har du prövat från en annan publik adress än din egen? Vanligtvis stöds inte anslutning från LAN till den egna WAN-adressen. Har du kollat Netfilters (linuxkärnans brandvägg) inställningar med iptables -L? Iptables är ett program för att ställa in Netfilter. Kan vara att iptables inte ingår som stadard i Motion Eye OS.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
15 timmar sedan, skrev Interactives:

Ska man skriva 192.168.1.xxx port 59208 då?

Eller ska man skriva 192.168.xxx port 80?

ja, 80 i routern men från externt blir det ju 85.123.456.789:59208

 

59208 är bara en helt "random" port för att inte eventuellt krocka med någon "vanlig" port, som kanske din ISP använder för underhåll osv.

 

Blir det någon skillnad om du skriver http://85.123.... ?

Om du ändrar protokoll till https (vid portforward), och använder det i adressen?

 

3 minuter sedan, skrev fagerja:

Har du prövat från en annan publik adress än din egen?

Ts använder en mobil där wifi är avstängt.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

image.png.182ca38731c87d9a3a9fea9ac360912a.png

11 timmar sedan, skrev Cecilia:

Kan du ta en skärmavbild på hur det ser ut i routerns inställningar för port forward?

Du kan ju stryka över delar av den externa IP-adressen i Skärmklippverktyget innan du sparar bilden.

 

Det här är inställningarna i min router. Motioneye os är den undre av det två.

Vad tror du?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
8 timmar sedan, skrev Mikael63:

ja, 80 i routern men från externt blir det ju 85.123.456.789:59208

 

59208 är bara en helt "random" port för att inte eventuellt krocka med någon "vanlig" port, som kanske din ISP använder för underhåll osv.

 

Blir det någon skillnad om du skriver http://85.123.... ?

Om du ändrar protokoll till https (vid portforward), och använder det i adressen?

 

Ts använder en mobil där wifi är avstängt.

När jag skriver in http:// 85.123..... så slutar det att söka för att datorn tycker att det tar för lång tid.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Finns det något på inställningssidorna som heter något med "filtering" som kan göra att begäran från internet blockeras?

Finns det något på sidan "Firewall logs" som visar att något har kommit in vid just de tillfällen som du försöker komma in med mobilen och står det i så fall något om varför det har blockerats?

 

Fungerar den andra regeln om port forward?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
5 timmar sedan, skrev Cecilia:

Finns det något på inställningssidorna som heter något med "filtering" som kan göra att begäran från internet blockeras?

Finns det något på sidan "Firewall logs" som visar att något har kommit in vid just de tillfällen som du försöker komma in med mobilen och står det i så fall något om varför det har blockerats?

 

Fungerar den andra regeln om port forward?

Det finns 3 regler med olika former av "filtering". Mac, IP och Port Filtering. Men det står inget i nått av dem.

Brandvägsloggen säger mig inget. Inget som jag känner igen iallafall.

Den andra regeln har jag inte kollat ännu.

Kan man använda sig av DMZ adress?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Som jag skrev tidigare är DMZ bra för felsökning men inte så lämpligt permanent.

 

När det gäller brandväggsloggen så ha den uppe samtidigt som du gör ett försök med mobilen så ser du om det kommer något i loggen just då.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)
På 2018-12-29 på 19:07, skrev Cecilia:

Som jag skrev tidigare är DMZ bra för felsökning men inte så lämpligt permanent.

 

När det gäller brandväggsloggen så ha den uppe samtidigt som du gör ett försök med mobilen så ser du om det kommer något i loggen just då.

Jag har kollat brandväggens logg som du sade. Under Discription står det TCP- or UDP-based Port Scan och under Target står det 100.XX.XXX.XXX:40384, under Source står det 83.XXX:XXX.1:53. Nu ändrades det som stod under Source till 8.8.4.4:53 och sedan till samma som förut. Allt detta under tiden som jag söker med mobilen för att kunna logga in.

Och som tidigare så går det att logga in när jag är inom  nätverket och inte utanför. Så håller den på.  Den växlar mellan dessa 2 tsl.

Redigerad av Interactives

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har du en fast tilldelad ip-adress från din ISP?

Om inte - har du koll på din externa adress när du testar så att du inte använder en som inte längre gäller?

Har du prövat att ändra till "BOTH" för protokoll?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har din router IP-adressen 100.xx.xxx.xxx nu eftersom Target är det?

 

Source till 8.8.4.4:53

Det är Googles DNS server så det är något helt annat. Port 53 används för DNS-förfrågningar.

 

Kolla vad mobilen har för IP-adress genom att surfa till exempel till https://www.whatismyip.com/.

 

Åtminstone i början med mobilt bredband så fick routern inte en unik IP-adress utan på vägen till internet hade operatören en egen "router" och den stoppade allt från internet som inte var ett svar på något meddelande som gått till internet (eftersom den inte visste vilken kunds anslutningen det var avsett för) och därmed kunde man inte ha en egen webbserver mm. Kan ju vara bra att kolla med Comhem att det ska gå.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

 

Citat

I couldn't access it as I also needed to change the 'Gateway' setting on MotionEye OS.

It is set to a default something like 192.168.1.1

The 'Gateway' setting must be changed to match the IP that you use to log in to your router.

Once I changed that I was able log in to MotionEye OS when away from home.

från https://www.reddit.com/r/raspberry_pi/comments/5qtbos/portforwarding_for_motioneye_os_more_info_inside/

 

Fast det troliga är väl att detta redan är lika...

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
1 timme sedan, skrev Mikael63:

Har du en fast tilldelad ip-adress från din ISP?

Om inte - har du koll på din externa adress när du testar så att du inte använder en som inte längre gäller?

Har du prövat att ändra till "BOTH" för protokoll?

Jag har en fast ip-adress. Ialla fall så är den alltid samma när jag kollar. Både intern och externt. Har kollat med Whatsmyip.com och där är det alltid samma.

Ja det har jag.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...