Just nu i M3-nätverket
Jump to content

2 webbservrar.


przygoda

Recommended Posts

Jag har ett problem. Det kanske inte rör php direkt men jag vet inte riktigt vart jag skall posta det. Det är nämligen så att jag har 2 webbservrar. En PWS och en Apache. Nu till min fråga att efter det att jag har installerat apache så funkar inte mina asp sidor som ligger på PWS när jag startar dem. Det har fungerat tidigare när inte Apache var installerad. På apache kör jag php. När jag startar en asp sida som hämtar data ifrån en Access databas får jag följande medelnade:

 

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

 

[Microsoft][ODBC Microsoft Access Driver] Selected collating sequence not supported by the operating system.

 

/prj/index.asp, line 6

 

Skulle uppskata att få hjälp med att få båda att funka. Behöver inte funka samtidigt. Men jag vill gärna att PWS funkar när Apache är avstängd och vice versa.

 

Tack för all hjälp.

Link to comment
Share on other sites

Låter väldigt krångligt att få flera webbservrar att funka på samma dator.

 

Du kan inte köra apache på en annan dator å ha i garderoben typ?

 

Eller så konfigurerar du någon av webbservrarna att köra på en annan port än 80 - då kanske du kan köra båda parallellt...

 

Link to comment
Share on other sites

Är det ens möjligt?

 

Eftersom jag mest håller på med apache(php) så vill jag ju helst inte ha den i garderoben. PWS(asp) vill jag ju oxå ha att tillgå.

 

Hur konfiguerar man Apache eller PWS att köra på nån annan port än port 80?

 

Tacksam för mera hjälp.

 

Link to comment
Share on other sites

Hur konfiguerar man Apache eller PWS att köra på nån annan port än port 80?

 

Låter som ett fall för readmefilerna?

 

Apacheporten stoppar man väl in i httpd.conf eller vad den kan heta under Windowsporten ;)

 

-

 

Tänkte mest att det är lärorikt att ha en separat webbserver (kör något unix-system på den) som apacheserver när man utvecklar, så man har något att utveckla och testa mot :)

 

Link to comment
Share on other sites

Det låter inte som något fel på varken PWS eller Apachen utan mer på MDAC:en. Alltså de filer som kommunicerar med Access.

 

Testa att ladda ner den senaste från ms sida och installera.

 

----------------------------------------

- Magnus

- Nemo Saltat Sobrius

 

 

Link to comment
Share on other sites

Drog ner Microsoft Data Access SDK 2.1 Updater Files for x86 och nu funkar allt igen. Tack för hjälpen. Uppskatar det verkligen.

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...