Just nu i M3-nätverket
Gå till innehåll
zenap81

Kopiera formler! Hur gör du??

Rekommendera Poster

Hej.

 

Har blivit lite låst på en troligt vis enkel lösning!

 

jag har information i blad 1 på A2,A3,A4 - a14000.

 

infon i blad 1 på A2 vill jag ha blad 2 på, A2 även där. Men nu kommer vi till problemet.

 

nästa information som finns i blad 1, A3 ska jag ha på blad 2 A12, blad 1, A4 ska vara på blad 2 A22 osv.

 

lätt att skriva in manuellt kan tyckas med jag ska göra så här ca 14000 gånger. ;(

 

Tack så länge!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skriv in formeln i den första cellen. Kopiera. Gå till sista rad du vill ha formeln på. Tryck ned ctrl+shift+ pil upp, markera allt, och klistra in.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Om du vill ha en ren formellösning så får du nog lägga in en formel på blad2 som 

1. Kolla om man är på en x2-rad (a2, a12, a22 osv) , om inte - fyll cellen med tomt värde.   OM(REST(RAD()-2;10)<>0;""

2. om du är på en x2 rad- Hämta värdet från rätt rad i blad 1, t.ex med hjälp av index INDEX(Blad1!A:A;HELTAL((RAD()-2)/10)+2)

 

Något i den här stilen i A2 och kopiera ner:

=OM(REST(RAD()-2;10)<>0;"";INDEX(Blad1!A:A;HELTAL((RAD()-2)/10)+2))

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Alternativt, fyll i den här formeln i A2:

=INDEX(Blad1!A:A;HELTAL((RAD()-2)/10)+2)

markera området A1:A11

Nu kan du kopiera eller "dra ner" området och det hamnar en formel på var 10: rad .

det är lättast att "dra" med musen. Om du kopierar oså måste du vara väldigt noga när du markerar området du skall klistra in på. Det måste börja i A12 och sluta i en cell  med en AX1 adress (Typ a140011).

Fördelen med den här metoden jämfört med den rena formelvarianten är att du slipper en massa formler som bara returnerar ""

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej och tack för svaren!

 

Har kommit en bra bil i min "onormala" lista!

 

Nu behöver jag lägga in en formel typ A2:A10 och nedåt. A 11 får inte röras

 

Så här

A2:A10 =OMFEL(OM(SÖK("https";C2);B1;"");"")

A11 får inte röras

A12:AA20 =OMFEL(OM(SÖK("https";C2);B1;"");"")

A21 får inte röras

 

OSV till typ 140 000 rader!

 

Går detta med er hjälp?

 

Tack så länge!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...