Just nu i M3-nätverket
Gå till innehåll
Joice

Räkna antal förekomster text i fler flikar

Rekommendera Poster

Jag har försökt hitta en lösning på att räkna text i samma kolumner fast i olika flikar.

Jag har text i A1-A9 i flera flikar och vill sammanställa hur många jag har av ett visst ord.

Är det någon som kan hjälpa mig?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

För att lösa detta medhelst formler så behöver du ett sammanställningsblad med en tabell som listar flikarna i din arbetsbok, ladda hem min exempelfil så förstår du hur jag menar.

Det finns andra lösningar men det involverar att ladda hem och installera tredjeparts-verktyg till Excel.

 

=PRODUKTSUMMA(ANTAL.OM(INDIREKT("'"&A2:A4&"'!A1:A9");B2))

Exempeldokument som visar hur formeln fungerar i praktiken:

eForum 180614 - Räkna antal förekomster text i fler flikar.xlsx

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

ANTAL.OM fungerar tyvärr inte som  3D formel. Annars hade det varit en baggis.

 

Men om det bara är några få blad kan du hålla det enkelt och göra en sökning för varje blad, sen summerar du antalet träffar. Enkelt men formeln blir lång om du har många blad: 

=ANTAL.OM(Blad1!A1:A9;"SöktOrd")+ANTAL.OM(Blad2!A1:A9;"SöktOrd")  osv (Ett slags manuell variant av Oves formel)

 

Ovanstående hittar hur många gånger SöktOrd står ensamt i en cell

 

Den här hur många det förekommer i en text (även om det inte är ensamt)

=ANTAL.OM(Blad1!A1:A9;"*SöktOrd*")+ANTAL.OM(Blad2!A1:A9;"*SöktOrd*")   osv

 

Eller så här om du vill skriva sökordet i cell E5 istället för att hårdkoda det

=ANTAL.OM(Blad1!A1:A9;"*"&E5&"*")+ANTAL.OM(Blad2!A1:A9;"*"&E5&"*")   osv

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×