Just nu i M3-nätverket
Gå till innehåll
AnnaK

Ogiltlig formel i dynamisk kalender

Rekommendera Poster

Hej,
Jag har laddat ner en dynamisk kalender här; https://www.excelbrevet.se/wp-content/uploads/2015/03/DynamiskKalender-Excelbrevet1.xlsx

Filen fungerar fint och jag har kunnat kopiera in fler flikar och ändrat ordinarie kalender 2015 till andra år. Men det är något fel med formlerna när det gäller veckonummer.  Formel för vecka 1: ="v."&VECKONR(A3;21) resp formel för vecka 2: =OM(B7=2;"v."&VECKONR(A7;21);"") med fortsättning vecka 3-52 på samma sätt som vecka två fast med annan cellhänvisning på kolumn B.

 

Hur ska jag ändra så att formlerna fungerar för veckonummer?

 

Tack på förhand!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

vad får du för fel?

 

Laddar hem och och tittar på boken och allt ser rätt ut för mig.

Vilken version av Excel kör du? formeln veckonr har ändrats sedan, kan det vara, excel 2012?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
På ‎2018‎-‎03‎-‎11 på 12:23, Monshi säger:

vad får du för fel?

 

Laddar hem och och tittar på boken och allt ser rätt ut för mig.

Vilken version av Excel kör du? formeln veckonr har ändrats sedan, kan det vara, excel 2012?

Oj, jag har inte tänkt på vilken version, nu var jag tvungen att kolla och det var "ännu värre" dvs jag har office 2007... På temat, går det att uppdatera lr är det till att köpa ny version om jag vill ha nyare?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Söker lite och hittar, för Excel 2007

Från den tråden

=HELTAL((A1-DATUM(ÅR(A1-REST(A1-2;7)+3);1;2)+REST(DATUM(ÅR(A1-REST(A1-2;7)+3);1;2);7)+5)/7)

iställer för veckonr som i Excel 2007 bara har två returtyper.

 

Uppgradera, Office 365 är nog det som gäller nu.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Använder Office 365 nu och den dynamiska kalendern fungerar fint. Försöker dock hitta formeln för att lördagar blir grön och söndagar röd. Skulle vilja kunna ändra och inte ha ngn bakgrundsfärg. Något tips på hur jag gör det? Tack på förhand!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×