Just nu i M3-nätverket
Gå till innehåll
filuren72

Letarad med sökväg

Rekommendera Poster

filuren72


Följande rad vill jag ändra på så att den "hämtar" bl.a. sökväg i en annan cell. Är det möjligt?

=LETARAD(VECKODAG(C10);'F:\Mina Dokument\XLS\[Sportdatabasen.xlsx]kalender'!$L$10:$M$16;2;0)

Kolumn A        Kolumn B
Rad 1 Sökväg        F:\Mina Dokument\XLS\
Rad 2 Fil        Sportdatabasen.xlsx
Rad 3 Blad        kalender
Rad 4 Övrigt        !$L$10:$M$16


Raden nedan funkar inte
=LETARAD(VECKODAG(O16);SAMMANFOGA(B1;B2;"!";B3;"'";B4);2)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MH_

1. Din sammanfoga är fel. Om data står som de gör i ditt exempel så skall det vara:

SAMMANFOGA("'";A1;"[";A2;"]";A3;"'";A4)

 

2. För att excel skall förstå att du skapat en adress så måste du använda INDIREKT

INDIREKT(SAMMANFOGA("'";A1;"[";A2;"]";A3;"'";A4))

 

3. (det tråkiga). Av någon anledning fungerar inte indirekt mot stängda arbetsböcker.

Så, om du stänger sportdatabasen så kommer den här formeln fortfarande att ge rätt svar:

=LETARAD(VECKODAG(O16);'F:\Mina Dokument\XLS\[Sportdatabasen.xlsx]kalender'!$L$10:$M$16;2)

Medan den här ger ett felmeddelande. 

=LETARAD(VECKODAG(O16);INDIREKT(SAMMANFOGA("'";A1;"[";A2;"]";A3;"'";A4));2)

 

Tråkigt men, så är det.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Nä, mer avancerade formler fungerar inte mot stängda.

INDIREKT och FÖRSKJUTNING, fungerar inte exempelvis.

Om lite färre alternativ kan du alltid bygga upp formler med exakta referenser och välja ut vilken du ska ha.

Eller skapa en VBA-snurra som uppdaterar koden med en fast referens. Det kan gå.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...