Just nu i M3-nätverket
Gå till innehåll
Mikael63

Skräptecken vid utskrift.

Rekommendera Poster

https://eforum.idg.se/topic/353945-moraliskt-stöd-ang-kasta-ut-vista-önskas/?p=1690578 skrev jag om en bärbar som fått nytt liv m.h.a. Linux Mint.

 

Har nu stött på ett problem, ett problem som jag även ställt en fråga om i annat forum men behöver massor av inputs innan  jag försöker lösa detta via fjärruppkoppling.

 

Skrivaren skriver skräptecken lite när den behagar.. 
 
Skrivaren är en DELL B1260dn och jag hämtade drivers från från Dells hemsida; B1260dn_Linux_v1.03_Driver.tar.gz
 
Det var lite "bök" innan jag kunde installera eftersom körning av install.sh i cdroot\Linux inte fungerade men den pekade i sin tur på cdroot\Linux/noarch/utils/start_install.sh vilken gick att köra och gav ett MS Windows-stuk på den fortsatta installationen.
Skrivaren installerades alltså och en testutskrift fungerade. Det installerades även någon "DELL printer Managment.."
 
Utskrifter via den medföljande Xreader (PDF) gav skräptecken vid test varför Acrobat Reader installerades och där fungerade utskrifterna.
Utskrift från nätet - typ Blocket, banken osv. ger också bara skräptecken.
Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Utskrift från nätet - typ Blocket, banken osv. ger också bara skräptecken.

Tyder på att din webbläsare har problem med kompatibiliteten med  Dells drivrutiner.

Det går ju att skriva ut om du skriver ut en .pdf med Acrobat Reader.

 

Har upplevt det här själv. Med Linux Mint 17.3. Inga problem skriva ut från Apache Open Office.

Omöjligt skriva ut från Firefox. Med de drivrutiner som Linux Mint förslog till Brother HL-5470DW.

Men efter jag laddat ner skrivardrivare från Brother. Drivar som i själva verket var ett installationsprogram för drivare

för när jag väl startade programmet så satte det igång med att dra ner en massa filer från Internet.

Och med allt det paketet av filer installerat så funkar utskrifterna utan problem.

Oavsett vilket program som jag vill skriva ut från.

Redigerad av jannejanne

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ja, det var ju bra för dig... men att ladda ner drivrutiner från tillverkaren har jag ju gjort redan...

 

Nåja, jag har några andra uppslag att pröva i morgon när jag fjärransluter till den krånglande datorn..

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vad har du för teckenkodning? Kommandot: locale charmap visar vilken teckenkodning, som används. Jag rekommenderar att använda UTF-8. Vid behov kan en fil konverteras från en kodning till en annan med iconv eller recode.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Återkoppling/ händelseförlopp i kronologisk ordning:

Igår kunde jag fjärransluta och tog då bort skrivaren. Kunde inte lägga till en skrivare eftersom den var avstängd och användaren inte var hemma.

Idag hade användaren startat skrivaren och den hade "lagt till sig själv" igen.

Tog bort den. Avinstallerade Dell Unified driver, som hade installerats i paketet från Dell.

La till skrivaren på nytt men nu enligt tips från https://superuser.com/questions/637179/dell-b1260dn-printer-linux-open-source-driver (Dock inte som nätverksskrivare, som fallet i den tråden).

Prövade utskrift från LibreOffice = OK

Acrobat Reader = OK

Firefox och där en "Skriv ut"-knapp = FEL

Chrome och samma skriv ut som ovan = OK

Chrome och högerklick-skriv ut = OK

Tillbaks till FF och letade högerklick-skriv ut men hittade inte, valde skriv ut från menyn = OK

 

Så långt trodde jag att jag begränsat felet till att det uppstår när man väljer att skriva ut via en sådan "Skriv ut"-knapp och då enbart i FF.

Detta stämmer också efter "felanmälan" från användaren.

 

För att verifiera detta prövade jag åter Firefox och där en "Skriv ut"-knapp. Resultatet = OK. (!)

*suck*...

 

Just nu inget fel men det lär ju dyka upp igen och jag har bett användaren att direkt notera vad som gjorts, vilken webbläsare, vilken hemsida osv.

 

Kommandot: locale charmap visar teckenkodning UTF-8.

 

Jag tar fortfarande emot bra-att-kolla-saker så att jag har något att gå efter om(när) detta händer igen.

 

 

(postar detta i annat forum också)

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Att det blir fel teckenkodning i en webbläsare beror oftast på att använd teckenkodning inte är angiven eller att fel kodning anges. Felet ligger då på webbsidan. Webbläsaren försöker lista ut använd kodning och konverterar vid behov koden till den kodning, som är angiven i miljövariabeln LANG. Fungerar begränsat från UTF-8 då UTF-8 har 136000 olika tecken och ISO-8859 serien har endast 256. De 128 första tecknen har samma kod i UTF-8 och ISO-8859. 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×