Just nu i M3-nätverket
Gå till innehåll
bonjati

Fel vid letarad

Rekommendera Poster

bonjati

Hej!

Har stött på ett något märkligt problem. Jag försöker köra letarad funktionen där den utifrån ett organisationsnr ska hämta företagsnamnet till en lista. Trots att all info finns får jag upp #saknas. Då är allt formaterar som tal. (Vilket ju är brukligt)

 

Om jag däremot formaterar fälten (orgnr) som text så går det men bara om jag trycker enter i varje enskild cell. (vilket inte är särskilt praktiskt)

 

Tidigare när jag har haft problem med formuler har det hjälpt med markera område+ F2+enter men inte nu :/

 

Någon som jag säga vad det är för lurt här? Kör Excel 2016btw. 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
lasse67

Hej!

Har stött på ett något märkligt problem. Jag försöker köra letarad funktionen där den utifrån ett organisationsnr ska hämta företagsnamnet till en lista. Trots att all info finns får jag upp #saknas. Då är allt formaterar som tal. (Vilket ju är brukligt)

 

Om jag däremot formaterar fälten (orgnr) som text så går det men bara om jag trycker enter i varje enskild cell. (vilket inte är särskilt praktiskt)

 

Tidigare när jag har haft problem med formuler har det hjälpt med markera område+ F2+enter men inte nu :/

 

Någon som jag säga vad det är för lurt här? Kör Excel 2016btw. 

hej 

 

har du kollat så du inte har några dolda tecken eller mellanslag i någon cell? prova med RENSA  eller STÄDA. 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
bonjati

hej 

 

har du kollat så du inte har några dolda tecken eller mellanslag i någon cell? prova med RENSA  eller STÄDA. 

Hittar inget av de varan. En enkel siffersträng.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Och dina data är inte lagrade som text?

Talet 0 är vitt skiljt från strängen "0"

 

Testa sök vid LETARAD(G2&"";....)

och se vad som sker.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
lasse67

någonting jag upptäckt är jag markerar alla celler i en kolumn och högerklickar och väljer formatera celler och formaterar som tal så funkar inte det. däremot så om jag markerar hela kolumnen och sedan tittar efter det där lilla tecknet till vänster om kolumnen som följer med och klickar på den och väljer "Tal" så funkar det. har ingen aning om varför det är så men det funkar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Om det är blandat text och tal och du vill ha det som tal skriv in värdet 1 i en cell. Kopiera denna cell och klistra in special, enbart värden, multiplicera.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
bonjati

Jag har ett register med organisationer med tillhörande organisationsnr.

I ett register vill jag ta namnet på organisationen från flik B till Flik A. Det är alltså bara siffror den ska leta efter i formeln.  

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
bonjati

Prövade

=LETARAD([@OrgId]; RENSA(Huvudman!A:;2;FALSKT)

Men då fick jag #Värdefel! Istället för #Saknad!

 

Testade också 

=LETARAD(RENSA([@OrgId]); RENSA(Huvudman!A:;2;FALSKT)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Rensa fungerar nog inte på matriser, ger därför #Värdefel

 

men du kan testa

 

=PASSA("*" & G2 & "*";A1:A100;0)

=PASSA(G2 &"":A1:A100;0)

=PASSA(G2 *1;A1:A100;0)

något av det borde ge ett svar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...