Just nu i M3-nätverket
Gå till innehåll
Znorkel72

leta och markera värden Excel 2010

Rekommendera Poster

Hej

 

jag har en lagerdatabas i excel där bland annat artikelnummer , ordernummer och lagerplats finns med.

 

i den listan vill jag få fram alla de raderna som som har samma artikelnummer och ordernummer som har olika lagerplatser, dvs de artiklar som ligger på fler än en lagerplats från respektive order.

 

detta för att få fram en lista där man ser de artiklarna som har fler än en plats per order.

 

 

 

mvh

Peter

 

 

 

Excelsortering fråga eforum.xlsx

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Kan du skapa en hjälpkolumn, t.ex kolumn F?

Om du klistrar in den här formeln i F2 och kopierar ner så får du en siffra på alla rader som har dubbletter:

=ANTAL.OMF(B:B;B2;C:C;C2;D:D;"<>"&D2)

Eller så här om du vill ha 1/tomt:

=OM(ANTAL.OMF(B:B;B2;C:C;C2;D:D;"<>"&D2)>0;1;"")

Sen kan du filtrera eller sortera på kolumn F  -  Tänk bara på att det är ganska omfattande beräkningar för excel. 

 

En bättre variant kan vara att sortera enligt Oves förslag och sedan köra en formel i F-kolumnen som bara tittar upp/ner en rad:

=ELLER(OCH(B2=B1;C2=C1;D2<>D1);OCH(B2=B3;C2=C3;D2<>D3))

Då kan du filtrera fram de rader som är dubbletter (Nackdelen är att du inte får ändra på sorteringen, vill du sortera måste du först "döda" formeln i kolumn F genom att kopiera och klistra in som värde)

 

Om du nöjer dig med en färg-markering så kan du färga raderna med hjälp av villkorsstyrd formatering baserat på värdet i Kolumn F

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...