Just nu i M3-nätverket
Jump to content

Sortera om data i excel


Skrutt

Recommended Posts

Hej!

 

Ur ett system har jag exporterat  en lista med personer och "objekt" till excel. Problemet är att det redovisas en person och objekt per rad, vilket medför att en person som är kopplad till flera objekt syns på flera rader i listan

post-47790-0-17583400-1475833162.png

 

Antalet objekt som personerna i listan är kopplade till varierar - i mitt exempel ovan varierar det mellan två och fem objekt per person, men i min skarpa lista kan det variera från bara ett eller två, till långt över 30.

 

Jag skulle vilja kondensera listan så att varje person bara finns med på en rad, och att alla objekt som hen är kopplad till visas kommateckenavgränsat i en enda cell

post-47790-0-57405200-1475833180.png

 

Är detta möjligt att fixa på något enkelt sätt?

Link to comment
Share on other sites

Allt går, men om det är smidigt vet jag inte.

 

Förutsättning: listan är sorterad efter namn.

Kopiera kolumnrubrikerna namn/objekt till C1 och D1

 

Skriv in följande formel i C2

=OM(A2<>A3;A2;"")

och den här i D2

=OM(A2<>A1;B2;SAMMANFOGA(D1;", ";B2))

Kopiera ner formlerna till sista ifyllda rad (rad 13 i ditt exempel) . 

 

Kopiera kolumn C och D och kör "klistra in special"->värden för att "döda formlerna"

Om du sorterar efter namn och raderar de rader som  saknar namn så får du väl det du vill ha?

 

inte speciellt elegant men ganska snabbt. 

 

Tack så jättemycket, precis vad jag behövde!

I mina ögon så är den här lösningen alldeles lagom elegant  :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...