Just nu i M3-nätverket
Jump to content

Ersätta värde


Akutssk

Recommended Posts

Hej!

Jag har ett excelark med över 200000 rader. Varje rad har ett ID. Detta ID kan förekomma en gång eller flera hundra gånger.

Jag skulle nu vilja ersätta detta värde med en "ersättningskod" som gör att man inte kan härleda vilket ID det varit.

 

Har börjat ersätta ID manuellt, men inser att detta kommer ta en låååång tid...

I bifogad fil ser ni ett ex. på hur det ser ut. I Kolumn A finns ID och i kolumn B har jag skrivit in en "kod", en bokstav som ökar varje ID.

 

Någon som har förslag på hur detta skulle kunna automatiseras?

 

Tack på förhand!

 

/Akutssk

Ersätta med kod.xlsx

Link to comment
Share on other sites

Ove Söderlund

Detta är nog inte en så svår sak att lösa, men jag undrar bara om det är just bokstäver du önskar ha? Det blir lite knepigare, men går säkert att lösa när du kommer till 'Z' (eller 'Ö') och ska fortsätta med 'AA', 'AB', osv..

 

Detta går mkt enklare att lösa om koden kan vara en siffra istället, är det en acceptabel lösning för dig?

 

Ett annat alternativ kan vara att köra med ett löpnummer i stil med ID1, ID2 (ev. använda nollvärdesutfyllnad typ ID00001) osv...

Link to comment
Share on other sites

Ove Söderlund

Som jag och MH_resurrected är inne på så är löpnummer enklaste metoden.

 

1. Sortera din lista på ID-kolumnen (kolumn A)

2. Jag antar att listan har kolumnrubriker på rad 1

3. Infoga kolumn efter kolumn A om det inte finns en tom kolumn där

4. Skriv in värdet 1 i cell B2

5. Skriv in följande formel i cell B3: =OM(A3=A2;B2;B2+1)

6. Autofyll/kopiera nedåt till listans slut

7. Ta bort formlerna i kolumn B genom att markera hela kolumnen och kopiera, därefter markera kolumnen igen (om den avmarkerades) och klistra in special, endast värden.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...