Just nu i M3-nätverket
Jump to content

Jämföra kolumner


Martassen

Recommended Posts

Jag har en uppställning. Se bifogad bild.
Om B2 även finns någonstans i Akolumnen så ska dess värde returneras i B1. Om det i B2 ej finns någonstans i Akolumnen så ska "Saknas" returneras.

 

Jag ställde mig i C2 och gjorde följande formel:
=LETARAD(B2;$A$2:$B$4;1;0). Därefter kopiera jag ner och det blir som bifogad bild.
Tänker jag rätt när jag använder Letarad?

 

 

Fråga2:
Av nyfikenhet kan jag inte låta bli fråga. Hur gör man ifrån båda hållen?

Om vill i D2 ha en formel som gör:

Om namnet finns någonstans i båda kolumnerna. Spelar ingen roll vart i kolumnerna så ska dess värde returneras annars ska  "Finns ej i båda" returneras. Ska jag köra 2 letarad?
Därefter kopiera ner formeln.

 

Fråga3:
Ett annat sätt att kolla om ett värde finns i båda kolumnerna. Jag står i E2.
Lägger in formeln:
=OM(OCH(ICKE(ÄRSAKNAD(PASSA($A$2:$A$100;$B$2:$B$100;0))));"Finns i båda";"")

 

Denna formel kollar väl bara hela tiden om värdet finns i båda rakt över?
 

Tacksam för tips

 

Link to comment
Share on other sites

1 ©. smaksak. Man jag skulle nog ha använt antal.om() för den första delen, bara för att det blir tydligt och en snygg övergång till 2:an :-)

=OM(ANTAL.OM(A:A;B2)>0;B2)

=OM(ANTAL.OM(A:A;B2)>0;B2;SAKNAS())

 

2 (D). Antal.omf() där du kollar i både A och B kolumnen

=OM(ANTAL.OMF(A:A;B2;B:B;B2)>0;B2;"finns ej i båda")

 

3.orkar inte...

Ok. Hur skulle det se ut om jag använder letarad på punkt2?

Link to comment
Share on other sites

Rekommenderar inte matrisformel om du har stora tabeller då denna typ av ekvationer är mycket beräkningsintensiva. Inget problem i mindre tabeller,det orkar alla datorer med  men om tabellerna växer till några tusen raden kan du ha ett prestandaproblem på din hals.

Link to comment
Share on other sites

  • 2 weeks later...

Mmh, den där formeln är ju lite kaka på kaka. Argument två är ju alltid sant och behövs inte.

=OM(ÄRFEL(PASSA(B2;$A$2:$A$6;0));"Finns ej i A";"Finns i A")

är mer korrekt i detta fall.

Eller om du vill använda antal.om

=OM(ANTAL.OM($A$2:$A$6;B2)=0;"Finns ej i A";"Finns i A")

Link to comment
Share on other sites

Japp.

 

Jag snurra nog till det när jag tänker ifrån båda hållen :-).

 

Om finns i A kolumn ska värdet returneras + finns i A
Om finns i B-Kolumn. ska värdet returneras + finns i B.
Om finns i B och C ska värdet returneras och Finns i båda.

 

Blir nog mekigt :-).

 

Det är ok vi skippar det :-).

 

Tackar för all hjälp.

 

 

Link to comment
Share on other sites

Nja, inget problen

 

=OM(ÄRFEL(PASSA(D2;A1:A10;0));"Finns ej i A";"Finns i A")

=OM(ÄRFEL(PASSA(D2;B1:B10;0));"Finns ej i B";"Finns i B")

=OM(OCH(ICKE(ÄRFEL(PASSA(D2;B1:B100));ICKE(ÄRFEL(PASSA(D2;C1:C10;0)));"finns i båda";"Finns ej i båda")

 

Skriva på frihand, kan finns småfel i. Bara att kombinera ihop dem till det du vill ha.

Link to comment
Share on other sites

Körde första formeln i bifogat exempel. Öl finns ju :-).

 

Provade sedan sista formeln men den börjar bråka. Den säger "För många argument".

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...