Just nu i M3-nätverket
Jump to content

Räkna namn i en kolumn.


akno

Recommended Posts

Jag har i Excel 2010 en tabell med Förnamn Efternamn plus diverse andra data på ca 12000rader. Jag vill kunna räkna hur många gånger ett specifikt förnamn förekommer men har inte lyckats klura ut hur.

 

Bland formler för statistik finns ANTAL.OMF men den fungerar inte om personen har flera förnamn där sökt namn ingår. Med den får jag bara med de som har endast det namn jag söker. Har försökt skapa ett makro som går igenom förnamnskolumnen och räknar igenom på hur många rader namnet jag söker förekommer men inte lyckats få till det. Jag är för dålig på att skapa Makron och behöver all hjälp jag kan få.

 

Akke

Link to comment
Share on other sites

Hej!

 

Menar du att förnamnskolumnen kan innehålla flera namn, typ "Adam Bertil"? I så fall hade jag lagt till en kolumn med följande formel för varje rad:

=OMFEL(HITTA($D$1;A1)>0;0)*1

 

I mitt exempel står det eftersökta namnet i cell D2 och förnamnen i A-kolumnen. Hitta() letar efter en given sträng i en annan sträng och returnerar startpositionen. Formeln ger alltid 1 om ett namn ingår i förnamn eller 0 annars, sedan är det bara att summera Hitta-kolumnen för totalt antal träffar.

 

/Johan

Link to comment
Share on other sites

Hej!

 

Menar du att förnamnskolumnen kan innehålla flera namn, typ "Adam Bertil"? I så fall hade jag lagt till en kolumn med följande formel för varje rad:

=OMFEL(HITTA($D$1;A1)>0;0)*1

 

I mitt exempel står det eftersökta namnet i cell D2 och förnamnen i A-kolumnen. Hitta() letar efter en given sträng i en annan sträng och returnerar startpositionen. Formeln ger alltid 1 om ett namn ingår i förnamn eller 0 annars, sedan är det bara att summera Hitta-kolumnen för totalt antal träffar.

 

/Johan

Tack för hjälpen, det fungerar OK.

 

/Åke

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...