Just nu i M3-nätverket
Gå till innehåll
Grimrath

msiexec.exe använder alla resurser och fryser datorn

Rekommendera Poster

Grimrath

Hej,

 

Jag har stora problem. Jag har windows 10 sen ett par månader tillbaka (uppgraderade ifrån win7). Igår så installerade jag spelet overwatch via battle.net klienten och helt plötsligt så har 'windows installer' börjat använda alla systemresurser vilket resulterar i att datorn låser sig och jag måste starta om (se bifogad bild). Detta tar ofta 5-10minuter ifrån att jag startat datorn.

 

Jag har ingen aning om vad jag ska göra och jag törs inte skriva mer då det bara är en tidsfråga innan datorn fryser och jag tvingas skriva om det här mailet ytterligare en gång.

 

Oerhört tacksam för hjälp!

 

Vänliga hälsningar,

Richard

post-138612-0-62429600-1465921736_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman
Postad (redigerade)

Hej och välkommen till Eforum.

 

Vad har du för dator: fabrikat och modellbeteckning samt stationär eller laptop?

Eller moderkortets tillverkare och modellbeteckning?

Grafikkort: fabrikat och modellbeteckning?

Vilken webbläsare använder du för Battle.net klienten?

 

Jag kollade lite som hastigast på BattleNet forum och det finns flera med liknande problem http://us.battle.net/en/forum/9772479/

Se också detta: https://eu.battle.net/support/en/article/battlenet-lockups-and-crash-errors

 

Kanske du skulle börja med att avinstallera spelet och sedan Bettle.net klienten, därefter så startar du om datorn och kör Windows update:

Start > Inställningar > System och säkerhet > Windows update. Starta om datorn om uppdateringar har installerats.

Därefter så installerar du senaste drivrutiner från dator eller moderkortstillverkaren samt senaste grafikdrivrutin direkt från dess tillverkare.

Starta om datorn.

Prova igen att installera Battle.net klienten samt spelet.

 

Mvh

Redigerad av Flyfisherman
Lagt till sista raden om att installera...

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Grimrath

Tack och tack för svar,

 

Angående dator:

Det är ett ihopplock från 2013 i en stationär dator. Grafikkortet är dock sedan förra året.

PSU: Corsair TX 650W PSU

HDD: Seagate Barracuda 3TB , Kingston HyperX 3k SSD 120GB

MB,Processor,RAM:

MSI Z87-G43, socket-1150

Intel Core i5-4670K 3,4GHz, 6MB, 84W, HD4600

4x Kingston HyperX Genisis 1600MHz 4GB DDR3

GPU: EVGA GeForce GTX 970 4GB

 

Battle.net klienten är ett eget program och så vitt jag vet så använder inte den någon av mina installerade webbläsare. Dock är IE och Firefox de webbläsare som finns installerade. Endast Firefox används.

 

I 9 fall av 10 så startar 'windows installer' direkt då operativsystemet startats och minnesåtgången stiger stadigt mot 12Gb. När den gränsen uppnåtts så fryser datorn och kan endast startas om genom att bryta matningen. I övriga fall så dröjer det uppemot 10-30 minuter innan 'windows installer' startar och samma sak händer. Windows installer använder upp alla resurser oavsett om jag gör någonting eller ingenting alls efter att ha startat och loggat in på datorn.

 

Då battle.net inte ligger i autostart så är alltså den enda gemensamma nämnaren att det sista som jag medvetet installerade var ovan nämnda spel via battle.net klienten.

 

Jag ska avinstallera nämnda program och se till att uppdatera drivrutiner till moderkort, gpu och även se till att win10 uppdateras. Då jag numer inte kan använda datorn mer än i felsäkert läge så bifogar jag även loggar från FRST förra gången jag lyckades hinna göra någonting över huvud taget utanför felsäkert läge innan datorn rös ihop. dessa är bifogade samt inklistrade nedan.

 

Ytterst tacksam för all hjälp! Skulle era instruktioner fungera så återkopplar jag, i övrigt kan ni förutsätta att problematiken kvarstår. :)

FRST.txt

Addition.txt

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Det ser ut som att du installerade Malwarebytes Anti-Malware (MBAM) i måndags. Berodde det på något skadligt program eller reklamprogram?

Det kan i så fall finnas rester kvar som stör Windows.

 

Eller att det är din proxy-inställning som gör det:

ProxyServer: [s-1-5-21-3292367788-2949453755-2887943096-1000] => http=216.228.51.245:28981

Även AVG Web Tuneup kan tänkas ha orsakat något problem.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
vertpre

Om du öppnar Tjänster och letar upp Windows Installer, har du då möjligheten att stoppa tjänsten, för att se om det hjälper?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Grimrath

Hej,

MBAM installerade jag direkt efter att problematiken med 'windows installer' började i tron om att det var något skadligt program som låg bakom. Dock visade scannen 'no threats found'.

Proxy-inställning? Nu är jag inte helt med. Har du möjlighet att expandera lite på det?

Det går inte att stoppa processen msiexec.exe via services. Enda som går att välja innan den startar är just 'starta' efter den väl gjort det så är samtliga val utgråade och ej valbara.

Windows är uppdaterat, drivrutiner för grafikkortet likaså. Drivrutiner till moderkortet vet jag inte var jag ska hitta.
Har avinstallerat AVG tune up men har fortfarande samma problem.

Min mus fungerar inte i felsäkert läge så det är en pina. Skriver alla mina inlägg i ett .txt dokument och startar sedan om datorn tills att jag hinner klistra in det här på eforum innan datorn fryser.
 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman
Drivrutiner till moderkortet vet jag inte var jag ska hitta.

https://www.msi.com/Motherboard/support/Z87-G43.html#down-driver&Win10%2064

 

Har du skrivare/skanner tillkopplad så koppla ur dessa.

Men jag har uppriktigt sagt ingen aning vad som händer hos dig, Allting verkar besynnerligt.

Om det är något skumt med systemfilerna så kör sfc /scannow i felsäkert läge:Guide - SystemFileChecker (SFC) i felsäkertläge på Windows

 

Ja tills antingen Cecilia, vertpre eller någon annan återkommer med ev. idé så får vi se vidare.

Mvh :(

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

För att ta bort inställning för proxy-server:

Kontrollpanelen - Internetalternativ - Anslutningar - LAN-inställningar
Ta bort eventuellt innehåll i rutan Adress
Avbocka "Använd en proxyserver...."

 

Borde gå bra att göra i felsäkert läge även med en mus som inte fungerar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
vertpre

Vad det gäller din mus.

 

Är det en USB mus, prova andra USB uttag.

 

Gå in i bios, brukar vara att trycka på delete vid uppstart, och aktivera USB Legacy Support om det inte är aktiverat. Den borde finnas under menyn Advanced och USB Configuration men eftersom jag aldrig har haft ett MSI moderkort, är jag inte säker. Se om det hjälper.

 

Har du avinstallerat Overwatch?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Grimrath

Nu går det längre tid mellan att msiexec.exe startar och fryser datorn. Efter 3-4 omstarter via reset-knappen så brukar datorn klara sig ett par timmar innan den fryser igen.
Jag har avinstallerat battle.net samt alla spel som går via det programmet. Även lite diverse andra program det egentligen inte finns någon användning för.

Drivrutiner till moderkortet är uppdaterade, Proxyserver är avaktiverad (troligen hamachi som använt detta, vilket också är avinstallerat)
Har även kört sfc /scannow som administratör utanför felsäkert läge så att log kunde bifogas. Den har hittat korrupta filer vilka den inte kunnat reparera.

Problemet kvarstår. Har ni något tips på hur jag går vidare härifrån?

 

sfcdetails.txt
 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

I felsäkert läge kan Sfc /scannow åtgärda fler problem än i normalt läge. Ibland kan man behöva köra Sfc /scannow tre gånger i felsäkert läge innan man vet att programmet har gjort allt det kan.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Grimrath

Hej Cecilia, vertpre och flyfisherman.

Stort tack för er hjälp och ert engagemang.

 

Jag har kört sfc /scannow i felsäkert läge sex gånger efter varandra. Det stod fortfarande att det fanns korrupta filer som inte kunde repareras.

msiexec.exe fryser fortfarande datorn.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Det verkar som att felet som SFC upptäcker är rätt vanligt och inte brukar orsaka något problem.

 

mimimi666 replied on30 November 2015

The correct fix will be to remove wrongly installed and activated by Microsoft wow64_microsoft-windows-r..xwddmdriver-wow64-c_31bf3856ad364e35_10.0.10586.0_none_3dae054b56911c22 directory (Microsoft RemoteFX Display driver, 32bit part, which contains opencl.dll with reduced functionality, which overwrites correct Nvidia/ATI/Intel \SysWoW64\opencl.dll on upgrade or attempt of DISM recover from install.wim) from WinSxS (64bit counterpart is in amd64_rdvgwddmdx11.inf_31bf3856ad364e35_10.0.10586 .0_none_5fcf2a87752df0d7 directory, but is inactive and does no harm). But I know no tool for correct selective remove or deactivate of specific directory from WinSxS. Since \SysWoW64\opencl.dll is hardlink to WinSxS one, attempt to install Nvidia/ATI/Intel driver corrupts two Microsoft opencl.dlls at once (so sfc /scannow fails to recover), and attempt to recover WinSxS one from install.wim damages Nvidia/ATI/Intel display driver's opencl.dll from other hand.

...

mimimi666 replied on6 December 2015

1) To previous posts: as I already say, restoring Microsoft opencl.dll via DISM makes things worse.

 

2) \SysWoW64\opencl.dll related problems are minimal, they are restricted to 32bit applications which directly use OpenCL API only. It is application interface DLL, not a driver part in the strict sense.

http://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/sfc-scannow-report-opencldll-bad/4209b042-1b7b-4fa2-a720-2c0e489d137b

 

Ställ in datorn för en så kallad Clean Boot enligt instruktionen på sidan https://support.microsoft.com/sv-se/kb/929135 (fast det kallas för felsäkert läge men är en annan sak än vad man normalt menar med felsäkert läge).

Se om problemet med att "Windows Installer" tar allt minne då uppstår. Om inte får du aktivera några tjänster och/eller autostartande program i taget tills du kommer fram till vilken tjänst eller vilket program det är som är orsaken. Du kan t ex börja med att aktivera alla tjänster men fortsätta ha de autostartande programmen inaktiverade för att komma fram till om det är en tjänst eller ett program som är orsaken till problemet.
 

Om du redan har någon tjänst eller något program som är inaktiverat behöver du skriva upp den informationen först.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...