Just nu i M3-nätverket
Gå till innehåll

Rekommendera Poster

Hej,

 

Jag skulle behöva hjälp med att få till rätt funktion men en checkbox i excel.

Att skapa den och få den på plats är ju inga konstigheter men jag vill att den ska aktivera en beräkning när den bockas i.

 

Tex att jag skriver in ett värde i cell N55 och sen har en del data i andra celler så ska det i Cell N56 levereras ett resultat av detta om checkboxen är ibockad, annars ska N56 förbli tom. Dvs det går inte bara att gör cell N56 osynlig då den cellen ingår i en summering tillsammans med andra celler.

 

Formlen som beräknas ser ut såhär:

=OM($G55=$B$23;$C$22;OM($G55=$B$24;$C$22;OM($G55=$B$25;$C$22;OM($G55=$B$26;$C$22))))*($C$18-$C$17)*N55

 

Är detta möjligt att lösa?

 

Tacksam för hjälp.

Ola

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Länka kryssrutan till en cell

Om slut din beräkning med

=OM(K1=1;......;"")

där då ..... är din beräkning.

K1 är cellen du länkar din kryssruta till.

 

eller liknande.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Länka kryssrutan till en cell

Om slut din beräkning med

=OM(K1=1;......;"")

där då ..... är din beräkning.

K1 är cellen du länkar din kryssruta till.

 

eller liknande.

Tack, funkar fint. 

Det uppträdde dock en märklig sak. När jag skyddar kalkylbladet så går det inte att bocka i checkboxen trots att jag låst upp både cellen och checkboxen i egenskaperna för den respektive.

Finns det lösning på det också månne?

 

Annars tackar jag för hjälpen jag fått.

 

//Ola

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ta bort skyddet på cellen den där länkad till. Om du inte vill att användaren ska kunna se/ändra den cellen lägg den i en annars tom kolumn och dölj hela kolumnen.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...