Just nu i M3-nätverket
Jump to content

Uppdatering av ClamTK (snabbfråga)


DePhaz

Recommended Posts

Gokväll!

 

Kastar bara in en snabb fråga här (obs, ärligt menad).

 

Skulle bli glad om någon kunde tala om hur jag uppdaterar ClamTK (antivirusmotor och grafiskt gränssnitt) under Linux Mint 13. Har en gång för länge sedan gjort samma sak under Ubuntu men då var det väl mest av en slump att jag lyckades. Vågar inte riktigt lita på att rycktet om Linux som virusfritt så jag vill verkligen uppdatera. Obs, ska terminalen användas så var tydlig  ty jag äro lite ointelligent ;)

 

Tack på förhand. ^_^

Link to comment
Share on other sites

Ber om ursäkt för att mitt inlägg här inte är svar på vad du efterfrågar.

Men jag kollade i Mint-forumet och där hade jag skrivit:

 

Det grafiska gränssnittet ClamTK är segt som attan, och fult. Och visar alltid att uppdatering finns.

samt

..jag såg att ClamAV fick uselt betyg varför jag i stället installerade Bitdefender.

 

Så mitt råd är att överge ClamAV och satsa på Bitdefender.

 

Finns i programförrådet.

 

post-52940-0-68607900-1459275883_thumb.png

Link to comment
Share on other sites

Jag kollade lite (innan jag läst inlägg #5) på alternativ.

Kollade en rapport från AV-Comparative ang."File Detection Test", fast för Windowsprogram (antar jag).

Sedan kollade jag en annan artikel från AV-Comparative ang. antivirus för Linux.

Enligt denna så är det endast Comodo och Sophos som är gratis.

Comodos hemsida lyckades inte ens generera en nerladdningslänk varför jag ratade den. Sophos skulle enligt artikeln bara ha ett webbgränssnitt för vissa inställningar.

Sökningar och uppdateringar skulle då göras från kommandoraden.

 

Tog då fasta på ursprungsfrågan i denna tråd.

Laddade hem ClamAV från dess hemsida (ej programförrådet).

Följde man de medföljande anvisningarna för att konfigurera, kompilera och installera så fick man felmeddelanden.

Installerade då ClamAV via förrådet.

Gränssnittet ClamTK laddade jag ner den senaste, 5.20 och installerade.

 

Fortfarande "fult" och med en del märkliga "effekter":

post-52940-0-97818300-1459438162_thumb.png

 

Dubbelklick på inställningar ger:

post-52940-0-59658800-1459438161_thumb.png

 

Ändrade till:

post-52940-0-45424400-1459438160_thumb.png

 

Klickar man på Update manager får man välja manuell eller automatisk:

post-52940-0-14246900-1459438159_thumb.png

 

Har man valt automatiskt kan man inte uppdatera manuellt:

post-52940-0-02247400-1459438158_thumb.png

 

Är valet manuellt kan man söka manuellt:

post-52940-0-17136500-1459438157_thumb.png

 

post-52940-0-98720600-1459438155_thumb.png

 

 

Enligt inställningarna ska ClamTK själv uppdateras, återstår väl att se...

 

OT: Själv skulle jag vilja ha ett program som kan integreras i min filbläddrare Caja *) så att man med ett högerklick kan kontrollera en fil.

*) Jo, den startar lite snabbare än Krusader som jag egentligen föredrar

Link to comment
Share on other sites

Enligt detta test hamnar ESET högt upp i ranking.

Installerade det, mest på skoj, och kan konstatera att den inte hittar de "hot" som Bitdefender och ClamAV gjorde.

 

Ex. denna:

https://www.virustotal.com/en/file/7e320c27c1fc2a3071d47dc4d0259f27b3f8c1130325f88a102f5b506c66e1fe/analysis/

som faktiskt visar att ESET betraktar det som ett hot.

Men alltså inte min installerade version...

 

Rättelse:

Jag behövde i inställningarna kryssa i att skanning ska innefatta "Potentially unsafe application"

 

../Patch.exe - Win32/HackTool.Patcher.AC potentially unsafe application

 

Link to comment
Share on other sites

Enligt detta test hamnar ESET högt upp i ranking.

Installerade det, mest på skoj, och kan konstatera att den inte hittar de "hot" som Bitdefender och ClamAV gjorde.

 

Ex. denna:

https://www.virustotal.com/en/file/7e320c27c1fc2a3071d47dc4d0259f27b3f8c1130325f88a102f5b506c66e1fe/analysis/

som faktiskt visar att ESET betraktar det som ett hot.

Men alltså inte min installerade version...

 

Rättelse:

Jag behövde i inställningarna kryssa i att skanning ska innefatta "Potentially unsafe application"

 

../Patch.exe - Win32/HackTool.Patcher.AC potentially unsafe application

 

Ja, hack/crack är ju inte precis skadliga program utan vanligen något man väljer själv att använda ;)

Det är väl mest för företag som det är viktigt att sånt inte finns på datorerna, eftersom ledningen vill inte riskera hamna i blåsväder för att en anställd installerar cracks.

Link to comment
Share on other sites

Har inte hunnit med att titta på det (dålig ursäkt) men nu tänkte jag titta på det.

 

Såg att det blivit fler inlägg men tänkte ändå följa min plan att uppdatera Clam. Gick in på: https://code.google.com/archive/p/clamtk/ (dit man länkas från: http://clamtk.sourceforge.net/ ). Visste inte riktigt vad jag skulle göra så jag valde en länkt längre ner på sida och kom till: https://community.linuxmint.com/software/view/clamtk . Försöker jag installera därifrån får jag bara meddelandet att ClamTK redan är intestallerat. I programförrådet hittade jag inget att installera och programmet vägrar uppdatera sig själv trots att det är satt att göra så. Så hur ska jag göra? Känns som man ska köra apt get update någonting men vet inte vad.

Link to comment
Share on other sites

Fel: Dependency is not satisfiable: libgtk2-perl (>= 2:1.241)

 

Samma sak om jag sparar filen eller öppnar paketinstalleraren direkt

Link to comment
Share on other sites

Jag vet inte om detta beror på att du kör en äldre version av Linux Mint men du kan ju testa att installera libgtk2-perl via Pakethanteraren Synaptic

 

post-52940-0-55740900-1459675199_thumb.png

Link to comment
Share on other sites

  • 2 weeks later...

Ursäkta sent svar.

 

Filen du nämnde är enligt pakethanteraren redan installerad. Den "vanliga" filen alltså, inte dokumentationen till den.

Link to comment
Share on other sites

Ingen aning. Så här står det i programhanteraren under "Detaljer" :

 

Version: 2:1.223-1build3

Storlek: 4MB av diskutrymme frigjort

Påverkan på paket clamtk (borttaget), libgtk2-perl (borttaget)

Link to comment
Share on other sites

Ja, då stämmer ju felmeddelandet eftersom

2:1.223 är äldre än

2:1.241

ja, även 2:1.241 är väl för gammal, den måste vara nyare.

Om du tittar i Pakethanteraren Synaptic, som min bild visar, är det möjligen en nyare där?

 

Se

http://www.ubuntuupdates.org/package/core/xenial/universe/base/libgtk2-perl

 

OBS! Möjligen är denna för ny.

 

Här verkar samma version som jag har finnas:

http://packages.ubuntu.com/trusty/libgtk2-perl

Link to comment
Share on other sites

OK, för att slutföra denna uppgift: Hur ska jag uppdatera den? Ska jag skriva något i Terminalen? JAg är urkass på sånt här...

Link to comment
Share on other sites

Med "den" så antar jag att du menar det paket som är för gammalt.
 
Klicka in på nedanstående länk:
http://packages.ubuntu.com/trusty/libgtk2-perl
 
Väl där skrollar du ner till
Download libgtk2-perl
 
och där väljer du att klicka på antingen amd64 eller i386 beroende på om du kör 64- resp.32-bitarssystem. Jag antar du kör 32 varför du väljer i386 vilket är samma som denna länk:
http://packages.ubuntu.com/trusty/i386/libgtk2-perl/download
 
Där får man välja server att hämta från och det spelar nog ingen roll vilken man väljer men jag valde, när jag nu testar, den svenska dvs.

se.archive.ubuntu.com/ubuntu och där själva länken är

http://se.archive.ubuntu.com/ubuntu/pool/universe/libg/libgtk2-perl/libgtk2-perl_1.249-2_i386.deb

 

Välj att spara filen och sedan Öppna med Paketinstalleraren GDebi och där väljer du att Installera.

 

Om allt funkar så har du installerat det paket som behövs för att sedan kunna installera ClamTK enligt inlägg #11

 

Link to comment
Share on other sites

Jag älskar bra förklaringar och detta var en bra förklaring. Men...

 

"Fel: Dependency is not satisfiable: libpango-1.0-0 (>= 1.18.0)" 

 

Tog en annan av filerna, samma fel. :(

Link to comment
Share on other sites

När får du..

"Fel: Dependency is not satisfiable: libpango-1.0-0 (>= 1.18.0)

.. när du prövar med ClamTK igen eller när du ska installera libgtk2-perl?

 

Det blir väl så när man inte installerar via Program- och/eller Pakethanteraren. De ser oftast till att alla beroenden som behövs installeras samtidigt.

 

Det är kanske helt enkelt så att ClamTK 5.20 är för ny för din Mint 13.

Link to comment
Share on other sites

Det blir detta fel i Paketinstalleraren. Jo, det kanske är så att den nya versionen är för ny. Hoppas bara att antivirus definisionerna (stavade säker fel där) uppdateras så jag har någon slags säkerhet i systemet.

Link to comment
Share on other sites

Bara någon gång när jag tänker på det (är väl lite slö av mig). Skullnaden mellan Ubuntu och Mint är att det tidigare själv säger till när det finns uppdaterigar, i Mint måste man titta efter själv mer eller mindre. Clam är dock inställt så att det ska uppdatera sina databas varje dag klockan 18 så jag försöker ha datorn igång då.

Link to comment
Share on other sites

 

i Mint måste man titta efter själv mer eller mindre.

Nja, man få hålla koll på om ikonen för Uppdateringshanteraren ändras från en grön bock till en blå symbol med ett utropstecken.

post-52940-0-72236100-1461162540.png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...