Just nu i M3-nätverket
Jump to content

strul med index


Rino74

Recommended Posts

Hej

 

Vore tacksam för lite hjälp, kört fast i formeln,

bifogar även fil för att underlätta förståelsen ;)

 

Skulle vilja lista ut placeringarna av de  de högsta tal i en lista

baserat på dels MAX som anger högsta nr och ANTAL.OM som ger antalet högsta nr det finns i vardera rad.

 

Hittade en typ av INDEX formel på engelsk sida, som skulle utföra det jobbet, men icke. (japp jag har översatt formeln till svensk Excel).

 

det låter kanske rörigt men hoppas det klarnar om ni kollar filen

(se bifogad fil)

Test.xlsx

Link to comment
Share on other sites

Var hittade du formeln. Nu finns det en cirklerefens i den som troligen inte ska vara där.

 

Hur man löser detta med en formel i en cell vet jag inte så jag är lite nyfiken. Med stödceller kan jag ordna det.

Link to comment
Share on other sites

hittade den här

http://stackoverflow.com/questions/18528624/extracting-the-top-5-maximum-values-in-excel

 

=INDEX($B$2:$B$28,MATCH(1,INDEX(($A$2:$A$28=LARGE($A$2:$A$28,ROWS(D$1:D1)))*(COUNTIF(D$1:D1,$B$2:$B$28)=0),),0))

 

som jag förstod så skulle man få excel till att lista ut cell information till andra celler och i sortering störst-lägst baserad på resultat, men jag vet oxå att engelska formler skiljer sig med svenska så jag kan ha översatt den felaktigt

 

har försökt även och byta ut RAD mot KOLUMN men då det inte gjorde skillnad (eftersom det dom visar går vertikalt och jag vill ha mitt horisontalt)

Link to comment
Share on other sites

=OM(KOLUMNER($M3:M3)>$L3;"";INDEX($A$3:$A$32;PASSA(1;INDEX((B$3:B$32=$K3)*(RADER($A$3:$A$32)>0););0)))

ska fungera på din första rad i din tabell. 

 

Du får uppdatera referensen b3:B32 till kolumn C manuellt på rad 2 osv.

 

Har förenklat den lite. Det du missade på var att ROWS är RADER, dvs det du  skulle använd KOLUMNER.

 

Omslutet med en OM-sats som ser till att bara givet antal värden hämtas samt tagit bort/bytt ut ANTAL.OM på slutet till en annan funktion som ger samma effekt, nämligen ger att INDEX returnerar en vektor istället för normalt ett enda värde.

Link to comment
Share on other sites

Kanon, tack för hjälpen, har fyllat i och justerat ref till rätt celler, men han listar inte siffrorna rätt?

 

Den första cell raden stämmer men efterkommande är lite fel tyvärr...Mysko

 

bifogar filen igen med rätt ifyllt så du ser

 

Test.xlsx

Link to comment
Share on other sites

Min förenkling av formeln ställde till, jag har lärt mig ett nytt sätt att använda ANTAL.OM

 

=OM(KOLUMNER($M3:M3)>$L3;"";INDEX($A$3:$A$32;PASSA(1;INDEX(($B$3:$B$32=$K3)*(ANTAL.OM($M3:M3;$A$3:$A$32)=0););0)))

i första cellen, kopiera åt höger.

När du kopierar nedåt, uppdatera referensen till B-kolumnen.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...